dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
* Include request for reset-rework branch v3
@ 2012-05-02  4:00 j.glisse
  2012-05-02  4:00 ` [PATCH 01/13] drm/radeon: make radeon_gpu_is_lockup a per ring function j.glisse
                   ` (13 more replies)
  0 siblings, 14 replies; 21+ messages in thread
From: j.glisse @ 2012-05-02  4:00 UTC (permalink / raw)
  To: dri-devel

Ok so i reread stuff and the :
drm/radeon: add general purpose fence signaled callback
is a big NAK actually. It change the paradigm. Moving most of
the handling into the irq process which is something i am intimatly
convinced we should avoid.

Here is the patchset up to ib pool cleanup. I have yet rebase the
other patches as i am tracking done some issue in the sa allocation.

Cheers,
Jerome

^ permalink raw reply	[flat|nested] 21+ messages in thread
* Reworking of GPU reset logic
@ 2012-04-19 22:39 Christian König
  2012-04-19 22:39 ` [PATCH 01/13] drm/radeon: make radeon_gpu_is_lockup a per ring function Christian König
  0 siblings, 1 reply; 21+ messages in thread
From: Christian König @ 2012-04-19 22:39 UTC (permalink / raw)
  To: dri-devel

This includes mostly fixes for multi ring lockups and GPU resets, but it should general improve the behavior of the kernel mode driver in case something goes badly wrong.

On the other hand it completely rewrites the IB pool and semaphore handling, so I think there are still a couple of problems in it.

The first four patches were already send to the list, but the current set depends on them so I resend them again.

Cheers,
Christian.

^ permalink raw reply	[flat|nested] 21+ messages in thread

end of thread, other threads:[~2012-05-02 16:26 UTC | newest]

Thread overview: 21+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2012-05-02  4:00 Include request for reset-rework branch v3 j.glisse
2012-05-02  4:00 ` [PATCH 01/13] drm/radeon: make radeon_gpu_is_lockup a per ring function j.glisse
2012-05-02  4:00 ` [PATCH 02/13] drm/radeon: replace gpu_lockup with ring->ready flag j.glisse
2012-05-02  4:00 ` [PATCH 03/13] drm/radeon: register ring debugfs handlers on init j.glisse
2012-05-02  4:00 ` [PATCH 04/13] drm/radeon: use central function for IB testing j.glisse
2012-05-02  4:00 ` [PATCH 05/13] drm/radeon: rework gpu lockup detection and processing j.glisse
2012-05-02  4:00 ` [PATCH 06/13] drm/radeon: fix a bug in the SA code j.glisse
2012-05-02  4:00 ` [PATCH 07/13] drm/radeon: add proper locking to the SA j.glisse
2012-05-02  4:00 ` [PATCH 08/13] drm/radeon: add sub allocator debugfs file j.glisse
2012-05-02  4:00 ` [PATCH 09/13] drm/radeon: improve sa allocator v2 j.glisse
2012-05-02  4:00 ` [PATCH 10/13] drm/radeon: return -ENOENT in fence_wait_next v2 j.glisse
2012-05-02  4:00 ` [PATCH 11/13] drm/radeon: rename fence_wait_last to fence_wait_empty j.glisse
2012-05-02  4:00 ` [PATCH 12/13] drm/radeon: don't keep list of created fences j.glisse
2012-05-02  4:00 ` [PATCH 13/13] drm/radeon: add fence and retry to sa allocator v2 j.glisse
2012-05-02  4:04 ` Include request for reset-rework branch v3 Jerome Glisse
2012-05-02  9:04   ` Christian König
2012-05-02 10:32     ` Dave Airlie
2012-05-02 11:25       ` Christian König
2012-05-02 14:07         ` Jerome Glisse
2012-05-02 16:26     ` Alex Deucher
  -- strict thread matches above, loose matches on Subject: below --
2012-04-19 22:39 Reworking of GPU reset logic Christian König
2012-04-19 22:39 ` [PATCH 01/13] drm/radeon: make radeon_gpu_is_lockup a per ring function Christian König

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox