dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: David Herrmann <dh.herrmann@gmail.com>
To: dri-devel@lists.freedesktop.org
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
Subject: [PATCH 04/20] drm: move "struct drm_magic_entry" to drm_auth.c
Date: Fri, 29 Aug 2014 12:12:30 +0200	[thread overview]
Message-ID: <1409307166-12396-5-git-send-email-dh.herrmann@gmail.com> (raw)
In-Reply-To: <1409307166-12396-1-git-send-email-dh.herrmann@gmail.com>

In drm_release(), we currently call drm_remove_magic() if the drm_file
has a drm-magic attached. Therefore, once drm_master_release() is called,
the magic-list _must_ be empty.

By dropping the no-op cleanup, we can move "struct drm_magic_entry" to
drm_auth.c and avoid exposing it to all of DRM.

Signed-off-by: David Herrmann <dh.herrmann@gmail.com>
---
 drivers/gpu/drm/drm_auth.c | 6 ++++++
 drivers/gpu/drm/drm_drv.c  | 7 -------
 include/drm/drmP.h         | 6 ------
 3 files changed, 6 insertions(+), 13 deletions(-)

diff --git a/drivers/gpu/drm/drm_auth.c b/drivers/gpu/drm/drm_auth.c
index 3cedae1..708a204 100644
--- a/drivers/gpu/drm/drm_auth.c
+++ b/drivers/gpu/drm/drm_auth.c
@@ -35,6 +35,12 @@
 
 #include <drm/drmP.h>
 
+struct drm_magic_entry {
+	struct list_head head;
+	struct drm_hash_item hash_item;
+	struct drm_file *priv;
+};
+
 /**
  * Find the file with the given magic number.
  *
diff --git a/drivers/gpu/drm/drm_drv.c b/drivers/gpu/drm/drm_drv.c
index b1587e2..6645669 100644
--- a/drivers/gpu/drm/drm_drv.c
+++ b/drivers/gpu/drm/drm_drv.c
@@ -133,7 +133,6 @@ EXPORT_SYMBOL(drm_master_get);
 static void drm_master_destroy(struct kref *kref)
 {
 	struct drm_master *master = container_of(kref, struct drm_master, refcount);
-	struct drm_magic_entry *pt, *next;
 	struct drm_device *dev = master->minor->dev;
 	struct drm_map_list *r_list, *list_temp;
 
@@ -154,12 +153,6 @@ static void drm_master_destroy(struct kref *kref)
 		master->unique_len = 0;
 	}
 
-	list_for_each_entry_safe(pt, next, &master->magicfree, head) {
-		list_del(&pt->head);
-		drm_ht_remove_item(&master->magiclist, &pt->hash_item);
-		kfree(pt);
-	}
-
 	drm_ht_remove(&master->magiclist);
 
 	mutex_unlock(&dev->struct_mutex);
diff --git a/include/drm/drmP.h b/include/drm/drmP.h
index 11c3575..0fdd813 100644
--- a/include/drm/drmP.h
+++ b/include/drm/drmP.h
@@ -290,12 +290,6 @@ struct drm_ioctl_desc {
 #define DRM_IOCTL_DEF_DRV(ioctl, _func, _flags)			\
 	[DRM_IOCTL_NR(DRM_##ioctl)] = {.cmd = DRM_##ioctl, .func = _func, .flags = _flags, .cmd_drv = DRM_IOCTL_##ioctl, .name = #ioctl}
 
-struct drm_magic_entry {
-	struct list_head head;
-	struct drm_hash_item hash_item;
-	struct drm_file *priv;
-};
-
 /**
  * DMA buffer.
  */
-- 
2.1.0

  parent reply	other threads:[~2014-08-29 10:13 UTC|newest]

Thread overview: 53+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-08-29 10:12 [PATCH 00/20] DRM: Core Cleanups David Herrmann
2014-08-29 10:12 ` [PATCH 01/20] drm/radeon: move drm_buffer to drm/radeon/ David Herrmann
2014-08-29 11:20   ` Thierry Reding
2014-09-08  4:08   ` Alex Deucher
2014-08-29 10:12 ` [PATCH 02/20] drm: mark drm_buf and drm_map as legacy David Herrmann
2014-08-29 11:32   ` Thierry Reding
2014-08-29 10:12 ` [PATCH 03/20] drm: move "struct drm_vma_entry" to drm_vm.c David Herrmann
2014-08-29 11:34   ` Thierry Reding
2014-08-29 10:12 ` David Herrmann [this message]
2014-08-29 11:39   ` [PATCH 04/20] drm: move "struct drm_magic_entry" to drm_auth.c Thierry Reding
2014-08-29 10:12 ` [PATCH 05/20] drm: drop unused "struct drm_waitlist" David Herrmann
2014-08-29 11:40   ` Thierry Reding
2014-08-29 10:12 ` [PATCH 06/20] drm: move AGP definitions harder David Herrmann
2014-08-29 11:43   ` Thierry Reding
2014-08-29 12:39     ` Daniel Vetter
2014-08-29 10:12 ` [PATCH 07/20] drm: replace weird conditional includes David Herrmann
2014-08-29 11:45   ` Thierry Reding
2014-08-29 10:12 ` [PATCH 08/20] drm: drop __KERNEL__ protection in drmP.h David Herrmann
2014-08-29 11:46   ` Thierry Reding
2014-08-29 10:12 ` [PATCH 09/20] drm: merge drm_memory.h into drm_memory.c David Herrmann
2014-08-29 11:56   ` Thierry Reding
2014-08-29 12:43     ` Daniel Vetter
2014-08-29 13:26       ` Thierry Reding
2014-08-29 10:12 ` [PATCH 10/20] drm: move __OS_HAS_AGP into drm_agpsupport.h David Herrmann
2014-08-29 12:03   ` Thierry Reding
2014-08-29 12:45     ` Daniel Vetter
2014-08-29 10:12 ` [PATCH 11/20] drm: order includes alphabetically in drmP.h David Herrmann
2014-08-29 12:05   ` Thierry Reding
2014-08-29 10:12 ` [PATCH 12/20] drm: drop DRM_DEBUG_CODE David Herrmann
2014-08-29 12:10   ` Thierry Reding
2014-08-29 10:12 ` [PATCH 13/20] drm: inline "struct drm_sigdata" David Herrmann
2014-08-29 12:21   ` Thierry Reding
2014-08-29 10:12 ` [PATCH 14/20] drm: move remaining includes in drmP.h to the top David Herrmann
2014-08-29 12:26   ` Thierry Reding
2014-08-29 10:12 ` [PATCH 15/20] drm: simplify drm_*_set_unique() David Herrmann
2014-08-29 12:39   ` Thierry Reding
2014-08-29 12:58   ` Daniel Vetter
2014-08-29 10:12 ` [PATCH 16/20] drm: drop unused drm_master->unique_size David Herrmann
2014-08-29 12:41   ` Thierry Reding
2014-08-29 12:58   ` Daniel Vetter
2014-08-29 10:12 ` [PATCH 17/20] drm: add driver->set_busid() callback David Herrmann
2014-08-29 12:54   ` Thierry Reding
2014-08-29 13:01   ` Daniel Vetter
2014-08-29 13:30     ` Thierry Reding
2014-08-29 10:12 ` [PATCH 18/20] drm: Goody bye, drm_bus! David Herrmann
2014-08-29 12:55   ` Thierry Reding
2014-08-29 13:02   ` Daniel Vetter
2014-08-29 10:12 ` [PATCH 19/20] drm: merge drm_usb into udl David Herrmann
2014-08-29 13:00   ` Thierry Reding
2014-08-29 13:06   ` Daniel Vetter
2014-08-29 10:12 ` [PATCH 20/20] drm: move drm-lock API to drm_legacy.h David Herrmann
2014-08-29 13:02   ` Thierry Reding
2014-08-29 13:08 ` [PATCH 00/20] DRM: Core Cleanups Daniel Vetter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1409307166-12396-5-git-send-email-dh.herrmann@gmail.com \
    --to=dh.herrmann@gmail.com \
    --cc=daniel.vetter@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox