* [PATCH] drm: Use idr_init_base(1) when using id==0 for invalid
@ 2018-02-12 14:55 Chris Wilson
2018-02-12 17:14 ` Ville Syrjälä
0 siblings, 1 reply; 5+ messages in thread
From: Chris Wilson @ 2018-02-12 14:55 UTC (permalink / raw)
To: dri-devel; +Cc: Daniel Vetter, intel-gfx, Dave Airlie, Christian Konig
Use the new idr_init_base() function to create an IDR that knows id==0
is never allocated as it maps to an invalid identifier. By knowing that
id==0 is invalid, the IDR can start from id=1 instead avoiding the issue
of having to start each lookup from the zeroth leaf as id==0 is always
unused (and thus the tree-of-bitmaps indicate that is the first
available).
References: 6ce711f27500 ("idr: Make 1-based IDRs more efficient")
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
Cc: Christian Konig <christian.koenig@amd.com>
Cc: Dave Airlie <airlied@redhat.com>
---
Note this requires 4.16-rc1.
---
drivers/gpu/drm/drm_gem.c | 4 ++--
drivers/gpu/drm/drm_syncobj.c | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/drm_gem.c b/drivers/gpu/drm/drm_gem.c
index 01f8d9481211..4975ba9a7bc8 100644
--- a/drivers/gpu/drm/drm_gem.c
+++ b/drivers/gpu/drm/drm_gem.c
@@ -98,7 +98,7 @@ drm_gem_init(struct drm_device *dev)
struct drm_vma_offset_manager *vma_offset_manager;
mutex_init(&dev->object_name_lock);
- idr_init(&dev->object_name_idr);
+ idr_init_base(&dev->object_name_idr, 1);
vma_offset_manager = kzalloc(sizeof(*vma_offset_manager), GFP_KERNEL);
if (!vma_offset_manager) {
@@ -776,7 +776,7 @@ drm_gem_open_ioctl(struct drm_device *dev, void *data,
void
drm_gem_open(struct drm_device *dev, struct drm_file *file_private)
{
- idr_init(&file_private->object_idr);
+ idr_init_base(&file_private->object_idr, 1);
spin_lock_init(&file_private->table_lock);
}
diff --git a/drivers/gpu/drm/drm_syncobj.c b/drivers/gpu/drm/drm_syncobj.c
index 0b7b0d1ad2d5..d4f4ce484529 100644
--- a/drivers/gpu/drm/drm_syncobj.c
+++ b/drivers/gpu/drm/drm_syncobj.c
@@ -546,7 +546,7 @@ static int drm_syncobj_export_sync_file(struct drm_file *file_private,
void
drm_syncobj_open(struct drm_file *file_private)
{
- idr_init(&file_private->syncobj_idr);
+ idr_init_base(&file_private->syncobj_idr, 1);
spin_lock_init(&file_private->syncobj_table_lock);
}
--
2.16.1
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
^ permalink raw reply related [flat|nested] 5+ messages in thread* Re: [PATCH] drm: Use idr_init_base(1) when using id==0 for invalid
2018-02-12 14:55 [PATCH] drm: Use idr_init_base(1) when using id==0 for invalid Chris Wilson
@ 2018-02-12 17:14 ` Ville Syrjälä
2018-02-13 13:48 ` Christian König
0 siblings, 1 reply; 5+ messages in thread
From: Ville Syrjälä @ 2018-02-12 17:14 UTC (permalink / raw)
To: Chris Wilson
Cc: Daniel Vetter, intel-gfx, Christian Konig, dri-devel, Dave Airlie
On Mon, Feb 12, 2018 at 02:55:33PM +0000, Chris Wilson wrote:
> Use the new idr_init_base() function to create an IDR that knows id==0
> is never allocated as it maps to an invalid identifier. By knowing that
> id==0 is invalid, the IDR can start from id=1 instead avoiding the issue
> of having to start each lookup from the zeroth leaf as id==0 is always
> unused (and thus the tree-of-bitmaps indicate that is the first
> available).
>
> References: 6ce711f27500 ("idr: Make 1-based IDRs more efficient")
> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
> Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
> Cc: Christian Konig <christian.koenig@amd.com>
> Cc: Dave Airlie <airlied@redhat.com>
Yep, looks like all of these pass start==1 to idr_alloc().
Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
Looks like at least tile_idr and crtc_idr could use this as well,
although I suppose they're not hit nearly as hard as the gem stuff.
Also someone should really s/crtc_idr/obj_id_idr/ or something
along those lines.
> ---
> Note this requires 4.16-rc1.
> ---
> drivers/gpu/drm/drm_gem.c | 4 ++--
> drivers/gpu/drm/drm_syncobj.c | 2 +-
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_gem.c b/drivers/gpu/drm/drm_gem.c
> index 01f8d9481211..4975ba9a7bc8 100644
> --- a/drivers/gpu/drm/drm_gem.c
> +++ b/drivers/gpu/drm/drm_gem.c
> @@ -98,7 +98,7 @@ drm_gem_init(struct drm_device *dev)
> struct drm_vma_offset_manager *vma_offset_manager;
>
> mutex_init(&dev->object_name_lock);
> - idr_init(&dev->object_name_idr);
> + idr_init_base(&dev->object_name_idr, 1);
>
> vma_offset_manager = kzalloc(sizeof(*vma_offset_manager), GFP_KERNEL);
> if (!vma_offset_manager) {
> @@ -776,7 +776,7 @@ drm_gem_open_ioctl(struct drm_device *dev, void *data,
> void
> drm_gem_open(struct drm_device *dev, struct drm_file *file_private)
> {
> - idr_init(&file_private->object_idr);
> + idr_init_base(&file_private->object_idr, 1);
> spin_lock_init(&file_private->table_lock);
> }
>
> diff --git a/drivers/gpu/drm/drm_syncobj.c b/drivers/gpu/drm/drm_syncobj.c
> index 0b7b0d1ad2d5..d4f4ce484529 100644
> --- a/drivers/gpu/drm/drm_syncobj.c
> +++ b/drivers/gpu/drm/drm_syncobj.c
> @@ -546,7 +546,7 @@ static int drm_syncobj_export_sync_file(struct drm_file *file_private,
> void
> drm_syncobj_open(struct drm_file *file_private)
> {
> - idr_init(&file_private->syncobj_idr);
> + idr_init_base(&file_private->syncobj_idr, 1);
> spin_lock_init(&file_private->syncobj_table_lock);
> }
>
> --
> 2.16.1
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel
--
Ville Syrjälä
Intel OTC
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
^ permalink raw reply [flat|nested] 5+ messages in thread* Re: [PATCH] drm: Use idr_init_base(1) when using id==0 for invalid
2018-02-12 17:14 ` Ville Syrjälä
@ 2018-02-13 13:48 ` Christian König
2018-02-19 14:35 ` Chris Wilson
0 siblings, 1 reply; 5+ messages in thread
From: Christian König @ 2018-02-13 13:48 UTC (permalink / raw)
To: Ville Syrjälä, Chris Wilson
Cc: Daniel Vetter, intel-gfx, dri-devel, Dave Airlie
Am 12.02.2018 um 18:14 schrieb Ville Syrjälä:
> On Mon, Feb 12, 2018 at 02:55:33PM +0000, Chris Wilson wrote:
>> Use the new idr_init_base() function to create an IDR that knows id==0
>> is never allocated as it maps to an invalid identifier. By knowing that
>> id==0 is invalid, the IDR can start from id=1 instead avoiding the issue
>> of having to start each lookup from the zeroth leaf as id==0 is always
>> unused (and thus the tree-of-bitmaps indicate that is the first
>> available).
>>
>> References: 6ce711f27500 ("idr: Make 1-based IDRs more efficient")
>> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
>> Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
>> Cc: Christian Konig <christian.koenig@amd.com>
>> Cc: Dave Airlie <airlied@redhat.com>
> Yep, looks like all of these pass start==1 to idr_alloc().
> Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
Acked-by: Christian König <christian.koenig@amd.com> as well.
Probably going to do this for the command submission context handles in
amdgpu as well.
Thanks,
Christian.
>
> Looks like at least tile_idr and crtc_idr could use this as well,
> although I suppose they're not hit nearly as hard as the gem stuff.
> Also someone should really s/crtc_idr/obj_id_idr/ or something
> along those lines.
>
>> ---
>> Note this requires 4.16-rc1.
>> ---
>> drivers/gpu/drm/drm_gem.c | 4 ++--
>> drivers/gpu/drm/drm_syncobj.c | 2 +-
>> 2 files changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/drm_gem.c b/drivers/gpu/drm/drm_gem.c
>> index 01f8d9481211..4975ba9a7bc8 100644
>> --- a/drivers/gpu/drm/drm_gem.c
>> +++ b/drivers/gpu/drm/drm_gem.c
>> @@ -98,7 +98,7 @@ drm_gem_init(struct drm_device *dev)
>> struct drm_vma_offset_manager *vma_offset_manager;
>>
>> mutex_init(&dev->object_name_lock);
>> - idr_init(&dev->object_name_idr);
>> + idr_init_base(&dev->object_name_idr, 1);
>>
>> vma_offset_manager = kzalloc(sizeof(*vma_offset_manager), GFP_KERNEL);
>> if (!vma_offset_manager) {
>> @@ -776,7 +776,7 @@ drm_gem_open_ioctl(struct drm_device *dev, void *data,
>> void
>> drm_gem_open(struct drm_device *dev, struct drm_file *file_private)
>> {
>> - idr_init(&file_private->object_idr);
>> + idr_init_base(&file_private->object_idr, 1);
>> spin_lock_init(&file_private->table_lock);
>> }
>>
>> diff --git a/drivers/gpu/drm/drm_syncobj.c b/drivers/gpu/drm/drm_syncobj.c
>> index 0b7b0d1ad2d5..d4f4ce484529 100644
>> --- a/drivers/gpu/drm/drm_syncobj.c
>> +++ b/drivers/gpu/drm/drm_syncobj.c
>> @@ -546,7 +546,7 @@ static int drm_syncobj_export_sync_file(struct drm_file *file_private,
>> void
>> drm_syncobj_open(struct drm_file *file_private)
>> {
>> - idr_init(&file_private->syncobj_idr);
>> + idr_init_base(&file_private->syncobj_idr, 1);
>> spin_lock_init(&file_private->syncobj_table_lock);
>> }
>>
>> --
>> 2.16.1
>>
>> _______________________________________________
>> dri-devel mailing list
>> dri-devel@lists.freedesktop.org
>> https://lists.freedesktop.org/mailman/listinfo/dri-devel
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
^ permalink raw reply [flat|nested] 5+ messages in thread* Re: [PATCH] drm: Use idr_init_base(1) when using id==0 for invalid
2018-02-13 13:48 ` Christian König
@ 2018-02-19 14:35 ` Chris Wilson
2018-02-19 14:50 ` Daniel Vetter
0 siblings, 1 reply; 5+ messages in thread
From: Chris Wilson @ 2018-02-19 14:35 UTC (permalink / raw)
To: Christian König, Ville Syrjälä
Cc: Daniel Vetter, intel-gfx, dri-devel, Dave Airlie
Quoting Christian König (2018-02-13 13:48:24)
> Am 12.02.2018 um 18:14 schrieb Ville Syrjälä:
> > On Mon, Feb 12, 2018 at 02:55:33PM +0000, Chris Wilson wrote:
> >> Use the new idr_init_base() function to create an IDR that knows id==0
> >> is never allocated as it maps to an invalid identifier. By knowing that
> >> id==0 is invalid, the IDR can start from id=1 instead avoiding the issue
> >> of having to start each lookup from the zeroth leaf as id==0 is always
> >> unused (and thus the tree-of-bitmaps indicate that is the first
> >> available).
> >>
> >> References: 6ce711f27500 ("idr: Make 1-based IDRs more efficient")
> >> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
> >> Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
> >> Cc: Christian Konig <christian.koenig@amd.com>
> >> Cc: Dave Airlie <airlied@redhat.com>
> > Yep, looks like all of these pass start==1 to idr_alloc().
> > Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
>
> Acked-by: Christian König <christian.koenig@amd.com> as well.
>
> Probably going to do this for the command submission context handles in
> amdgpu as well.
Thanks for the review, pushed to drm-misc-next.
As noted, there are probably quite a few more idr's that we can move
over to idr_init_base(1), e.g. the KMS objects. If someone feels like a
small task?
-Chris
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
^ permalink raw reply [flat|nested] 5+ messages in thread* Re: [PATCH] drm: Use idr_init_base(1) when using id==0 for invalid
2018-02-19 14:35 ` Chris Wilson
@ 2018-02-19 14:50 ` Daniel Vetter
0 siblings, 0 replies; 5+ messages in thread
From: Daniel Vetter @ 2018-02-19 14:50 UTC (permalink / raw)
To: Chris Wilson
Cc: Daniel Vetter, intel-gfx, dri-devel, Dave Airlie,
Christian König
On Mon, Feb 19, 2018 at 02:35:38PM +0000, Chris Wilson wrote:
> Quoting Christian König (2018-02-13 13:48:24)
> > Am 12.02.2018 um 18:14 schrieb Ville Syrjälä:
> > > On Mon, Feb 12, 2018 at 02:55:33PM +0000, Chris Wilson wrote:
> > >> Use the new idr_init_base() function to create an IDR that knows id==0
> > >> is never allocated as it maps to an invalid identifier. By knowing that
> > >> id==0 is invalid, the IDR can start from id=1 instead avoiding the issue
> > >> of having to start each lookup from the zeroth leaf as id==0 is always
> > >> unused (and thus the tree-of-bitmaps indicate that is the first
> > >> available).
> > >>
> > >> References: 6ce711f27500 ("idr: Make 1-based IDRs more efficient")
> > >> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
> > >> Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
> > >> Cc: Christian Konig <christian.koenig@amd.com>
> > >> Cc: Dave Airlie <airlied@redhat.com>
> > > Yep, looks like all of these pass start==1 to idr_alloc().
> > > Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
> >
> > Acked-by: Christian König <christian.koenig@amd.com> as well.
> >
> > Probably going to do this for the command submission context handles in
> > amdgpu as well.
>
> Thanks for the review, pushed to drm-misc-next.
>
> As noted, there are probably quite a few more idr's that we can move
> over to idr_init_base(1), e.g. the KMS objects. If someone feels like a
> small task?
I'll type a todo.rst patch.
-Daniel
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
^ permalink raw reply [flat|nested] 5+ messages in thread
end of thread, other threads:[~2018-02-19 14:50 UTC | newest]
Thread overview: 5+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2018-02-12 14:55 [PATCH] drm: Use idr_init_base(1) when using id==0 for invalid Chris Wilson
2018-02-12 17:14 ` Ville Syrjälä
2018-02-13 13:48 ` Christian König
2018-02-19 14:35 ` Chris Wilson
2018-02-19 14:50 ` Daniel Vetter
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox