dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: David Herrmann <dh.herrmann@gmail.com>
To: dri-devel@lists.freedesktop.org
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
Subject: [PATCH 0/8] DRM File Context Cleanups
Date: Wed,  3 Aug 2016 20:04:24 +0200	[thread overview]
Message-ID: <20160803180432.1341-1-dh.herrmann@gmail.com> (raw)

Hi

Some rather random cleanups on drm_file and whatever I found on the way. The
idea here really is to get to a point where we can allocate drm_file from a
kernel context to get in-kernel rendering to work. This would allow allocating
dumb-buffers, dma-bufs, etc. from within the kernel and get fbdev generically
working, as well as panic renderers et al.

The only critical thing is drm_file->filp, which points to the underlying
"struct file". We really don't want to fake a "struct file" for in-kernel
renderers (even though it is possible), so this series tries to get rid of all
non-legacy users of it. The only real place left is vm_mmap() in drm_bufs.c.

Tested on i915 only.

Thanks
David

David Herrmann (8):
  drm: rename DRM_MINOR_LEGACY to DRM_MINOR_PRIMARY
  drm: remove redundant drm_file->uid
  drm: reduce GETCLIENT to a minimum
  drm: make vma-manager entries untyped
  drm: use drm_file to tag vm-bos
  drm: use priv->pid to deduce task EUID
  drm: rename drm_file.filp to drm_file.legacy_filp
  drm: provide management functions for drm_file

 drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c |   3 +-
 drivers/gpu/drm/ast/ast_ttm.c           |   3 +-
 drivers/gpu/drm/bochs/bochs_mm.c        |   3 +-
 drivers/gpu/drm/cirrus/cirrus_ttm.c     |   3 +-
 drivers/gpu/drm/drm_bufs.c              |   7 +-
 drivers/gpu/drm/drm_drv.c               | 149 ++++++++++++++++++++++++++++++--
 drivers/gpu/drm/drm_fops.c              | 133 ++--------------------------
 drivers/gpu/drm/drm_gem.c               |   8 +-
 drivers/gpu/drm/drm_info.c              |   4 +-
 drivers/gpu/drm/drm_internal.h          |   4 +
 drivers/gpu/drm/drm_ioctl.c             |   5 +-
 drivers/gpu/drm/drm_vma_manager.c       |  40 ++++-----
 drivers/gpu/drm/mgag200/mgag200_ttm.c   |   3 +-
 drivers/gpu/drm/nouveau/nouveau_bo.c    |   3 +-
 drivers/gpu/drm/qxl/qxl_ttm.c           |   3 +-
 drivers/gpu/drm/radeon/radeon_ttm.c     |   3 +-
 include/drm/drmP.h                      |   7 +-
 include/drm/drm_vma_manager.h           |  18 ++--
 18 files changed, 213 insertions(+), 186 deletions(-)

-- 
2.9.2

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

             reply	other threads:[~2016-08-03 18:04 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-08-03 18:04 David Herrmann [this message]
2016-08-03 18:04 ` [PATCH 1/8] drm: rename DRM_MINOR_LEGACY to DRM_MINOR_PRIMARY David Herrmann
2016-08-04  7:45   ` Frank Binns
2016-08-04  8:16     ` Daniel Vetter
2016-08-03 18:04 ` [PATCH 2/8] drm: remove redundant drm_file->uid David Herrmann
2016-08-03 18:57   ` Chris Wilson
2016-08-03 19:01   ` Chris Wilson
2016-08-04  8:29     ` David Herrmann
2016-08-03 18:04 ` [PATCH 3/8] drm: reduce GETCLIENT to a minimum David Herrmann
2016-08-03 18:04 ` [PATCH 4/8] drm: make vma-manager entries untyped David Herrmann
2016-08-03 18:51   ` Chris Wilson
2016-08-04  9:29   ` Emil Velikov
2016-08-03 18:04 ` [PATCH 5/8] drm: use drm_file to tag vm-bos David Herrmann
2016-08-03 19:08   ` Chris Wilson
2016-08-04  8:16     ` Daniel Vetter
2016-08-04  8:30       ` David Herrmann
2016-08-03 18:04 ` [PATCH 6/8] drm: use priv->pid to deduce task EUID David Herrmann
2016-08-03 18:58   ` Chris Wilson
2016-08-03 18:04 ` [PATCH 7/8] drm: rename drm_file.filp to drm_file.legacy_filp David Herrmann
2016-08-03 18:04 ` [PATCH 8/8] drm: provide management functions for drm_file David Herrmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160803180432.1341-1-dh.herrmann@gmail.com \
    --to=dh.herrmann@gmail.com \
    --cc=daniel.vetter@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox