From: Daniel Vetter <daniel@ffwll.ch>
To: Chris Wilson <chris@chris-wilson.co.uk>,
David Herrmann <dh.herrmann@gmail.com>,
dri-devel@lists.freedesktop.org,
Daniel Vetter <daniel.vetter@ffwll.ch>
Subject: Re: [PATCH 5/8] drm: use drm_file to tag vm-bos
Date: Thu, 4 Aug 2016 10:16:25 +0200 [thread overview]
Message-ID: <20160804081624.GT6232@phenom.ffwll.local> (raw)
In-Reply-To: <20160803190819.GE12611@nuc-i3427.alporthouse.com>
On Wed, Aug 03, 2016 at 08:08:19PM +0100, Chris Wilson wrote:
> On Wed, Aug 03, 2016 at 08:04:29PM +0200, David Herrmann wrote:
> > Rather than using "struct file*", use "struct drm_file*" as tag VM tag for
> > BOs. This will pave the way for "struct drm_file*" without any "struct
> > file*" back-pointer.
> >
> > Signed-off-by: David Herrmann <dh.herrmann@gmail.com>
>
> Ok, the danger of untyped is having to check each and trying to spot any
> missed conversions.
Hm yeah ... any reason we can't just switch to struct drm_file instead? At
least I can't come up with any other use case where we might supply
something else, and it's always nice to enlist the compiler for a little
bit of help.
-Daniel
>
> Couldn't find a mistake or omission,
> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
> -Chris
>
> --
> Chris Wilson, Intel Open Source Technology Centre
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2016-08-04 8:16 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-03 18:04 [PATCH 0/8] DRM File Context Cleanups David Herrmann
2016-08-03 18:04 ` [PATCH 1/8] drm: rename DRM_MINOR_LEGACY to DRM_MINOR_PRIMARY David Herrmann
2016-08-04 7:45 ` Frank Binns
2016-08-04 8:16 ` Daniel Vetter
2016-08-03 18:04 ` [PATCH 2/8] drm: remove redundant drm_file->uid David Herrmann
2016-08-03 18:57 ` Chris Wilson
2016-08-03 19:01 ` Chris Wilson
2016-08-04 8:29 ` David Herrmann
2016-08-03 18:04 ` [PATCH 3/8] drm: reduce GETCLIENT to a minimum David Herrmann
2016-08-03 18:04 ` [PATCH 4/8] drm: make vma-manager entries untyped David Herrmann
2016-08-03 18:51 ` Chris Wilson
2016-08-04 9:29 ` Emil Velikov
2016-08-03 18:04 ` [PATCH 5/8] drm: use drm_file to tag vm-bos David Herrmann
2016-08-03 19:08 ` Chris Wilson
2016-08-04 8:16 ` Daniel Vetter [this message]
2016-08-04 8:30 ` David Herrmann
2016-08-03 18:04 ` [PATCH 6/8] drm: use priv->pid to deduce task EUID David Herrmann
2016-08-03 18:58 ` Chris Wilson
2016-08-03 18:04 ` [PATCH 7/8] drm: rename drm_file.filp to drm_file.legacy_filp David Herrmann
2016-08-03 18:04 ` [PATCH 8/8] drm: provide management functions for drm_file David Herrmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160804081624.GT6232@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=chris@chris-wilson.co.uk \
--cc=daniel.vetter@ffwll.ch \
--cc=dh.herrmann@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox