From: Daniel Vetter <daniel@ffwll.ch>
To: Sean Paul <seanpaul@chromium.org>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>,
DRI Development <dri-devel@lists.freedesktop.org>,
Daniel Vetter <daniel.vetter@intel.com>
Subject: Re: [PATCH 15/15] drm: drop drmP.h include from drm_crtc.c
Date: Fri, 13 Jul 2018 18:41:08 +0200 [thread overview]
Message-ID: <20180713164108.GE3008@phenom.ffwll.local> (raw)
In-Reply-To: <20180712135133.GY20303@art_vandelay>
On Thu, Jul 12, 2018 at 09:51:33AM -0400, Sean Paul wrote:
> On Mon, Jul 09, 2018 at 10:40:16AM +0200, Daniel Vetter wrote:
> > This is starting to become easy!
> >
> > Note: This needs the patch to move for_each_if from drmP.h to kernel.h
> > or it won't compile.
> >
> > Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
>
> Once for_each_if gets sorted out (however it goes).
Yeah I've left those out for now, will deal with that bikeshed when I'm
back from vacations.
>
> Reviewed-by: Sean Paul <seanpaul@chromium.org>
Thanks a lot for your review, everything except the drmP.h shuffling
patches merged.
Cheers, Daniel
>
> > ---
> > drivers/gpu/drm/drm_crtc.c | 5 ++++-
> > 1 file changed, 4 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> > index a6906c4ab880..30f93e460f4e 100644
> > --- a/drivers/gpu/drm/drm_crtc.c
> > +++ b/drivers/gpu/drm/drm_crtc.c
> > @@ -34,7 +34,7 @@
> > #include <linux/slab.h>
> > #include <linux/export.h>
> > #include <linux/dma-fence.h>
> > -#include <drm/drmP.h>
> > +#include <linux/uaccess.h>
> > #include <drm/drm_crtc.h>
> > #include <drm/drm_edid.h>
> > #include <drm/drm_fourcc.h>
> > @@ -42,6 +42,9 @@
> > #include <drm/drm_atomic.h>
> > #include <drm/drm_auth.h>
> > #include <drm/drm_debugfs_crc.h>
> > +#include <drm/drm_drv.h>
> > +#include <drm/drm_print.h>
> > +#include <drm/drm_file.h>
> >
> > #include "drm_crtc_internal.h"
> > #include "drm_internal.h"
> > --
> > 2.18.0
> >
> > _______________________________________________
> > dri-devel mailing list
> > dri-devel@lists.freedesktop.org
> > https://lists.freedesktop.org/mailman/listinfo/dri-devel
>
> --
> Sean Paul, Software Engineer, Google / Chromium OS
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
prev parent reply other threads:[~2018-07-13 16:41 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-09 8:40 [PATCH 00/15] bunch of kerneldocs polish and related cleanup Daniel Vetter
2018-07-09 8:40 ` [PATCH 01/15] drm: move drv test macros out of drmP.h Daniel Vetter
2018-07-12 13:52 ` Sean Paul
2018-07-09 8:40 ` [PATCH 02/15] drm: Drop drmP.h from drm_connector.c Daniel Vetter
2018-07-12 13:53 ` Sean Paul
2018-07-09 8:40 ` [PATCH 03/15] drm/doc: switch drm_connector_state to inline comments Daniel Vetter
2018-07-12 13:54 ` Sean Paul
2018-07-09 8:40 ` [PATCH 04/15] drm/doc: polish for sturct drm_connector Daniel Vetter
2018-07-12 14:01 ` Sean Paul
2018-07-09 8:40 ` [PATCH 05/15] drm: drop _mode_ from update_edit_property() Daniel Vetter
2018-07-13 14:59 ` Sean Paul
2018-07-13 16:05 ` Daniel Vetter
2018-07-09 8:40 ` [PATCH 06/15] drm: drop _mode_ from drm_mode_connector_attach_encoder Daniel Vetter
2018-07-13 15:01 ` Sean Paul
2018-07-09 8:40 ` [PATCH 07/15] drm: drop _mode_ from remaining connector functions Daniel Vetter
2018-07-13 15:05 ` Sean Paul
2018-07-09 8:40 ` [PATCH 08/15] drm: Switch drm_plane_state to inline kerneldoc style Daniel Vetter
2018-07-13 15:08 ` Sean Paul
2018-07-09 8:40 ` [PATCH 09/15] drm: switch drm_plane to inline comments Daniel Vetter
2018-07-13 15:20 ` Sean Paul
2018-07-09 8:40 ` [PATCH 10/15] drm: drop drmP.h include from drm_plane.c Daniel Vetter
2018-07-13 15:22 ` Sean Paul
2018-07-09 8:40 ` [PATCH 11/15] drm/doc: move struct drm_crtc to in-line comments Daniel Vetter
2018-07-13 15:27 ` Sean Paul
2018-07-09 8:40 ` [PATCH 12/15] drm/doc: Group the fb gem helpers better Daniel Vetter
2018-07-12 12:18 ` Noralf Trønnes
2018-07-09 8:40 ` [PATCH 13/15] drm/doc: Includ drm_of.c helpers Daniel Vetter
2018-07-13 15:28 ` Sean Paul
2018-07-09 8:40 ` [PATCH 14/15] drm/doc: use inline kerneldoc style for drm_crtc_state Daniel Vetter
2018-07-13 15:33 ` Sean Paul
2018-07-09 8:40 ` [PATCH 15/15] drm: drop drmP.h include from drm_crtc.c Daniel Vetter
2018-07-12 13:51 ` Sean Paul
2018-07-13 16:41 ` Daniel Vetter [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180713164108.GE3008@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=daniel.vetter@ffwll.ch \
--cc=daniel.vetter@intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=seanpaul@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox