dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Eric Engestrom <eric.engestrom@intel.com>
To: Harry Wentland <harry.wentland@amd.com>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>,
	Sean Paul <sean@poorly.run>,
	DRI Development <dri-devel@lists.freedesktop.org>,
	Daniel Vetter <daniel.vetter@intel.com>
Subject: Re: [PATCH 20/21] drm/todo: Add some cleanup tasks
Date: Fri, 5 Oct 2018 17:20:02 +0100	[thread overview]
Message-ID: <20181005162002.wt7256zqiduhrz57@intel.com> (raw)
In-Reply-To: <7f615afd-747c-ce97-320a-0ccaa46d412d@amd.com>

On Friday, 2018-10-05 12:07:26 -0400, Harry Wentland wrote:
> On 2018-10-04 04:24 PM, Daniel Vetter wrote:
> > Motivated by review comments from Ville&Sean.
> > 
> > Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> > Cc: Sean Paul <sean@poorly.run>
> > Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
> 
> Acked-by: Harry Wentland <harry.wentland@amd.com>
> 
> Harry
> 
> > ---
> >  Documentation/gpu/todo.rst | 10 ++++++++++
> >  1 file changed, 10 insertions(+)
> > 
> > diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
> > index 77c2b3c25565..5c9d86c962af 100644
> > --- a/Documentation/gpu/todo.rst
> > +++ b/Documentation/gpu/todo.rst
> > @@ -339,6 +339,16 @@ Some of these date from the very introduction of KMS in 2008 ...
> >    leftovers from older (never merged into upstream) KMS designs where modes
> >    where set using their ID, including support to add/remove modes.
> >  
> > +- Make ->funcs and ->helper_private vtables optional. There's a bunch of empty
> > +  function tables in drivers, but before we can remove them we need to make sure
> > +  that all the users in helpers and drivers do correctly check for a NULL
> > +  vtable.
> > +
> > +- Cleanup up the various ->destroy callbacks. A lot of them just wrapt the

small typo: s/wrapt/wrap/

> > +  drm_*_cleanup implementations and can be removed. Some tack a kfree() at the
> > +  end, for which we could add drm_*_cleanup_kfree(). And then there's the (for
> > +  historical reasons) misnamed drm_primary_helper_destroy() function.
> > +
> >  Better Testing
> >  ==============
> >  
> > 
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2018-10-05 16:21 UTC|newest]

Thread overview: 47+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-04 20:24 [PATCH 00/21] atomic helper cleanup, take 2 Daniel Vetter
2018-10-04 20:24 ` [PATCH 01/21] drm/amdgpu: Remove default best_encoder hook from DC Daniel Vetter
2018-10-05 15:41   ` Harry Wentland
2018-10-05 20:13     ` Leo Li
2018-10-04 20:24 ` [PATCH 02/21] drm/atomic-helper: Unexport drm_atomic_helper_best_encoder Daniel Vetter
2018-10-04 20:24 ` [PATCH 03/21] drm: Extract drm_atomic_state_helper.[hc] Daniel Vetter
2018-10-04 20:24 ` [PATCH 04/21] drm/vmwgfx: Don't look at state->allow_modeset Daniel Vetter
2018-10-04 20:24 ` [PATCH 05/21] drm/vmwgfx: Remove confused comment from vmw_du_connector_atomic_set_property Daniel Vetter
2018-10-04 22:40   ` Thomas Hellstrom
2018-10-05  6:43     ` Daniel Vetter
2018-10-05  7:48       ` Daniel Vetter
2018-10-05 18:19         ` Thomas Hellstrom
2018-10-05 18:30           ` Daniel Vetter
2018-10-04 20:24 ` [PATCH 06/21] drm/atomic: Improve docs for drm_atomic_state->allow_modeset Daniel Vetter
2018-10-04 20:24 ` [PATCH 07/21] drm/vmwgfx: Add FIXME comments for customer page_flip handlers Daniel Vetter
2018-10-04 20:24 ` [PATCH 08/21] drm/arcpgu: Drop transitional hooks Daniel Vetter
2018-10-04 20:24 ` [PATCH 09/21] drm/atmel: " Daniel Vetter
2018-10-04 20:24 ` [PATCH 10/21] drm/arcpgu: Use drm_atomic_helper_shutdown Daniel Vetter
     [not found] ` <20181004202446.22905-1-daniel.vetter-/w4YWyX8dFk@public.gmane.org>
2018-10-04 20:24   ` [PATCH 11/21] drm/msm: " Daniel Vetter
2018-10-04 20:24 ` [PATCH 12/21] drm/sti: " Daniel Vetter
2018-10-04 20:24 ` [PATCH 13/21] drm/vc4: " Daniel Vetter
2018-10-04 20:24 ` [PATCH 14/21] drm/zte: " Daniel Vetter
2018-10-05 13:07   ` Shawn Guo
2018-10-04 20:24 ` [PATCH 15/21] drm: Remove transitional helpers Daniel Vetter
2018-10-04 21:04   ` Sam Ravnborg
2018-10-05  6:10     ` Daniel Vetter
2018-10-04 20:24 ` [PATCH 16/21] drm/vmwgfx: Fix vmw_du_cursor_plane_atomic_check Daniel Vetter
2018-10-05 16:06   ` Daniel Vetter
2018-10-05 16:21     ` Thomas Hellstrom
2018-10-05 20:46       ` Daniel Vetter
2018-10-05 20:53         ` Thomas Hellstrom
2018-10-04 20:24 ` [PATCH 17/21] drm: Unexport drm_plane_helper_check_update Daniel Vetter
2018-10-04 21:03   ` Sam Ravnborg
2018-10-05  6:13     ` Daniel Vetter
2018-10-04 20:24 ` [PATCH 18/21] drm: Unexport primary plane helpers Daniel Vetter
2018-10-04 21:14   ` Sam Ravnborg
2018-10-05  6:18     ` Daniel Vetter
2018-10-05  9:47   ` [PATCH] " Daniel Vetter
2018-10-04 20:24 ` [PATCH 19/21] drm/doc: fix drm_driver_legacy_fb_format Daniel Vetter
2018-10-05  5:07   ` Gerd Hoffmann
2018-10-04 20:24 ` [PATCH 20/21] drm/todo: Add some cleanup tasks Daniel Vetter
2018-10-04 20:35   ` Ville Syrjälä
2018-10-05 16:07   ` Harry Wentland
2018-10-05 16:20     ` Eric Engestrom [this message]
2018-10-04 20:24 ` [PATCH 21/21] drm/doc: kerneldoc for quirk_addfb_prefer_xbgr_30bpp Daniel Vetter
2018-10-24 10:01   ` Alexandru-Cosmin Gheorghe
2018-10-24 12:19     ` Daniel Vetter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181005162002.wt7256zqiduhrz57@intel.com \
    --to=eric.engestrom@intel.com \
    --cc=daniel.vetter@ffwll.ch \
    --cc=daniel.vetter@intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=harry.wentland@amd.com \
    --cc=sean@poorly.run \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox