dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Sean Paul <sean@poorly.run>
To: dri-devel@lists.freedesktop.org
Cc: David Airlie <airlied@linux.ie>,
	daniel.vetter@ffwll.ch, Sean Paul <seanpaul@chromium.org>,
	Ben Skeggs <bskeggs@redhat.com>,
	tzimmermann@suse.de, nouveau@lists.freedesktop.org
Subject: [PATCH v5 08/13] drm/nouveau: Change debug checks to specifically target syslog
Date: Mon,  8 Jun 2020 17:04:58 -0400	[thread overview]
Message-ID: <20200608210505.48519-9-sean@poorly.run> (raw)
In-Reply-To: <20200608210505.48519-1-sean@poorly.run>

From: Sean Paul <seanpaul@chromium.org>

Since the logs protected by these checks specifically target syslog,
use the new drm_debug_syslog_enabled() call to avoid triggering
these prints when only trace is enabled.

Signed-off-by: Sean Paul <seanpaul@chromium.org>

Changes in v5:
-Added to the set
---
 drivers/gpu/drm/nouveau/dispnv50/disp.h | 4 ++--
 drivers/gpu/drm/nouveau/nouveau_drv.h   | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/nouveau/dispnv50/disp.h b/drivers/gpu/drm/nouveau/dispnv50/disp.h
index 696e70a6b98b..d60602db2cf0 100644
--- a/drivers/gpu/drm/nouveau/dispnv50/disp.h
+++ b/drivers/gpu/drm/nouveau/dispnv50/disp.h
@@ -85,14 +85,14 @@ extern const u64 wndwc57e_modifiers[];
 
 #define evo_mthd(p, m, s) do {						\
 	const u32 _m = (m), _s = (s);					\
-	if (drm_debug_enabled(DRM_UT_KMS))				\
+	if (drm_debug_syslog_enabled(DRM_UT_KMS))				\
 		pr_err("%04x %d %s\n", _m, _s, __func__);		\
 	*((p)++) = ((_s << 18) | _m);					\
 } while(0)
 
 #define evo_data(p, d) do {						\
 	const u32 _d = (d);						\
-	if (drm_debug_enabled(DRM_UT_KMS))				\
+	if (drm_debug_syslog_enabled(DRM_UT_KMS))				\
 		pr_err("\t%08x\n", _d);					\
 	*((p)++) = _d;							\
 } while(0)
diff --git a/drivers/gpu/drm/nouveau/nouveau_drv.h b/drivers/gpu/drm/nouveau/nouveau_drv.h
index 2a6519737800..b916d1f456cd 100644
--- a/drivers/gpu/drm/nouveau/nouveau_drv.h
+++ b/drivers/gpu/drm/nouveau/nouveau_drv.h
@@ -257,11 +257,11 @@ void nouveau_drm_device_remove(struct drm_device *dev);
 #define NV_INFO(drm,f,a...) NV_PRINTK(info, &(drm)->client, f, ##a)
 
 #define NV_DEBUG(drm,f,a...) do {                                              \
-	if (drm_debug_enabled(DRM_UT_DRIVER))                                  \
+	if (drm_debug_syslog_enabled(DRM_UT_DRIVER))                                  \
 		NV_PRINTK(info, &(drm)->client, f, ##a);                       \
 } while(0)
 #define NV_ATOMIC(drm,f,a...) do {                                             \
-	if (drm_debug_enabled(DRM_UT_ATOMIC))                                  \
+	if (drm_debug_syslog_enabled(DRM_UT_ATOMIC))                                  \
 		NV_PRINTK(info, &(drm)->client, f, ##a);                       \
 } while(0)
 
-- 
Sean Paul, Software Engineer, Google / Chromium OS

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  parent reply	other threads:[~2020-06-08 21:06 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-08 21:04 [PATCH v5 00/13] drm/trace: Mirror DRM debug logs to tracefs Sean Paul
2020-06-08 21:04 ` [PATCH v5 01/13] drm/mipi_dbi: Convert pr_debug calls to DRM_DEBUG_DRIVER Sean Paul
2020-06-09 18:28   ` Sam Ravnborg
2020-06-08 21:04 ` [PATCH v5 02/13] drm/sil164: Convert dev_printk to drm_dev_dbg Sean Paul
2020-06-08 21:04 ` [PATCH v5 03/13] drm/i915/utils: Replace dev_printk with drm helpers Sean Paul
2020-06-08 21:04 ` [PATCH v5 04/13] drm/msm/dpu: Replace definitions for dpu debug macros Sean Paul
2020-06-08 21:04 ` [PATCH v5 05/13] drm/print: rename drm_debug* to be more syslog-centric Sean Paul
2020-06-08 21:04 ` [PATCH v5 06/13] drm/amd: Gate i2c transaction logs on drm_debug_syslog Sean Paul
2020-06-09  7:10   ` Christian König
2020-06-08 21:04 ` [PATCH v5 07/13] drm/etnaviv: Change buffer dump checks to target syslog Sean Paul
2020-06-08 21:04 ` Sean Paul [this message]
2020-06-08 21:04 ` [PATCH v5 09/13] drm/i915: Change infoframe debug checks to specify syslog Sean Paul
2020-06-08 21:05 ` [PATCH v5 10/13] drm/print: Add drm_debug_category_printer Sean Paul
2020-06-08 21:05 ` [PATCH v5 11/13] drm/mst: Convert debug printers to debug category printers Sean Paul
2020-06-08 21:05 ` [PATCH v5 12/13] drm/i915: Use debug category printer for welcome message Sean Paul
2020-06-08 21:05 ` [PATCH v5 13/13] drm/print: Add tracefs support to the drm logging helpers Sean Paul
2020-06-08 23:47   ` kernel test robot
2020-06-09  1:45   ` kernel test robot
2020-06-09 15:49     ` [PATCH v6 " Sean Paul
2020-06-10 15:01       ` Steven Rostedt
2020-06-10 15:29         ` Sean Paul
2020-06-09  1:45   ` [RFC PATCH] drm/print: trace_arr can be static kernel test robot
2020-06-10  7:57   ` [PATCH v5 13/13] drm/print: Add tracefs support to the drm logging helpers Pekka Paalanen
2020-06-10 13:29     ` Sean Paul
2020-06-10 14:09       ` Pekka Paalanen
2020-06-29 16:42 ` [PATCH v5 00/13] drm/trace: Mirror DRM debug logs to tracefs Sean Paul

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200608210505.48519-9-sean@poorly.run \
    --to=sean@poorly.run \
    --cc=airlied@linux.ie \
    --cc=bskeggs@redhat.com \
    --cc=daniel.vetter@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=nouveau@lists.freedesktop.org \
    --cc=seanpaul@chromium.org \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox