From: kernel test robot <lkp@intel.com>
To: Sean Paul <sean@poorly.run>, dri-devel@lists.freedesktop.org
Cc: kbuild-all@lists.01.org, Jonathan Corbet <corbet@lwn.net>,
David Airlie <airlied@linux.ie>,
daniel.vetter@ffwll.ch, linux-doc@vger.kernel.org,
Steven Rostedt <rostedt@goodmis.org>,
Chris Wilson <chris@chris-wilson.co.uk>,
Sean Paul <seanpaul@chromium.org>,
tzimmermann@suse.de
Subject: Re: [PATCH v5 13/13] drm/print: Add tracefs support to the drm logging helpers
Date: Tue, 9 Jun 2020 09:45:04 +0800 [thread overview]
Message-ID: <202006090859.AP8QhpSU%lkp@intel.com> (raw)
In-Reply-To: <20200608210505.48519-14-sean@poorly.run>
[-- Attachment #1: Type: text/plain, Size: 2949 bytes --]
Hi Sean,
I love your patch! Perhaps something to improve:
[auto build test WARNING on drm-intel/for-linux-next]
[also build test WARNING on drm-exynos/exynos-drm-next tegra-drm/drm/tegra/for-next drm-tip/drm-tip linus/master v5.7 next-20200608]
[cannot apply to drm/drm-next]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system. BTW, we also suggest to use '--base' option to specify the
base tree in git format-patch, please see https://stackoverflow.com/a/37406982]
url: https://github.com/0day-ci/linux/commits/Sean-Paul/drm-trace-Mirror-DRM-debug-logs-to-tracefs/20200609-050750
base: git://anongit.freedesktop.org/drm-intel for-linux-next
config: x86_64-randconfig-s021-20200607 (attached as .config)
compiler: gcc-9 (Debian 9.3.0-13) 9.3.0
reproduce:
# apt-get install sparse
# sparse version: v0.6.1-247-gcadbd124-dirty
# save the attached .config to linux build tree
make W=1 C=1 ARCH=x86_64 CF='-fdiagnostic-prefix -D__CHECK_ENDIAN__'
If you fix the issue, kindly add following tag as appropriate
Reported-by: kernel test robot <lkp@intel.com>
sparse warnings: (new ones prefixed by >>)
>> drivers/gpu/drm/drm_print.c:459:21: sparse: sparse: non-ANSI function declaration of function 'drm_trace_init'
>> drivers/gpu/drm/drm_print.c:492:24: sparse: sparse: non-ANSI function declaration of function 'drm_trace_cleanup'
Please review and possibly fold the followup patch.
vim +/drm_trace_init +459 drivers/gpu/drm/drm_print.c
452
453 /**
454 * drm_trace_init - initializes the drm trace array
455 *
456 * This function fetches (or creates) the drm trace array. This should be called
457 * once on drm subsystem creation and matched with drm_trace_cleanup().
458 */
> 459 void drm_trace_init()
460 {
461 trace_arr = trace_array_get_by_name("drm");
462 if (!trace_arr)
463 return;
464 }
465 EXPORT_SYMBOL(drm_trace_init);
466
467 /**
468 * drm_trace_printf - adds an entry to the drm tracefs instance
469 * @format: printf format of the message to add to the trace
470 *
471 * This function adds a new entry in the drm tracefs instance
472 */
473 void drm_trace_printf(const char *format, ...)
474 {
475 struct va_format vaf;
476 va_list args;
477
478 va_start(args, format);
479 vaf.fmt = format;
480 vaf.va = &args;
481 trace_array_printk(trace_arr, _THIS_IP_, "%pV", &vaf);
482 va_end(args);
483 }
484
485 /**
486 * drm_trace_cleanup - destroys the drm trace array
487 *
488 * This function destroys the drm trace array created with drm_trace_init. This
489 * should be called once on drm subsystem close and matched with
490 * drm_trace_init().
491 */
> 492 void drm_trace_cleanup()
---
0-DAY CI Kernel Test Service, Intel Corporation
https://lists.01.org/hyperkitty/list/kbuild-all@lists.01.org
[-- Attachment #2: .config.gz --]
[-- Type: application/gzip, Size: 49230 bytes --]
[-- Attachment #3: Type: text/plain, Size: 160 bytes --]
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2020-06-09 1:46 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-06-08 21:04 [PATCH v5 00/13] drm/trace: Mirror DRM debug logs to tracefs Sean Paul
2020-06-08 21:04 ` [PATCH v5 01/13] drm/mipi_dbi: Convert pr_debug calls to DRM_DEBUG_DRIVER Sean Paul
2020-06-09 18:28 ` Sam Ravnborg
2020-06-08 21:04 ` [PATCH v5 02/13] drm/sil164: Convert dev_printk to drm_dev_dbg Sean Paul
2020-06-08 21:04 ` [PATCH v5 03/13] drm/i915/utils: Replace dev_printk with drm helpers Sean Paul
2020-06-08 21:04 ` [PATCH v5 04/13] drm/msm/dpu: Replace definitions for dpu debug macros Sean Paul
2020-06-08 21:04 ` [PATCH v5 05/13] drm/print: rename drm_debug* to be more syslog-centric Sean Paul
2020-06-08 21:04 ` [PATCH v5 06/13] drm/amd: Gate i2c transaction logs on drm_debug_syslog Sean Paul
2020-06-09 7:10 ` Christian König
2020-06-08 21:04 ` [PATCH v5 07/13] drm/etnaviv: Change buffer dump checks to target syslog Sean Paul
2020-06-08 21:04 ` [PATCH v5 08/13] drm/nouveau: Change debug checks to specifically " Sean Paul
2020-06-08 21:04 ` [PATCH v5 09/13] drm/i915: Change infoframe debug checks to specify syslog Sean Paul
2020-06-08 21:05 ` [PATCH v5 10/13] drm/print: Add drm_debug_category_printer Sean Paul
2020-06-08 21:05 ` [PATCH v5 11/13] drm/mst: Convert debug printers to debug category printers Sean Paul
2020-06-08 21:05 ` [PATCH v5 12/13] drm/i915: Use debug category printer for welcome message Sean Paul
2020-06-08 21:05 ` [PATCH v5 13/13] drm/print: Add tracefs support to the drm logging helpers Sean Paul
2020-06-08 23:47 ` kernel test robot
2020-06-09 1:45 ` kernel test robot [this message]
2020-06-09 15:49 ` [PATCH v6 " Sean Paul
2020-06-10 15:01 ` Steven Rostedt
2020-06-10 15:29 ` Sean Paul
2020-06-09 1:45 ` [RFC PATCH] drm/print: trace_arr can be static kernel test robot
2020-06-10 7:57 ` [PATCH v5 13/13] drm/print: Add tracefs support to the drm logging helpers Pekka Paalanen
2020-06-10 13:29 ` Sean Paul
2020-06-10 14:09 ` Pekka Paalanen
2020-06-29 16:42 ` [PATCH v5 00/13] drm/trace: Mirror DRM debug logs to tracefs Sean Paul
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=202006090859.AP8QhpSU%lkp@intel.com \
--to=lkp@intel.com \
--cc=airlied@linux.ie \
--cc=chris@chris-wilson.co.uk \
--cc=corbet@lwn.net \
--cc=daniel.vetter@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=kbuild-all@lists.01.org \
--cc=linux-doc@vger.kernel.org \
--cc=rostedt@goodmis.org \
--cc=sean@poorly.run \
--cc=seanpaul@chromium.org \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox