* linux-next: manual merge of the drm tree with the pci tree
@ 2020-12-08 2:27 Stephen Rothwell
2020-12-08 11:47 ` Mika Westerberg
2020-12-14 20:39 ` Stephen Rothwell
0 siblings, 2 replies; 3+ messages in thread
From: Stephen Rothwell @ 2020-12-08 2:27 UTC (permalink / raw)
To: Dave Airlie, DRI, Bjorn Helgaas
Cc: Daniel Vetter, Linux Next Mailing List, Mika Westerberg,
Linux Kernel Mailing List, Qinglang Miao
[-- Attachment #1.1: Type: text/plain, Size: 1355 bytes --]
Hi all,
Today's linux-next merge of the drm tree got a conflict in:
drivers/gpu/vga/vga_switcheroo.c
between commit:
99efde6c9bb7 ("PCI/PM: Rename pci_wakeup_bus() to pci_resume_bus()")
from the pci tree and commit:
9572e6693cd7 ("vga_switcheroo: simplify the return expression of vga_switcheroo_runtime_resume")
from the drm tree.
I fixed it up (see below) and can carry the fix as necessary. This
is now fixed as far as linux-next is concerned, but any non trivial
conflicts should be mentioned to your upstream maintainer when your tree
is submitted for merging. You may also want to consider cooperating
with the maintainer of the conflicting tree to minimise any particularly
complex conflicts.
--
Cheers,
Stephen Rothwell
diff --cc drivers/gpu/vga/vga_switcheroo.c
index 8843b078ad4e,1401fd52f37a..000000000000
--- a/drivers/gpu/vga/vga_switcheroo.c
+++ b/drivers/gpu/vga/vga_switcheroo.c
@@@ -1039,12 -1038,8 +1038,8 @@@ static int vga_switcheroo_runtime_resum
mutex_lock(&vgasr_mutex);
vga_switcheroo_power_switch(pdev, VGA_SWITCHEROO_ON);
mutex_unlock(&vgasr_mutex);
- pci_wakeup_bus(pdev->bus);
+ pci_resume_bus(pdev->bus);
- ret = dev->bus->pm->runtime_resume(dev);
- if (ret)
- return ret;
-
- return 0;
+ return dev->bus->pm->runtime_resume(dev);
}
/**
[-- Attachment #1.2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 488 bytes --]
[-- Attachment #2: Type: text/plain, Size: 160 bytes --]
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: linux-next: manual merge of the drm tree with the pci tree
2020-12-08 2:27 linux-next: manual merge of the drm tree with the pci tree Stephen Rothwell
@ 2020-12-08 11:47 ` Mika Westerberg
2020-12-14 20:39 ` Stephen Rothwell
1 sibling, 0 replies; 3+ messages in thread
From: Mika Westerberg @ 2020-12-08 11:47 UTC (permalink / raw)
To: Stephen Rothwell
Cc: Dave Airlie, Daniel Vetter, Linux Kernel Mailing List, DRI,
Linux Next Mailing List, Qinglang Miao, Bjorn Helgaas
Hi,
On Tue, Dec 08, 2020 at 01:27:54PM +1100, Stephen Rothwell wrote:
> Hi all,
>
> Today's linux-next merge of the drm tree got a conflict in:
>
> drivers/gpu/vga/vga_switcheroo.c
>
> between commit:
>
> 99efde6c9bb7 ("PCI/PM: Rename pci_wakeup_bus() to pci_resume_bus()")
>
> from the pci tree and commit:
>
> 9572e6693cd7 ("vga_switcheroo: simplify the return expression of vga_switcheroo_runtime_resume")
>
> from the drm tree.
>
> I fixed it up (see below) and can carry the fix as necessary. This
> is now fixed as far as linux-next is concerned, but any non trivial
> conflicts should be mentioned to your upstream maintainer when your tree
> is submitted for merging. You may also want to consider cooperating
> with the maintainer of the conflicting tree to minimise any particularly
> complex conflicts.
Thanks for the fix Stephen! Looks correct to me.
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: linux-next: manual merge of the drm tree with the pci tree
2020-12-08 2:27 linux-next: manual merge of the drm tree with the pci tree Stephen Rothwell
2020-12-08 11:47 ` Mika Westerberg
@ 2020-12-14 20:39 ` Stephen Rothwell
1 sibling, 0 replies; 3+ messages in thread
From: Stephen Rothwell @ 2020-12-14 20:39 UTC (permalink / raw)
To: Dave Airlie, DRI, Bjorn Helgaas
Cc: Daniel Vetter, Linux Next Mailing List, Mika Westerberg,
Linux Kernel Mailing List, Qinglang Miao
[-- Attachment #1.1: Type: text/plain, Size: 1627 bytes --]
Hi all,
On Tue, 8 Dec 2020 13:27:54 +1100 Stephen Rothwell <sfr@canb.auug.org.au> wrote:
>
> Today's linux-next merge of the drm tree got a conflict in:
>
> drivers/gpu/vga/vga_switcheroo.c
>
> between commit:
>
> 99efde6c9bb7 ("PCI/PM: Rename pci_wakeup_bus() to pci_resume_bus()")
>
> from the pci tree and commit:
>
> 9572e6693cd7 ("vga_switcheroo: simplify the return expression of vga_switcheroo_runtime_resume")
>
> from the drm tree.
>
> I fixed it up (see below) and can carry the fix as necessary. This
> is now fixed as far as linux-next is concerned, but any non trivial
> conflicts should be mentioned to your upstream maintainer when your tree
> is submitted for merging. You may also want to consider cooperating
> with the maintainer of the conflicting tree to minimise any particularly
> complex conflicts.
>
> --
> Cheers,
> Stephen Rothwell
>
> diff --cc drivers/gpu/vga/vga_switcheroo.c
> index 8843b078ad4e,1401fd52f37a..000000000000
> --- a/drivers/gpu/vga/vga_switcheroo.c
> +++ b/drivers/gpu/vga/vga_switcheroo.c
> @@@ -1039,12 -1038,8 +1038,8 @@@ static int vga_switcheroo_runtime_resum
> mutex_lock(&vgasr_mutex);
> vga_switcheroo_power_switch(pdev, VGA_SWITCHEROO_ON);
> mutex_unlock(&vgasr_mutex);
> - pci_wakeup_bus(pdev->bus);
> + pci_resume_bus(pdev->bus);
> - ret = dev->bus->pm->runtime_resume(dev);
> - if (ret)
> - return ret;
> -
> - return 0;
> + return dev->bus->pm->runtime_resume(dev);
> }
>
> /**
This is now a conflict between the pci tree and Linus' tree.
--
Cheers,
Stephen Rothwell
[-- Attachment #1.2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 488 bytes --]
[-- Attachment #2: Type: text/plain, Size: 160 bytes --]
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2020-12-14 20:39 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2020-12-08 2:27 linux-next: manual merge of the drm tree with the pci tree Stephen Rothwell
2020-12-08 11:47 ` Mika Westerberg
2020-12-14 20:39 ` Stephen Rothwell
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox