From: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
To: dri-devel@lists.freedesktop.org
Cc: Matthew Brost <matthew.brost@intel.com>,
Luben Tuikov <luben.tuikov@amd.com>,
Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Subject: [PATCH 4/5] drm/sched: Rename drm_sched_run_job_queue_if_ready and clarify kerneldoc
Date: Thu, 2 Nov 2023 10:55:37 +0000 [thread overview]
Message-ID: <20231102105538.391648-5-tvrtko.ursulin@linux.intel.com> (raw)
In-Reply-To: <20231102105538.391648-1-tvrtko.ursulin@linux.intel.com>
From: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
"If ready" is not immediately clear what it means - is the scheduler
ready or something else? Drop the suffix, clarify kerneldoc, and employ
the same naming scheme as in drm_sched_run_free_queue:
- drm_sched_run_job_queue - enqueues if there is something to enqueue
*and* scheduler is ready (can queue)
- __drm_sched_run_job_queue - low-level helper to simply queue the job
Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Cc: Luben Tuikov <luben.tuikov@amd.com>
Cc: Matthew Brost <matthew.brost@intel.com>
---
drivers/gpu/drm/scheduler/sched_main.c | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/gpu/drm/scheduler/sched_main.c b/drivers/gpu/drm/scheduler/sched_main.c
index f9baca20b438..d5ddbce68fb7 100644
--- a/drivers/gpu/drm/scheduler/sched_main.c
+++ b/drivers/gpu/drm/scheduler/sched_main.c
@@ -256,10 +256,10 @@ drm_sched_rq_select_entity_fifo(struct drm_sched_rq *rq)
}
/**
- * drm_sched_run_job_queue - enqueue run-job work
+ * __drm_sched_run_job_queue - enqueue run-job work
* @sched: scheduler instance
*/
-static void drm_sched_run_job_queue(struct drm_gpu_scheduler *sched)
+static void __drm_sched_run_job_queue(struct drm_gpu_scheduler *sched)
{
if (!READ_ONCE(sched->pause_submit))
queue_work(sched->submit_wq, &sched->work_run_job);
@@ -928,7 +928,7 @@ static bool drm_sched_can_queue(struct drm_gpu_scheduler *sched)
void drm_sched_wakeup_if_can_queue(struct drm_gpu_scheduler *sched)
{
if (drm_sched_can_queue(sched))
- drm_sched_run_job_queue(sched);
+ __drm_sched_run_job_queue(sched);
}
/**
@@ -1041,13 +1041,13 @@ drm_sched_pick_best(struct drm_gpu_scheduler **sched_list,
EXPORT_SYMBOL(drm_sched_pick_best);
/**
- * drm_sched_run_job_queue_if_ready - enqueue run-job work if ready
+ * drm_sched_run_job_queue - enqueue run-job work if there are ready entities
* @sched: scheduler instance
*/
-static void drm_sched_run_job_queue_if_ready(struct drm_gpu_scheduler *sched)
+static void drm_sched_run_job_queue(struct drm_gpu_scheduler *sched)
{
if (drm_sched_select_entity(sched))
- drm_sched_run_job_queue(sched);
+ __drm_sched_run_job_queue(sched);
}
/**
@@ -1069,7 +1069,7 @@ static void drm_sched_free_job_work(struct work_struct *w)
sched->ops->free_job(job);
drm_sched_run_free_queue(sched);
- drm_sched_run_job_queue_if_ready(sched);
+ drm_sched_run_job_queue(sched);
}
/**
@@ -1126,7 +1126,7 @@ static void drm_sched_run_job_work(struct work_struct *w)
}
wake_up(&sched->job_scheduled);
- drm_sched_run_job_queue_if_ready(sched);
+ drm_sched_run_job_queue(sched);
}
/**
--
2.39.2
next prev parent reply other threads:[~2023-11-02 10:56 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-11-02 10:55 [PATCH 0/5] Some drm scheduler internal renames Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 1/5] drm/sched: Rename drm_sched_get_cleanup_job to be more descriptive Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 2/5] drm/sched: Move free worker re-queuing out of the if block Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 3/5] drm/sched: Rename drm_sched_free_job_queue to be more descriptive Tvrtko Ursulin
2023-11-02 10:55 ` Tvrtko Ursulin [this message]
2023-11-02 10:55 ` [PATCH 5/5] drm/sched: Drop suffix from drm_sched_wakeup_if_can_queue Tvrtko Ursulin
2023-11-05 0:00 ` [PATCH 0/5] Some drm scheduler internal renames Luben Tuikov
2023-11-05 1:51 ` Luben Tuikov
2023-11-06 12:41 ` Tvrtko Ursulin
2023-11-07 2:42 ` Luben Tuikov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20231102105538.391648-5-tvrtko.ursulin@linux.intel.com \
--to=tvrtko.ursulin@linux.intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=luben.tuikov@amd.com \
--cc=matthew.brost@intel.com \
--cc=tvrtko.ursulin@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox