dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
To: Luben Tuikov <ltuikov89@gmail.com>, dri-devel@lists.freedesktop.org
Cc: Matthew Brost <matthew.brost@intel.com>,
	Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Subject: Re: [PATCH 0/5] Some drm scheduler internal renames
Date: Mon, 6 Nov 2023 12:41:07 +0000	[thread overview]
Message-ID: <42646224-60e4-4ac1-b554-730b66fb2704@linux.intel.com> (raw)
In-Reply-To: <88bd3e1d-db66-40de-b06f-adcaefacccf3@gmail.com>


On 05/11/2023 01:51, Luben Tuikov wrote:
> On 2023-11-02 06:55, Tvrtko Ursulin wrote:
>> From: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
>>
>> I found some of the naming a bit incosistent and unclear so just a small
>> attempt to clarify and tidy some of them. See what people think if my first
>> stab improves things or not.
>>
>> Cc: Luben Tuikov <luben.tuikov@amd.com>
>> Cc: Matthew Brost <matthew.brost@intel.com>
>>
>> Tvrtko Ursulin (5):
>>    drm/sched: Rename drm_sched_get_cleanup_job to be more descriptive
>>    drm/sched: Move free worker re-queuing out of the if block
>>    drm/sched: Rename drm_sched_free_job_queue to be more descriptive
>>    drm/sched: Rename drm_sched_run_job_queue_if_ready and clarify
>>      kerneldoc
>>    drm/sched: Drop suffix from drm_sched_wakeup_if_can_queue
>>
>>   drivers/gpu/drm/scheduler/sched_entity.c |  4 +-
>>   drivers/gpu/drm/scheduler/sched_main.c   | 53 ++++++++++++------------
>>   include/drm/gpu_scheduler.h              |  2 +-
>>   3 files changed, 29 insertions(+), 30 deletions(-)
>>
> 
> Series is,
> 
> Reviewed-by: Luben Tuikov <ltuikov89@gmail.com>
> 
> and pushed to drm-misc-next.

Oh thanks, I definitely did not expect that to happen so quickly, 
especially since it conflicts with your fix for RR and there are some 
other opens. But it is fine, all that can be worked on top.

Regards,

Tvrtko

  reply	other threads:[~2023-11-06 12:41 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-11-02 10:55 [PATCH 0/5] Some drm scheduler internal renames Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 1/5] drm/sched: Rename drm_sched_get_cleanup_job to be more descriptive Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 2/5] drm/sched: Move free worker re-queuing out of the if block Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 3/5] drm/sched: Rename drm_sched_free_job_queue to be more descriptive Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 4/5] drm/sched: Rename drm_sched_run_job_queue_if_ready and clarify kerneldoc Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 5/5] drm/sched: Drop suffix from drm_sched_wakeup_if_can_queue Tvrtko Ursulin
2023-11-05  0:00 ` [PATCH 0/5] Some drm scheduler internal renames Luben Tuikov
2023-11-05  1:51 ` Luben Tuikov
2023-11-06 12:41   ` Tvrtko Ursulin [this message]
2023-11-07  2:42     ` Luben Tuikov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=42646224-60e4-4ac1-b554-730b66fb2704@linux.intel.com \
    --to=tvrtko.ursulin@linux.intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=ltuikov89@gmail.com \
    --cc=matthew.brost@intel.com \
    --cc=tvrtko.ursulin@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox