dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/5] Some drm scheduler internal renames
@ 2023-11-02 10:55 Tvrtko Ursulin
  2023-11-02 10:55 ` [PATCH 1/5] drm/sched: Rename drm_sched_get_cleanup_job to be more descriptive Tvrtko Ursulin
                   ` (6 more replies)
  0 siblings, 7 replies; 10+ messages in thread
From: Tvrtko Ursulin @ 2023-11-02 10:55 UTC (permalink / raw)
  To: dri-devel; +Cc: Matthew Brost, Luben Tuikov, Tvrtko Ursulin

From: Tvrtko Ursulin <tvrtko.ursulin@intel.com>

I found some of the naming a bit incosistent and unclear so just a small
attempt to clarify and tidy some of them. See what people think if my first
stab improves things or not.

Cc: Luben Tuikov <luben.tuikov@amd.com>
Cc: Matthew Brost <matthew.brost@intel.com>

Tvrtko Ursulin (5):
  drm/sched: Rename drm_sched_get_cleanup_job to be more descriptive
  drm/sched: Move free worker re-queuing out of the if block
  drm/sched: Rename drm_sched_free_job_queue to be more descriptive
  drm/sched: Rename drm_sched_run_job_queue_if_ready and clarify
    kerneldoc
  drm/sched: Drop suffix from drm_sched_wakeup_if_can_queue

 drivers/gpu/drm/scheduler/sched_entity.c |  4 +-
 drivers/gpu/drm/scheduler/sched_main.c   | 53 ++++++++++++------------
 include/drm/gpu_scheduler.h              |  2 +-
 3 files changed, 29 insertions(+), 30 deletions(-)

-- 
2.39.2


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2023-11-07  2:42 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2023-11-02 10:55 [PATCH 0/5] Some drm scheduler internal renames Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 1/5] drm/sched: Rename drm_sched_get_cleanup_job to be more descriptive Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 2/5] drm/sched: Move free worker re-queuing out of the if block Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 3/5] drm/sched: Rename drm_sched_free_job_queue to be more descriptive Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 4/5] drm/sched: Rename drm_sched_run_job_queue_if_ready and clarify kerneldoc Tvrtko Ursulin
2023-11-02 10:55 ` [PATCH 5/5] drm/sched: Drop suffix from drm_sched_wakeup_if_can_queue Tvrtko Ursulin
2023-11-05  0:00 ` [PATCH 0/5] Some drm scheduler internal renames Luben Tuikov
2023-11-05  1:51 ` Luben Tuikov
2023-11-06 12:41   ` Tvrtko Ursulin
2023-11-07  2:42     ` Luben Tuikov

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox