From: Maxime Ripard <mripard@kernel.org>
To: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>,
Daniel Vetter <daniel@ffwll.ch>
Cc: Jani Nikula <jani.nikula@linux.intel.com>,
dri-devel@lists.freedesktop.org,
Maxime Ripard <mripard@kernel.org>,
Jani Nikula <jani.nikula@intel.com>,
Lucas De Marchi <lucas.demarchi@intel.com>
Subject: [PATCH v3 04/13] drm/display: Make DisplayPort CEC-over-AUX Kconfig name consistent
Date: Wed, 27 Mar 2024 11:56:59 +0100 [thread overview]
Message-ID: <20240327-kms-kconfig-helpers-v3-4-eafee11b84b3@kernel.org> (raw)
In-Reply-To: <20240327-kms-kconfig-helpers-v3-0-eafee11b84b3@kernel.org>
While most display helpers Kconfig symbols have the DRM_DISPLAY prefix,
the DisplayPort CEC tunnelling implementation uses CONFIG_DRM_DISPLAY_DP_AUX_CEC.
Since the number of users is limited, we can easily rename it to make it
consistent.
Reviewed-by: Jani Nikula <jani.nikula@intel.com>
Reviewed-by: Lucas De Marchi <lucas.demarchi@intel.com>
Signed-off-by: Maxime Ripard <mripard@kernel.org>
---
arch/parisc/configs/generic-32bit_defconfig | 2 +-
drivers/gpu/drm/display/Kconfig | 2 +-
drivers/gpu/drm/display/Makefile | 2 +-
include/drm/display/drm_dp_helper.h | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/arch/parisc/configs/generic-32bit_defconfig b/arch/parisc/configs/generic-32bit_defconfig
index ee4febb30386..5ce258f3fffa 100644
--- a/arch/parisc/configs/generic-32bit_defconfig
+++ b/arch/parisc/configs/generic-32bit_defconfig
@@ -129,11 +129,11 @@ CONFIG_PRINTER=m
CONFIG_PPDEV=m
# CONFIG_HW_RANDOM is not set
CONFIG_I2C=y
CONFIG_HWMON=m
CONFIG_DRM=m
-CONFIG_DRM_DP_CEC=y
+CONFIG_DRM_DISPLAY_DP_AUX_CEC=y
# CONFIG_DRM_I2C_CH7006 is not set
# CONFIG_DRM_I2C_SIL164 is not set
CONFIG_DRM_RADEON=m
CONFIG_DRM_NOUVEAU=m
# CONFIG_DRM_NOUVEAU_BACKLIGHT is not set
diff --git a/drivers/gpu/drm/display/Kconfig b/drivers/gpu/drm/display/Kconfig
index 038be9795581..35cb68db0bfd 100644
--- a/drivers/gpu/drm/display/Kconfig
+++ b/drivers/gpu/drm/display/Kconfig
@@ -57,11 +57,11 @@ config DRM_DISPLAY_DP_AUX_CHARDEV
help
Choose this option to enable a /dev/drm_dp_auxN node that allows to
read and write values to arbitrary DPCD registers on the DP aux
channel.
-config DRM_DP_CEC
+config DRM_DISPLAY_DP_AUX_CEC
bool "Enable DisplayPort CEC-Tunneling-over-AUX HDMI support"
depends on DRM && DRM_DISPLAY_HELPER
select DRM_DISPLAY_DP_HELPER
select CEC_CORE
help
diff --git a/drivers/gpu/drm/display/Makefile b/drivers/gpu/drm/display/Makefile
index 44015aef1e8c..17d2cc73ff56 100644
--- a/drivers/gpu/drm/display/Makefile
+++ b/drivers/gpu/drm/display/Makefile
@@ -13,8 +13,8 @@ drm_display_helper-$(CONFIG_DRM_DISPLAY_DP_TUNNEL) += \
drm_display_helper-$(CONFIG_DRM_DISPLAY_HDCP_HELPER) += drm_hdcp_helper.o
drm_display_helper-$(CONFIG_DRM_DISPLAY_HDMI_HELPER) += \
drm_hdmi_helper.o \
drm_scdc_helper.o
drm_display_helper-$(CONFIG_DRM_DISPLAY_DP_AUX_CHARDEV) += drm_dp_aux_dev.o
-drm_display_helper-$(CONFIG_DRM_DP_CEC) += drm_dp_cec.o
+drm_display_helper-$(CONFIG_DRM_DISPLAY_DP_AUX_CEC) += drm_dp_cec.o
obj-$(CONFIG_DRM_DISPLAY_HELPER) += drm_display_helper.o
diff --git a/include/drm/display/drm_dp_helper.h b/include/drm/display/drm_dp_helper.h
index a62fcd051d4d..46f4e0467d24 100644
--- a/include/drm/display/drm_dp_helper.h
+++ b/include/drm/display/drm_dp_helper.h
@@ -720,11 +720,11 @@ static inline int drm_panel_dp_aux_backlight(struct drm_panel *panel,
return 0;
}
#endif
-#ifdef CONFIG_DRM_DP_CEC
+#ifdef CONFIG_DRM_DISPLAY_DP_AUX_CEC
void drm_dp_cec_irq(struct drm_dp_aux *aux);
void drm_dp_cec_register_connector(struct drm_dp_aux *aux,
struct drm_connector *connector);
void drm_dp_cec_unregister_connector(struct drm_dp_aux *aux);
void drm_dp_cec_attach(struct drm_dp_aux *aux, u16 source_physical_address);
--
2.44.0
next prev parent reply other threads:[~2024-03-27 10:57 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-03-27 10:56 [PATCH v3 00/13] drm/display: Convert helpers Kconfig symbols to depends on Maxime Ripard
2024-03-27 10:56 ` [PATCH v3 01/13] drm/display: Make DisplayPort AUX bus Kconfig name consistent Maxime Ripard
2024-03-27 10:56 ` [PATCH v3 02/13] drm/display: Make DisplayPort tunnel debug " Maxime Ripard
2024-03-27 10:56 ` [PATCH v3 03/13] drm/display: Make DisplayPort AUX Chardev " Maxime Ripard
2024-03-27 10:56 ` Maxime Ripard [this message]
2024-03-27 10:57 ` [PATCH v3 05/13] drm/display: Reorder Kconfig symbols Maxime Ripard
2024-03-27 10:57 ` [PATCH v3 06/13] drm/display: Make all helpers visible and switch to depends on Maxime Ripard
2024-03-27 10:57 ` [PATCH v3 07/13] drm: Make drivers depends on DRM_DW_HDMI Maxime Ripard
2024-03-28 10:01 ` Jani Nikula
2024-04-02 15:43 ` Mark Brown
2024-04-03 6:50 ` Alexander Stein
2024-04-23 5:45 ` Mark Brown
2024-04-23 8:05 ` Jani Nikula
2024-03-27 10:57 ` [PATCH v3 08/13] drm: Switch DRM_DISPLAY_HELPER to depends on Maxime Ripard
2024-03-27 10:57 ` [PATCH v3 09/13] drm: Switch DRM_DISPLAY_DP_AUX_BUS " Maxime Ripard
2024-04-09 8:35 ` Geert Uytterhoeven
2024-03-27 10:57 ` [PATCH v3 10/13] drm: Switch DRM_DISPLAY_DP_HELPER " Maxime Ripard
2024-03-27 10:57 ` [PATCH v3 11/13] drm: Switch DRM_DISPLAY_HDCP_HELPER " Maxime Ripard
2024-03-27 10:57 ` [PATCH v3 12/13] drm: Switch DRM_DISPLAY_HDMI_HELPER " Maxime Ripard
2024-03-27 10:57 ` [PATCH v3 13/13] drm/bridge: it6505: Remove useless select Maxime Ripard
2024-03-28 10:29 ` [PATCH v3 00/13] drm/display: Convert helpers Kconfig symbols to depends on Maxime Ripard
2024-04-09 9:26 ` Geert Uytterhoeven
2024-04-09 10:04 ` Jani Nikula
2024-04-09 10:35 ` Geert Uytterhoeven
2024-04-09 11:12 ` Jani Nikula
2024-04-09 15:24 ` Geert Uytterhoeven
2024-04-10 19:46 ` Diederik de Haas
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240327-kms-kconfig-helpers-v3-4-eafee11b84b3@kernel.org \
--to=mripard@kernel.org \
--cc=airlied@gmail.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=jani.nikula@intel.com \
--cc=jani.nikula@linux.intel.com \
--cc=lucas.demarchi@intel.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox