dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Yakir Yang <ykk@rock-chips.com>
To: Sean Paul <seanpaul@chromium.org>,
	dri-devel@lists.freedesktop.org, tomeu.vizoso@collabora.com,
	architt@codeaurora.org
Cc: daniel.vetter@intel.com, linux-kernel@vger.kernel.org,
	mika.kahola@intel.com, javier@osg.samsung.com
Subject: Re: [PATCH v3] drm/bridge: analogix_dp: Remove duplicated code
Date: Thu, 25 Aug 2016 16:02:26 +0800	[thread overview]
Message-ID: <253ab620-e918-64ed-e227-31f952e910e4@rock-chips.com> (raw)
In-Reply-To: <1472050481-32724-1-git-send-email-seanpaul@chromium.org>


[-- Attachment #1.1: Type: text/plain, Size: 1469 bytes --]

On 08/24/2016 10:54 PM, Sean Paul wrote:
> From: Tomeu Vizoso<tomeu.vizoso@collabora.com>
>
> Remove code for reading the EDID and DPCD fields and use the helpers
> instead.
>
> Besides the obvious code reduction, other helpers are being added to the
> core that could be used in this driver and will be good to be able to
> use them instead of duplicating them.
>
> Signed-off-by: Tomeu Vizoso<tomeu.vizoso@collabora.com>
> Tested-by: Javier Martinez Canillas<javier@osg.samsung.com>
> Tested-by: Sean Paul<seanpaul@chromium.org>
> Reviewed-by: Sean Paul<seanpaul@chromium.org>
> Signed-off-by: Sean Paul<seanpaul@chromium.org>
> Cc: Javier Martinez Canillas<javier@osg.samsung.com>
> Cc: Mika Kahola<mika.kahola@intel.com>
> Cc: Yakir Yang<ykk@rock-chips.com>
> Cc: Daniel Vetter<daniel.vetter@intel.com>
> Cc: Archit Taneja<architt@codeaurora.org>

Reviewed-by: Yakir Yang <ykk@rock-chips.com>

> ---
>
> v2:
>      - A bunch of good fixes from Sean and Yakir
>      - Moved the transfer function to analogix_dp_reg.c
>      - Removed reference to the EDID from the dp struct
>
> v3:
>      - Rebased on top of Yakir's PSR series
>      - Fixed checkpatch warning about line length
>
>
>   drivers/gpu/drm/bridge/analogix/analogix_dp_core.c | 274 ++++---------
>   drivers/gpu/drm/bridge/analogix/analogix_dp_core.h |  40 +-
>   drivers/gpu/drm/bridge/analogix/analogix_dp_reg.c  | 451 ++++++---------------
>   3 files changed, 210 insertions(+), 555 deletions(-)


[-- Attachment #1.2: Type: text/html, Size: 3161 bytes --]

[-- Attachment #2: Type: text/plain, Size: 160 bytes --]

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

      reply	other threads:[~2016-08-25  8:03 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-08-05 12:59 [PATCH] drm/bridge: analogix_dp: Remove duplicated code v2 Tomeu Vizoso
2016-08-05 13:35 ` Sean Paul
2016-08-08 10:43 ` Yakir Yang
2016-08-08 11:20   ` Tomeu Vizoso
2016-08-24 14:54     ` [PATCH v3] drm/bridge: analogix_dp: Remove duplicated code Sean Paul
2016-08-25  8:02       ` Yakir Yang [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=253ab620-e918-64ed-e227-31f952e910e4@rock-chips.com \
    --to=ykk@rock-chips.com \
    --cc=architt@codeaurora.org \
    --cc=daniel.vetter@intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=javier@osg.samsung.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mika.kahola@intel.com \
    --cc=seanpaul@chromium.org \
    --cc=tomeu.vizoso@collabora.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox