FS/XFS testing framework
 help / color / mirror / Atom feed
From: Dave Chinner <david@fromorbit.com>
To: David Disseldorp <ddiss@suse.de>, fstests@vger.kernel.org
Subject: Re: [PATCH] generic/019: kill background processes on interrupt
Date: Wed, 13 Apr 2022 10:26:56 +1000	[thread overview]
Message-ID: <20220413002656.GL1609613@dread.disaster.area> (raw)
In-Reply-To: <20220412142500.ubkbw2fvbxowzo5p@zlang-mailbox>

On Tue, Apr 12, 2022 at 10:25:00PM +0800, Zorro Lang wrote:
> On Tue, Apr 12, 2022 at 02:59:42PM +0200, David Disseldorp wrote:
> > On Mon, 11 Apr 2022 15:48:33 +1000, Dave Chinner wrote:
> > 
> > > From: Dave Chinner <dchinner@redhat.com>
> > > 
> > > If you ctrl-c generic/019, it leaves fsstress processes running.
> > > Kill them in the cleanup function so that they don't have to be
> > > manually killed after interrupting the test.
> > > 
> > > While touching the _cleanup() function, make it do everything that
> > > the generic _cleanup function it overrides does and fix the
> > > indenting.
> > > 
> > > Signed-off-by: Dave Chinner <dchinner@redhat.com>
> > > ---
> > >  tests/generic/019 | 6 ++++--
> > >  1 file changed, 4 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/tests/generic/019 b/tests/generic/019
> > > index db56dac1..cda107f4 100755
> > > --- a/tests/generic/019
> > > +++ b/tests/generic/019
> > > @@ -53,8 +53,10 @@ stop_fail_scratch_dev()
> > >  # Override the default cleanup function.
> > >  _cleanup()
> > >  {
> > > -    disallow_fail_make_request
> > > -    rm -f $tmp.*
> > > +	kill $fs_pid $fio_pid &> /dev/null
> > > +	disallow_fail_make_request
> > > +	cd /
> > > +	rm -r -f $tmp.*
> > >  }
> > >  
> > >  RUN_TIME=$((20+10*$TIME_FACTOR))
> > 
> > Might be worth unset'ing the "fs_pid" and "fio_pid" variables after the
> > wait, but should be fine as-is:
> 
> I agree. Better to avoid killing other system processes. Or how about this place
> does (avoid killing system useful processes):
> $KILLALL_PROG -q $FSSTRESS_PROG
> $KILLALL_PROG -q $FIO_PROG
> 
> Another picky question is, do we need to use a while loop checking, until the
> processes really get killed? :)

Do we really need to paint the bikeshed over how best to kill a
process? I don't have time to do that, this is just a drive-by fix
that works for me....

-Dave.
-- 
Dave Chinner
david@fromorbit.com

  reply	other threads:[~2022-04-13  0:27 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-04-11  5:48 [PATCH] generic/019: kill background processes on interrupt Dave Chinner
2022-04-12 12:59 ` David Disseldorp
2022-04-12 14:25   ` Zorro Lang
2022-04-13  0:26     ` Dave Chinner [this message]
2022-04-13  7:13       ` Amir Goldstein
2022-04-13 23:27         ` Darrick J. Wong
2022-04-18  0:02         ` Dave Chinner
2022-04-14 16:25       ` Zorro Lang
2022-04-14 19:16         ` Zorro Lang
2022-04-16  9:20           ` Amir Goldstein
2022-04-16 14:11             ` Zorro Lang
2022-04-16 17:13               ` Amir Goldstein
2022-04-18 17:07                 ` Darrick J. Wong
2022-04-18 18:08                   ` Zorro Lang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220413002656.GL1609613@dread.disaster.area \
    --to=david@fromorbit.com \
    --cc=ddiss@suse.de \
    --cc=fstests@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox