FS/XFS testing framework
 help / color / mirror / Atom feed
From: Zorro Lang <zlang@kernel.org>
To: "Darrick J. Wong" <djwong@kernel.org>
Cc: Christoph Hellwig <hch@lst.de>, fstests@vger.kernel.org
Subject: Re: [PATCH 3/5] generic/091: enable sub-block reads
Date: Thu, 3 Sep 2026 00:46:54 +0800	[thread overview]
Message-ID: <aphR1JHVpfU9_zTG@zlang-mailbox> (raw)
In-Reply-To: <20260831171931.GD839663@frogsfrogsfrogs>

On Mon, Aug 31, 2026 at 10:19:31AM -0700, Darrick J. Wong wrote:
> On Mon, Aug 31, 2026 at 09:51:06AM +0300, Christoph Hellwig wrote:
> > The description of generic/091 claims that it tries to exercise sub-block
> > direct I/O, but the test currently limits reads to PAGE_SIZE alignment.
> > 
> > Use the new min_dio_alignment -r option to query the minimal read
> > alignment and only limit the read alignment to that.
> > 
> > Signed-off-by: Christoph Hellwig <hch@lst.de>
> 
> I've long wondered about why reads are the page size when xfs could
> easily do smaller...

Maybe we should rename psize/PSIZE in _run_fsx_on_file helper (and cases
call *run_fsx* function) as well? Keeping that name for DIO read alignment
doesn't quite match the new semantics introduced by this series.

Thanks,
Zorro

> Reviewed-by: "Darrick J. Wong" <djwong@kernel.org>
> 
> --D
> 
> > ---
> >  tests/generic/091 | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/tests/generic/091 b/tests/generic/091
> > index 5cdf04890c0e..b2fba09d39ef 100755
> > --- a/tests/generic/091
> > +++ b/tests/generic/091
> > @@ -15,8 +15,8 @@ _begin_fstest rw auto quick
> >  _require_test
> >  _require_odirect
> >  
> > -psize=`$here/src/feature -s`
> >  bsize=`$here/src/min_dio_alignment $TEST_DIR $TEST_DEV`
> > +psize=`$here/src/min_dio_alignment -r $TEST_DIR $TEST_DEV`
> >  
> >  # fsx usage:
> >  # 
> > -- 
> > 2.53.0
> > 
> > 

  reply	other threads:[~2026-09-02 16:47 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-31  6:51 actually exercise sub-block direct I/O reads Christoph Hellwig
2026-08-31  6:51 ` [PATCH 1/5] statx.h: update to latest kernel UAPI Christoph Hellwig
2026-08-31 17:12   ` Darrick J. Wong
2026-09-02 15:31   ` Zorro Lang
2026-08-31  6:51 ` [PATCH 2/5] min_dio_alignment: add a -r option to query read alignment Christoph Hellwig
2026-08-31 17:16   ` Darrick J. Wong
2026-09-02 16:26   ` Zorro Lang
2026-09-03  5:34     ` Christoph Hellwig
2026-09-03 13:39       ` Zorro Lang
2026-09-02 16:31   ` Zorro Lang
2026-08-31  6:51 ` [PATCH 3/5] generic/091: enable sub-block reads Christoph Hellwig
2026-08-31 17:19   ` Darrick J. Wong
2026-09-02 16:46     ` Zorro Lang [this message]
2026-09-03  5:34       ` Christoph Hellwig
2026-09-03 13:33         ` Zorro Lang
2026-09-02 16:39   ` Zorro Lang
2026-08-31  6:51 ` [PATCH 4/5] generic/263: " Christoph Hellwig
2026-08-31 17:19   ` Darrick J. Wong
2026-09-02 16:48   ` Zorro Lang
2026-08-31  6:51 ` [PATCH 5/5] generic/760: " Christoph Hellwig
2026-08-31 17:19   ` Darrick J. Wong
2026-09-02 16:49   ` Zorro Lang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aphR1JHVpfU9_zTG@zlang-mailbox \
    --to=zlang@kernel.org \
    --cc=djwong@kernel.org \
    --cc=fstests@vger.kernel.org \
    --cc=hch@lst.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox