* [PATCH 0/5] sha1_file.c pack reading cleanups
@ 2006-08-26 8:10 Shawn Pearce
0 siblings, 0 replies; only message in thread
From: Shawn Pearce @ 2006-08-26 8:10 UTC (permalink / raw)
To: Junio C Hamano; +Cc: git
This is a 5 patch series built on `master`. I discovered these
cleanups when I lifted code from sha1_file.c for fast-import.c
(as I needed to read the pack I was writing and thus didn't have
a nice sorted index to work with).
I'll probably follow this series with another one which libifies
more of these functions to the point that I can actually use them
from within fast-import.c, without having an index file. But I
might first send partial pack mapping as I'm also doing that in
fast-import.c right now.
In this series:
1/5 Reorganize/rename unpack_non_delta_entry to unpack_compressed_entry.
2/5 Reuse compression code in unpack_compressed_entry.
3/5 Cleanup unpack_entry_gently and friends to use type_name array.
4/5 Cleanup unpack_object_header to use only offsets.
5/5 Convert unpack_entry_gently and friends to use offsets.
--
Shawn.
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2006-08-26 8:10 UTC | newest]
Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2006-08-26 8:10 [PATCH 0/5] sha1_file.c pack reading cleanups Shawn Pearce
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox