* [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied
@ 2012-03-20 1:39 Maciej Małecki
2012-03-20 1:55 ` Junio C Hamano
0 siblings, 1 reply; 4+ messages in thread
From: Maciej Małecki @ 2012-03-20 1:39 UTC (permalink / raw)
To: git; +Cc: Maciej Małecki
Using a different SSH key for various SSH commands seems to be a
recurring theme. Allow user to supply path to the SSH key he wants to
use for operations that require it without need to use `GIT_SSH`
variable and a wrapper script.
Signed-off-by: Maciej Małecki <me@mmalecki.com>
---
connect.c | 10 +++++++++-
1 files changed, 9 insertions(+), 1 deletions(-)
diff --git a/connect.c b/connect.c
index 912cdde..dd3489d 100644
--- a/connect.c
+++ b/connect.c
@@ -575,8 +575,9 @@ struct child_process *git_connect(int fd[2], const char *url_orig,
die("command line too long");
conn->in = conn->out = -1;
- conn->argv = arg = xcalloc(7, sizeof(*arg));
+ conn->argv = arg = xcalloc(9, sizeof(*arg));
if (protocol == PROTO_SSH) {
+ const char *key;
const char *ssh = getenv("GIT_SSH");
int putty = ssh && strcasestr(ssh, "plink");
if (!ssh) ssh = "ssh";
@@ -589,6 +590,13 @@ struct child_process *git_connect(int fd[2], const char *url_orig,
*arg++ = putty ? "-P" : "-p";
*arg++ = port;
}
+
+ key = getenv("GIT_SSH_KEY");
+ if (key) {
+ *arg++ = "-i";
+ *arg++ = key;
+ }
+
*arg++ = host;
}
else {
--
1.7.7.4
^ permalink raw reply related [flat|nested] 4+ messages in thread* Re: [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied
2012-03-20 1:39 [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied Maciej Małecki
@ 2012-03-20 1:55 ` Junio C Hamano
2012-03-20 2:07 ` Robin H. Johnson
0 siblings, 1 reply; 4+ messages in thread
From: Junio C Hamano @ 2012-03-20 1:55 UTC (permalink / raw)
To: Maciej Małecki; +Cc: git
Maciej Małecki <me@mmalecki.com> writes:
> if (protocol == PROTO_SSH) {
> + const char *key;
> const char *ssh = getenv("GIT_SSH");
> int putty = ssh && strcasestr(ssh, "plink");
> if (!ssh) ssh = "ssh";
> @@ -589,6 +590,13 @@ struct child_process *git_connect(int fd[2], const char *url_orig,
> *arg++ = putty ? "-P" : "-p";
> *arg++ = port;
> }
> +
> + key = getenv("GIT_SSH_KEY");
> + if (key) {
> + *arg++ = "-i";
> + *arg++ = key;
> + }
Hmm. I am somewhat torn.
The minimalist in me finds this extraneous and unnecessary noise. Why
should the user always set GIT_SSH_KEY environment variable that only
applies to git and does not help his other ssh sessions? Why isn't having
an entry in .ssh/config to name IdentityFile sufficient?
On the other hand, the feature-creepist in me finds this somewhat lacking.
Why should we give special treatment only to "-i $identity_file" option
[*1*] and not others? Do we have to invent new environment variables if
we wanted to pass "-c $cipher_spec", "-l $login_name", "-I $pkcs11", "-4",
"-6", or "-b $bind_address"?
Would GIT_SSH_ARGS='-i /home/me/.ssh/there.pub -l me' be more appropriate?
[Footnote]
*1* In any case, GIT_SSH_KEY is misnamed. It should match whatever word
ssh(1) uses to describe the concept--in this case, it is "identity file".
^ permalink raw reply [flat|nested] 4+ messages in thread* Re: [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied
2012-03-20 1:55 ` Junio C Hamano
@ 2012-03-20 2:07 ` Robin H. Johnson
2012-03-20 8:07 ` Maciej Małecki
0 siblings, 1 reply; 4+ messages in thread
From: Robin H. Johnson @ 2012-03-20 2:07 UTC (permalink / raw)
To: Git Mailing List
On Mon, Mar 19, 2012 at 06:55:06PM -0700, Junio C Hamano wrote:
> Hmm. I am somewhat torn.
>
> The minimalist in me finds this extraneous and unnecessary noise. Why
> should the user always set GIT_SSH_KEY environment variable that only
> applies to git and does not help his other ssh sessions? Why isn't having
> an entry in .ssh/config to name IdentityFile sufficient?
>
> Would GIT_SSH_ARGS='-i /home/me/.ssh/there.pub -l me' be more appropriate?
I'd strongly prefer a generic args support, for making it easier to use
in deployment code.
--
Robin Hugh Johnson
Gentoo Linux: Developer, Trustee & Infrastructure Lead
E-Mail : robbat2@gentoo.org
GnuPG FP : 11ACBA4F 4778E3F6 E4EDF38E B27B944E 34884E85
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied
2012-03-20 2:07 ` Robin H. Johnson
@ 2012-03-20 8:07 ` Maciej Małecki
0 siblings, 0 replies; 4+ messages in thread
From: Maciej Małecki @ 2012-03-20 8:07 UTC (permalink / raw)
To: git
W dniu 20 marca 2012 03:07 użytkownik Robin H. Johnson
<robbat2@gentoo.org> napisał:
> On Mon, Mar 19, 2012 at 06:55:06PM -0700, Junio C Hamano wrote:
>> Hmm. I am somewhat torn.
>>
>> The minimalist in me finds this extraneous and unnecessary noise. Why
>> should the user always set GIT_SSH_KEY environment variable that only
>> applies to git and does not help his other ssh sessions? Why isn't having
>> an entry in .ssh/config to name IdentityFile sufficient?
>>
>> Would GIT_SSH_ARGS='-i /home/me/.ssh/there.pub -l me' be more appropriate?
> I'd strongly prefer a generic args support, for making it easier to use
> in deployment code.
After rethinking it, I'm also +1 on GIT_SSH_ARGS. Should I submit a patch?
Sorry for noob question, but it'd go into a new e-mail thread, right?
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2012-03-20 8:07 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2012-03-20 1:39 [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied Maciej Małecki
2012-03-20 1:55 ` Junio C Hamano
2012-03-20 2:07 ` Robin H. Johnson
2012-03-20 8:07 ` Maciej Małecki
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox