Git development
 help / color / mirror / Atom feed
* [PATCH 00/13] more changes to port rebase -i to C using sequencer code
@ 2009-08-12  5:15 Christian Couder
  2009-08-12  5:15 ` [PATCH 01/13] sequencer: add "do_fast_forward()" to perform a fast forward Christian Couder
                   ` (13 more replies)
  0 siblings, 14 replies; 15+ messages in thread
From: Christian Couder @ 2009-08-12  5:15 UTC (permalink / raw)
  To: Junio C Hamano
  Cc: git, Johannes Schindelin, Stephan Beyer, Daniel Barkalow,
	Jakub Narebski

These is just the current state of my work.
Some patches have already been sent but are not yet in pu.

Christian Couder (9):
  sequencer: add "--fast-forward" option to "git sequencer--helper"
  sequencer: let "git sequencer--helper" callers set "allow_dirty"
  rebase -i: use "git sequencer--helper --fast-forward"
  pick: simplify "error(...)" followed by "return -1"
  pick: rename "pick()" to "pick_commit()"
  pick: remove useless PICK_REVERSE => PICK_ADD_NOTE code
  pick: simplify bogus comment about commiting immediately
  pick: libify "pick_help_msg()"
  rebase -i: use "git sequencer--helper --cherry-pick"

Stephan Beyer (4):
  sequencer: add "do_fast_forward()" to perform a fast forward
  revert: libify pick
  sequencer: add "do_commit()" and related functions
  sequencer: add "--cherry-pick" option to "git sequencer--helper"

 Makefile                    |    2 +
 builtin-revert.c            |  293 +++++++------------------------------------
 builtin-sequencer--helper.c |  298 ++++++++++++++++++++++++++++++++++++++++++-
 git-rebase--interactive.sh  |   19 +--
 pick.c                      |  232 +++++++++++++++++++++++++++++++++
 pick.h                      |   14 ++
 6 files changed, 592 insertions(+), 266 deletions(-)
 create mode 100644 pick.c
 create mode 100644 pick.h

^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2009-08-12 21:49 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2009-08-12  5:15 [PATCH 00/13] more changes to port rebase -i to C using sequencer code Christian Couder
2009-08-12  5:15 ` [PATCH 01/13] sequencer: add "do_fast_forward()" to perform a fast forward Christian Couder
2009-08-12  5:15 ` [PATCH 02/13] sequencer: add "--fast-forward" option to "git sequencer--helper" Christian Couder
2009-08-12  5:15 ` [PATCH 03/13] sequencer: let "git sequencer--helper" callers set "allow_dirty" Christian Couder
2009-08-12  5:15 ` [PATCH 04/13] rebase -i: use "git sequencer--helper --fast-forward" Christian Couder
2009-08-12  5:15 ` [PATCH 05/13] revert: libify pick Christian Couder
2009-08-12  5:15 ` [PATCH 06/13] pick: simplify "error(...)" followed by "return -1" Christian Couder
2009-08-12  5:15 ` [PATCH 07/13] pick: rename "pick()" to "pick_commit()" Christian Couder
2009-08-12  5:15 ` [PATCH 08/13] pick: remove useless PICK_REVERSE => PICK_ADD_NOTE code Christian Couder
2009-08-12  5:15 ` [PATCH 09/13] pick: simplify bogus comment about commiting immediately Christian Couder
2009-08-12  5:15 ` [PATCH 10/13] pick: libify "pick_help_msg()" Christian Couder
2009-08-12  5:15 ` [PATCH 11/13] sequencer: add "do_commit()" and related functions Christian Couder
2009-08-12  5:15 ` [PATCH 12/13] sequencer: add "--cherry-pick" option to "git sequencer--helper" Christian Couder
2009-08-12  5:15 ` [PATCH 13/13] rebase -i: use "git sequencer--helper --cherry-pick" Christian Couder
2009-08-12 21:49 ` [PATCH 00/13] more changes to port rebase -i to C using sequencer code Junio C Hamano

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox