From: Junio C Hamano <gitster@pobox.com>
To: "Elijah Newren via GitGitGadget" <gitgitgadget@gmail.com>
Cc: git@vger.kernel.org, Phillip Wood <phillip.wood123@gmail.com>,
Elijah Newren <newren@gmail.com>
Subject: Re: [PATCH v2 1/3] commit: reword the empty-commit rebase errors
Date: Thu, 27 Aug 2026 09:52:46 -0700 [thread overview]
Message-ID: <xmqq1pbjbj4x.fsf@gitster.g> (raw)
In-Reply-To: <xmqq5x0vbjxd.fsf@gitster.g> (Junio C. Hamano's message of "Thu, 27 Aug 2026 09:35:42 -0700")
Junio C Hamano <gitster@pobox.com> writes:
>> + die(_("cannot do a partial commit while resolving a commit that became empty."));
>
> That is a mouthful. It also is awkward to say "while resolving a commit".
This still stands, but I haven't come up with a better alternative yet.
> More importantly, I am not sure if whence == FROM_REBASE_PICK at
> this point in the code flow is a sufficient sign to tell that we
> were not just in the middle of a rebase, not just a rebase stopped
> with _some_ conflict, but the way the rebase stopped was because a
> step in rebase resulted in a commit that is no-op relative to the
> previous commit. What makes us certain that the rebase-pick is
> empty?
This confusion was because FROM_REBASE_PICK is a misleading name.
sequencer_determine_whence() is the only place that declares the
whence is FROM_REBASE_PICK, and it specifically checks if the
rebase-head and cherry-pick-head are identical before yielding that
value, so by definition we are dealing with an empty-pick situation.
This came from 430b75f720 (commit: give correct advice for empty
commit during a rebase, 2019-12-06); interestingly, the name of
FROM_REBASE_PICK and is_from_rebase() seem to have confused even the
originating commit ;-) The lines in question
+ else if (is_from_rebase(whence))
+ die(_("cannot do a partial commit during a rebase."));
are from that commit, which wanted to "give correct advice for empty
commit during a rebase".
We may want to
* change the code that does whence == FROM_REBASE_PICK to use
is_from_rebase(whence) everywhere (other than the implementation
of is_from_rebase() itself, of course).
* give FROM_REBASE_PICK and is_from_rebase() better names that
contain "empty" somewhere.
to unconfuse me.
next prev parent reply other threads:[~2026-08-27 16:52 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-26 5:21 [PATCH] commit: refuse to amend during conflict resolution Elijah Newren via GitGitGadget
2026-08-26 13:56 ` Phillip Wood
2026-08-27 0:21 ` Elijah Newren
2026-08-26 16:22 ` Junio C Hamano
2026-08-27 0:23 ` Elijah Newren
2026-08-26 16:39 ` Junio C Hamano
2026-08-27 0:24 ` Elijah Newren
2026-08-27 1:02 ` [PATCH v2 0/3] " Elijah Newren via GitGitGadget
2026-08-27 1:02 ` [PATCH v2 1/3] commit: reword the empty-commit rebase errors Elijah Newren via GitGitGadget
2026-08-27 15:19 ` Phillip Wood
2026-08-27 16:54 ` Junio C Hamano
2026-08-28 7:38 ` Elijah Newren
2026-08-27 16:35 ` Junio C Hamano
2026-08-27 16:52 ` Junio C Hamano [this message]
2026-08-28 7:38 ` Elijah Newren
2026-08-27 1:02 ` [PATCH v2 2/3] commit: refuse to amend during conflict resolution Elijah Newren via GitGitGadget
2026-08-27 15:19 ` Phillip Wood
2026-08-27 1:02 ` [PATCH v2 3/3] commit: refuse partial commits " Elijah Newren via GitGitGadget
2026-08-27 15:19 ` Phillip Wood
2026-08-27 15:19 ` [PATCH v2 0/3] commit: refuse to amend " Phillip Wood
2026-08-27 16:28 ` Elijah Newren
2026-08-28 7:44 ` [PATCH v3 0/5] " Elijah Newren via GitGitGadget
2026-08-28 7:44 ` [PATCH v3 1/5] commit: clarify FROM_REBASE_PICK and is_from_rebase() names Elijah Newren via GitGitGadget
2026-08-28 15:41 ` Junio C Hamano
2026-08-28 17:27 ` Elijah Newren
2026-08-28 7:44 ` [PATCH v3 2/5] commit: allow a partial commit when a rebase pick becomes empty Elijah Newren via GitGitGadget
2026-08-28 15:46 ` Junio C Hamano
2026-08-28 7:44 ` [PATCH v3 3/5] commit: reword the empty-commit rebase amend error Elijah Newren via GitGitGadget
2026-08-28 15:49 ` Junio C Hamano
2026-08-28 7:44 ` [PATCH v3 4/5] commit: refuse to amend during conflict resolution Elijah Newren via GitGitGadget
2026-08-28 7:44 ` [PATCH v3 5/5] commit: refuse partial commits " Elijah Newren via GitGitGadget
2026-08-28 16:18 ` Junio C Hamano
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=xmqq1pbjbj4x.fsf@gitster.g \
--to=gitster@pobox.com \
--cc=git@vger.kernel.org \
--cc=gitgitgadget@gmail.com \
--cc=newren@gmail.com \
--cc=phillip.wood123@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox