Grub Development Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Pavel Roskin <proski@gnu.org>
To: The development of GRUB 2 <grub-devel@gnu.org>
Subject: Re: [PATCH] Fix warning in fs/xfs.c
Date: Sun, 20 Jul 2008 16:28:05 -0400	[thread overview]
Message-ID: <1216585685.14762.11.camel@dv> (raw)
In-Reply-To: <87prp8ie41.fsf@xs4all.nl>

On Sun, 2008-07-20 at 20:50 +0200, Marco Gerards wrote:
> Pavel Roskin <proski@gnu.org> writes:
> > i4 and i8 are generally used by Linux XFS code to describe 32-bit and
> > 64-bit values if either can be used.  The "smallino" field was highly
> > misleading because it had to be negated.  It's the number of "big" (i8
> > or 64-bit) entries.  If it's 0, then the entries are "small".
> >
> > So it was natural to call it "i8count".  And once it was "i8count", it
> > was natural to call the first value "count".
> >
> > If you prefer another naming convention, let's rename the entries
> > according to it.  I was thinking having 2 32-bit integers "parent_hi"
> > and "parent_lo" or something like that.  Anyway, let's not use
> > "smallino" - "bigentries" would be better.
> 
> What I suggest is that you pick the names yourself or from a standard,
> instead of from Linux code.

OK, I'll try to be more creative.

-- 
Regards,
Pavel Roskin



  reply	other threads:[~2008-07-20 20:28 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-07-02  0:10 [PATCH] Fix warning in fs/xfs.c Pavel Roskin
2008-07-03 18:21 ` Marco Gerards
2008-07-03 18:48   ` Pavel Roskin
2008-07-20 18:50     ` Marco Gerards
2008-07-20 20:28       ` Pavel Roskin [this message]
2008-07-21 21:40       ` Cesare Leonardi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1216585685.14762.11.camel@dv \
    --to=proski@gnu.org \
    --cc=grub-devel@gnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox