Grub Development Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Robert Millan <rmh@aybabtu.com>
To: The development of GRUB 2 <grub-devel@gnu.org>
Subject: Re: [PATCH] allow user-configurable menucolor
Date: Thu, 3 Jan 2008 02:04:14 +0100	[thread overview]
Message-ID: <20080103010414.GC6843@thorin> (raw)
In-Reply-To: <200801030042.01855.okuji@enbug.org>

On Thu, Jan 03, 2008 at 12:42:01AM +0100, Yoshinori K. Okuji wrote:
> On Tuesday 01 January 2008 13:47, Robert Millan wrote:
> > This patch allows the following to work:
> >
> >   set color_normal=cyan/blue
> >   set color_highlight=white/blue
> 
> Although I am not a native speaker, I feel that they should be better 
> called "normal_color" and "highlight_color".

I like to come up with names that share their prefix, because this makes
the set more readable:

set color_normal=cyan/blue
set color_highlight=white/blue
set normal_color=cyan/blue
set highlight_color=white/blue

In the first one the "color_" section is easier to identify.  Althogh I
don't feel strongly about this of course :-)

> > which is equivalent to this command in GRUB Legacy:
> >
> >   color cyan/blue white/blue
> >
> > I haven't written a ChangeLog entry yet, because I'd like to receive
> > comments on the function names.  I don't really like
> > `parse_single_color_name' and `parse_color_name' but I don't know what to
> > call them :-(.  What conventions are there for referring to single colors
> > (i.e. those that describe only FG or only BG, not both) and complete colors
> > (FG + BG) ?
> 
> No such word, AFAIK. You know, it is ugly, because you want to put two 
> separate things into one place. ;)
> 
> Just look at CSS...
> 
> div {
>   color: black;
>   background-color: white;
> }
> 
> So, if you don't hesitate to create so many variables, you can simply 
> create "normal_color", "normal_background_color", "highlight_color" 
> and "highlight_background_color", although I don't know who would like it.

Sounds like this could save us some code space.  I'd go for _fg and _bg to
preserve alignment in the names.

-- 
Robert Millan

<GPLv2> I know my rights; I want my phone call!
<DRM> What use is a phone call, if you are unable to speak?
(as seen on /.)



  reply	other threads:[~2008-01-03  1:08 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-01-01 12:47 [PATCH] allow user-configurable menucolor Robert Millan
2008-01-01 13:14 ` Vesa Jääskeläinen
2008-01-01 13:40   ` Robert Millan
2008-01-01 13:51     ` Vesa Jääskeläinen
2008-01-01 14:45       ` Robert Millan
2008-01-01 17:38         ` Robert Millan
2008-01-02 21:48           ` Robert Millan
2008-01-02 23:55             ` Yoshinori K. Okuji
2008-01-03  0:56               ` Robert Millan
2008-01-02 23:42 ` Yoshinori K. Okuji
2008-01-03  1:04   ` Robert Millan [this message]
2008-01-03 15:35     ` Robert Millan
2008-01-03 16:04       ` Vesa Jääskeläinen
2008-01-03 16:38         ` Robert Millan
2008-01-23  8:56           ` Marco Gerards
2008-01-04  8:02         ` opening new context (was: [PATCH] allow user-configurable menucolor) Robert Millan
2008-01-05  1:34           ` Yoshinori K. Okuji
2008-01-05 11:49             ` Robert Millan
2008-01-05 12:03               ` Yoshinori K. Okuji
2008-01-05 12:09                 ` Robert Millan
2008-01-05 21:45       ` [PATCH] allow user-configurable menucolor Jeroen Dekkers
2008-01-05 23:42         ` Robert Millan
2008-01-06 11:33           ` Jeroen Dekkers
2008-01-06 12:54             ` Robert Millan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080103010414.GC6843@thorin \
    --to=rmh@aybabtu.com \
    --cc=grub-devel@gnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox