Igt-dev Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH i-g-t v2 0/2] gpgpu-fill changes for xehp and xe3
@ 2026-08-03  5:16 Zbigniew Kempczyński
  2026-08-03  5:16 ` [PATCH i-g-t v2 1/2] lib/gpgpu_fill: Rename variable to reflect function purpose Zbigniew Kempczyński
                   ` (6 more replies)
  0 siblings, 7 replies; 10+ messages in thread
From: Zbigniew Kempczyński @ 2026-08-03  5:16 UTC (permalink / raw)
  To: igt-dev; +Cc: Zbigniew Kempczyński

Alters xe3 shader and touches xehp due to changes in setting canonical
offset differences between i915 and xe.

Dominik Grzegorzek (1):
  lib/gpgpu_fill: Implement gpgpu_fill for XE3 which uses ugm instead of
    tgm

Zbigniew Kempczyński (1):
  lib/gpgpu_fill: Rename variable to reflect function purpose

 lib/gpgpu_fill.c                   | 49 +++++++++++++++++++++++++-----
 lib/gpgpu_fill.c.gen.iga64_codes.c | 20 +++++++++++-
 lib/gpgpu_fill.h                   |  2 +-
 lib/gpu_cmds.c                     |  2 +-
 4 files changed, 63 insertions(+), 10 deletions(-)

-- 
2.54.0


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2026-08-05 18:41 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-03  5:16 [PATCH i-g-t v2 0/2] gpgpu-fill changes for xehp and xe3 Zbigniew Kempczyński
2026-08-03  5:16 ` [PATCH i-g-t v2 1/2] lib/gpgpu_fill: Rename variable to reflect function purpose Zbigniew Kempczyński
2026-08-03 10:07   ` Piatkowski, Dominik Karol
2026-08-03  5:16 ` [PATCH i-g-t v2 2/2] lib/gpgpu_fill: Implement gpgpu_fill for XE3 which uses ugm instead of tgm Zbigniew Kempczyński
2026-08-03 10:07   ` Piatkowski, Dominik Karol
2026-08-03 17:43 ` ✗ Xe.CI.FULL: failure for gpgpu-fill changes for xehp and xe3 Patchwork
2026-08-05  3:48 ` ✓ Xe.CI.BAT: success for gpgpu-fill changes for xehp and xe3 (rev2) Patchwork
2026-08-05  3:58 ` ✓ i915.CI.BAT: " Patchwork
2026-08-05  8:45 ` ✓ Xe.CI.FULL: " Patchwork
2026-08-05 18:41 ` ✓ i915.CI.Full: " Patchwork

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox