From: Jani Nikula <jani.nikula@intel.com>
To: igt-dev@lists.freedesktop.org
Cc: jani.nikula@intel.com, ville.syrjala@linux.intel.com,
Kamil Konieczny <kamil.konieczny@linux.intel.com>
Subject: [PATCH i-g-t 0/4] igt: rename pipe to hardware_pipe
Date: Tue, 1 Sep 2026 11:46:36 +0300 [thread overview]
Message-ID: <cover.1788252273.git.jani.nikula@intel.com> (raw)
To emphasize the enum pipe and crtc->pipe are vendor-specific hardware
concepts, rename them to hardware_pipe. Further explanations in patch 3.
Jani Nikula (4):
tests/kms_chamelium_color_pipeline: prefer igt_crtc_name() over
kmstest_pipe_name()
tests/intel/kms_joiner_helper: iterate CRTCs instead of pipes
lib/kms: rename enum pipe to hardware_pipe, crtc->pipe to
crtc->hardware_pipe
lib/kms: use enum hardware_pipe for __intel_get_pipe_from_crtc_index()
return type
lib/igt_kms.c | 40 ++++++++++---------
lib/igt_kms.h | 22 ++++++----
.../chamelium/kms_chamelium_color_pipeline.c | 2 +-
tests/intel/kms_busy.c | 16 ++++----
tests/intel/kms_dp_link_training.c | 2 +-
tests/intel/kms_dsc.c | 2 +-
tests/intel/kms_dsc_helper.c | 4 +-
tests/intel/kms_dsc_helper.h | 2 +-
tests/intel/kms_frontbuffer_tracking.c | 2 +-
tests/intel/kms_joiner.c | 32 +++++++--------
tests/intel/kms_joiner_helper.c | 15 +++----
tests/intel/kms_mst.c | 2 +-
tests/intel/kms_pipe_b_c_ivb.c | 4 +-
tests/intel/kms_pipe_stress.c | 24 +++++------
tests/intel/kms_pm_dc.c | 8 ++--
tests/intel/kms_pm_lpsp.c | 2 +-
tests/intel/kms_psr2_sf.c | 4 +-
tests/intel/perf_pmu.c | 2 +-
tests/kms_cursor_crc.c | 2 +-
tests/kms_cursor_edge_walk.c | 2 +-
tests/kms_display_modes.c | 2 +-
tests/kms_panel_fitting.c | 2 +-
tests/kms_plane_scaling.c | 2 +-
23 files changed, 102 insertions(+), 93 deletions(-)
--
2.47.3
next reply other threads:[~2026-09-01 8:49 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-01 8:46 Jani Nikula [this message]
2026-09-01 8:46 ` [PATCH i-g-t 1/4] tests/kms_chamelium_color_pipeline: prefer igt_crtc_name() over kmstest_pipe_name() Jani Nikula
2026-09-02 14:34 ` Kamil Konieczny
2026-09-01 8:46 ` [PATCH i-g-t 2/4] tests/intel/kms_joiner_helper: iterate CRTCs instead of pipes Jani Nikula
2026-09-02 14:45 ` Kamil Konieczny
2026-09-02 21:40 ` Jani Nikula
2026-09-03 11:31 ` Kamil Konieczny
2026-09-01 8:46 ` [PATCH i-g-t 3/4] lib/kms: rename enum pipe to hardware_pipe, crtc->pipe to crtc->hardware_pipe Jani Nikula
2026-09-02 17:33 ` Kamil Konieczny
2026-09-01 8:46 ` [PATCH i-g-t 4/4] lib/kms: use enum hardware_pipe for __intel_get_pipe_from_crtc_index() return type Jani Nikula
2026-09-03 11:39 ` Kamil Konieczny
2026-09-01 23:01 ` ✓ i915.CI.BAT: success for igt: rename pipe to hardware_pipe Patchwork
2026-09-02 7:15 ` ✓ Xe.CI.BAT: " Patchwork
2026-09-02 13:29 ` ✓ Xe.CI.FULL: " Patchwork
2026-09-02 14:21 ` ✗ i915.CI.Full: failure " Patchwork
2026-09-07 8:09 ` [PATCH i-g-t 0/4] " Jani Nikula
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cover.1788252273.git.jani.nikula@intel.com \
--to=jani.nikula@intel.com \
--cc=igt-dev@lists.freedesktop.org \
--cc=kamil.konieczny@linux.intel.com \
--cc=ville.syrjala@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox