From: "Pandiyan, Dhinakaran" <dhinakaran.pandiyan@intel.com>
To: "Navare, Manasi D" <manasi.d.navare@intel.com>
Cc: "Vetter, Daniel" <daniel.vetter@intel.com>,
"intel-gfx@lists.freedesktop.org"
<intel-gfx@lists.freedesktop.org>,
"dri-devel@lists.freedesktop.org"
<dri-devel@lists.freedesktop.org>
Subject: Re: [PATCH 2/5] drm: Define a work struct for scheduling a uevent for modeset retry
Date: Tue, 25 Oct 2016 06:30:29 +0000 [thread overview]
Message-ID: <1477378009.19344.2.camel@dk-H97M-D3H> (raw)
In-Reply-To: <20161025062802.GA4440@intel.com>
On Mon, 2016-10-24 at 23:28 -0700, Manasi Navare wrote:
> On Sat, Oct 22, 2016 at 10:48:13AM +0200, Daniel Vetter wrote:
> > On Fri, Oct 21, 2016 at 04:45:40PM -0700, Manasi Navare wrote:
> > > This work struct will be used to schedule a uevent on a separate
> > > thread. This will be scheduled after a link train failure during modeset
> > > to indicate a modeset retry request. It will get executed after the
> > > current modeset is complete and all locks are released. This was
> > > required to avoid deadlock.
> > >
> > > Cc: dri-devel@lists.freedesktop.org
> > > Cc: Jani Nikula <jani.nikula@linux.intel.com>
> > > Cc: Daniel Vetter <daniel.vetter@intel.com>
> > > Cc: Ville Syrjala <ville.syrjala@linux.intel.com>
> > >
> > > Signed-off-by: Manasi Navare <manasi.d.navare@intel.com>
> > > ---
> > > include/drm/drm_connector.h | 5 +++++
> > > 1 file changed, 5 insertions(+)
> > >
> > > diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h
> > > index ac9d7d8..fcf6b97 100644
> > > --- a/include/drm/drm_connector.h
> > > +++ b/include/drm/drm_connector.h
> > > @@ -682,6 +682,11 @@ struct drm_connector {
> > > uint8_t num_h_tile, num_v_tile;
> > > uint8_t tile_h_loc, tile_v_loc;
> > > uint16_t tile_h_size, tile_v_size;
> > > +
> > > + /* Work struct to schedule a uevent on link train failure for
> > > + * DisplayPort.
> > > + */
> > > + struct work_struct i915_modeset_retry_work;
> >
> > You cannot put i915 stuff into core structs.
> > -Daniel
> >
> > > };
>
> I will rename it to use modeset_retry_work instead.
>
> Manasi
Why not move it struct intel_connector? The work function is defined in
intel_dp.c afaict
-DK
> > >
> > > #define obj_to_connector(x) container_of(x, struct drm_connector, base)
> > > --
> > > 1.9.1
> > >
> > > _______________________________________________
> > > Intel-gfx mailing list
> > > Intel-gfx@lists.freedesktop.org
> > > https://lists.freedesktop.org/mailman/listinfo/intel-gfx
> >
> > --
> > Daniel Vetter
> > Software Engineer, Intel Corporation
> > http://blog.ffwll.ch
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/intel-gfx
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2016-10-25 6:30 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-10-21 23:45 [PATCH 0/5] Handle link training failure for DDI platforms Manasi Navare
2016-10-21 23:45 ` [PATCH 1/5] drm: Add atomic helper to redo a modeset on current mode Manasi Navare
2016-10-22 8:47 ` Daniel Vetter
2016-10-22 14:01 ` [Intel-gfx] " Daniel Vetter
2016-10-22 14:46 ` Ville Syrjälä
2016-10-24 6:00 ` Daniel Vetter
2016-10-24 6:12 ` Manasi Navare
2016-10-24 6:33 ` Daniel Vetter
2016-10-24 7:00 ` Manasi Navare
2016-10-24 7:12 ` Daniel Vetter
2016-10-24 18:38 ` [Intel-gfx] " Sean Paul
2016-10-25 6:35 ` Daniel Vetter
2016-10-24 22:08 ` Manasi Navare
2016-10-25 6:40 ` [Intel-gfx] " Daniel Vetter
2016-10-25 12:09 ` Jani Nikula
2016-10-25 22:28 ` Manasi Navare
2016-10-25 22:38 ` Rodrigo Vivi
2016-10-21 23:45 ` [PATCH 2/5] drm: Define a work struct for scheduling a uevent for modeset retry Manasi Navare
2016-10-22 8:48 ` Daniel Vetter
2016-10-25 6:28 ` Manasi Navare
2016-10-25 6:30 ` Pandiyan, Dhinakaran [this message]
2016-10-25 6:45 ` [Intel-gfx] " Daniel Vetter
2016-10-21 23:45 ` [PATCH 3/5] drm/i915: Change the placement of some static functions in intel_dp.c Manasi Navare
2016-10-21 23:45 ` [PATCH 4/5] drm/i915; Add a function to return index of link rate Manasi Navare
2016-10-25 6:33 ` Pandiyan, Dhinakaran
2016-10-21 23:45 ` [PATCH 5/5] drm/i915: Link Rate fallback on Link training failure Manasi Navare
2016-10-24 17:53 ` Jim Bride
2016-10-25 6:23 ` Pandiyan, Dhinakaran
2016-10-25 18:32 ` Manasi Navare
2016-10-25 12:17 ` Jani Nikula
2016-10-25 18:00 ` Jim Bride
2016-10-25 18:37 ` Manasi Navare
2016-10-22 0:16 ` ✗ Fi.CI.BAT: warning for Handle link training failure for DDI platforms Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1477378009.19344.2.camel@dk-H97M-D3H \
--to=dhinakaran.pandiyan@intel.com \
--cc=daniel.vetter@intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=manasi.d.navare@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox