From: Jesse Barnes <jbarnes@virtuousgeek.org>
To: Chris Wilson <chris@chris-wilson.co.uk>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 2/4] drm/i915: add plane enable/disable functions
Date: Thu, 30 Dec 2010 13:49:35 -0800 [thread overview]
Message-ID: <20101230134935.061d283a@jbarnes-desktop> (raw)
In-Reply-To: <5b55a1$j45j3q@fmsmga002.fm.intel.com>
On Thu, 30 Dec 2010 21:45:22 +0000
Chris Wilson <chris@chris-wilson.co.uk> wrote:
> On Thu, 30 Dec 2010 13:40:30 -0800, Jesse Barnes <jbarnes@virtuousgeek.org> wrote:
> > On Thu, 30 Dec 2010 21:34:46 +0000
> > Chris Wilson <chris@chris-wilson.co.uk> wrote:
> >
> > > Trivial comment, on passing...
> > >
> > > On Thu, 30 Dec 2010 13:16:30 -0800, Jesse Barnes <jbarnes@virtuousgeek.org> wrote:
> > > > Add plane enable/disable functions to prevent duplicated code and allow
> > > > us to easily check for plane enable/disable requirements (such as pipe
> > > > enable).
> > >
> > > > +static void intel_disable_plane(struct drm_i915_private *dev_priv,
> > > > + enum plane plane, enum pipe pipe)
> > > > +{
> > > > + int reg;
> > > > + u32 val;
> > > > +
> > > > + reg = DSPCNTR(plane);
> > > > + val = I915_READ(reg);
> > > > + val &= ~DISPLAY_PLANE_ENABLE;
> > > > + I915_WRITE(reg, val);
> > > > + POSTING_READ(reg);
> > >
> > > > + reg = DSPADDR(plane);
> > > > + I915_WRITE(reg, I915_READ(reg)); /* trigger an update */
> > >
> > > Use intel_flush_display_plane(dev_priv, plane); though maybe that function
> > > becomes redundant? Unlikely...
> >
> > It was only used in one place after I added this, so I just stuffed the
> > update trigger into this function and deleted flush_display_plane.
>
> That was in the next function I read. ;-) I'd argue that the
> intel_flush_display_plane(), with the requisite whitespacing, remains
> clearer than the block of I915_READ/I915_WRITE + comment.
Sure, I can put it back. Self-documenting function names ftw.
--
Jesse Barnes, Intel Open Source Technology Center
next prev parent reply other threads:[~2010-12-30 21:49 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-12-30 21:16 [RFC/RFT] mode setting assertion functions Jesse Barnes
2010-12-30 21:16 ` [PATCH 1/4] drm/i915: add pipe enable/disable functions Jesse Barnes
2010-12-30 21:16 ` [PATCH 2/4] drm/i915: add plane " Jesse Barnes
2010-12-30 21:34 ` Chris Wilson
2010-12-30 21:40 ` Jesse Barnes
2010-12-30 21:45 ` Chris Wilson
2010-12-30 21:49 ` Jesse Barnes [this message]
2010-12-30 21:16 ` [PATCH 3/4] drm/i915: add panel lock assertion function Jesse Barnes
2010-12-30 21:16 ` [PATCH 4/4] drm/i915: add PLL enable/disable functions Jesse Barnes
2010-12-30 21:41 ` Chris Wilson
2010-12-30 21:47 ` Jesse Barnes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20101230134935.061d283a@jbarnes-desktop \
--to=jbarnes@virtuousgeek.org \
--cc=chris@chris-wilson.co.uk \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox