From: Jesse Barnes <jbarnes@virtuousgeek.org>
To: Ben Widawsky <ben@bwidawsk.net>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 03/10] drm/i915: introduce gtt_pte_t
Date: Thu, 25 Oct 2012 13:49:13 -0700 [thread overview]
Message-ID: <20121025134913.24ee2f06@jbarnes-desktop> (raw)
In-Reply-To: <1350956055-3224-4-git-send-email-ben@bwidawsk.net>
On Mon, 22 Oct 2012 18:34:08 -0700
Ben Widawsky <ben@bwidawsk.net> wrote:
> This will make the calculations of size easier to read instead of just
> assuming uint32_t everywhere.
>
> Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
> ---
> drivers/gpu/drm/i915/i915_gem_gtt.c | 14 ++++++++------
> 1 file changed, 8 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_gem_gtt.c b/drivers/gpu/drm/i915/i915_gem_gtt.c
> index 2b75028..a769b3c 100644
> --- a/drivers/gpu/drm/i915/i915_gem_gtt.c
> +++ b/drivers/gpu/drm/i915/i915_gem_gtt.c
> @@ -29,13 +29,15 @@
> #include "i915_trace.h"
> #include "intel_drv.h"
>
> +typedef uint32_t gtt_pte_t;
> +
> /* PPGTT support for Sandybdrige/Gen6 and later */
> static void i915_ppgtt_clear_range(struct i915_hw_ppgtt *ppgtt,
> unsigned first_entry,
> unsigned num_entries)
> {
> - uint32_t *pt_vaddr;
> - uint32_t scratch_pte;
> + gtt_pte_t *pt_vaddr;
> + gtt_pte_t scratch_pte;
> unsigned act_pd = first_entry / I915_PPGTT_PT_ENTRIES;
> unsigned first_pte = first_entry % I915_PPGTT_PT_ENTRIES;
> unsigned last_pte, i;
> @@ -120,7 +122,7 @@ int i915_gem_init_aliasing_ppgtt(struct drm_device *dev)
> i915_ppgtt_clear_range(ppgtt, 0,
> ppgtt->num_pd_entries*I915_PPGTT_PT_ENTRIES);
>
> - ppgtt->pd_offset = (first_pd_entry_in_global_pt)*sizeof(uint32_t);
> + ppgtt->pd_offset = (first_pd_entry_in_global_pt)*sizeof(gtt_pte_t);
>
> dev_priv->mm.aliasing_ppgtt = ppgtt;
>
> @@ -170,9 +172,9 @@ void i915_gem_cleanup_aliasing_ppgtt(struct drm_device *dev)
> static void i915_ppgtt_insert_sg_entries(struct i915_hw_ppgtt *ppgtt,
> const struct sg_table *pages,
> unsigned first_entry,
> - uint32_t pte_flags)
> + gtt_pte_t pte_flags)
> {
> - uint32_t *pt_vaddr, pte;
> + gtt_pte_t *pt_vaddr, pte;
> unsigned act_pd = first_entry / I915_PPGTT_PT_ENTRIES;
> unsigned first_pte = first_entry % I915_PPGTT_PT_ENTRIES;
> unsigned i, j, m, segment_len;
> @@ -215,7 +217,7 @@ void i915_ppgtt_bind_object(struct i915_hw_ppgtt *ppgtt,
> struct drm_i915_gem_object *obj,
> enum i915_cache_level cache_level)
> {
> - uint32_t pte_flags = GEN6_PTE_VALID;
> + gtt_pte_t pte_flags = GEN6_PTE_VALID;
>
> switch (cache_level) {
> case I915_CACHE_LLC_MLC:
Reviewed-by: Jesse Barnes <jbarnes@virtuousgeek.org>
--
Jesse Barnes, Intel Open Source Technology Center
next prev parent reply other threads:[~2012-10-25 20:49 UTC|newest]
Thread overview: 50+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-23 1:34 [PATCH 00/10] Kill AGP dependencies for Gen6+ Ben Widawsky
2012-10-23 1:34 ` [PATCH 01/10] drm/i915: No LLC_MLC for HSW Ben Widawsky
2012-10-23 10:15 ` Mika Kuoppala
2012-10-25 20:47 ` Jesse Barnes
2012-10-26 1:03 ` Ben Widawsky
2012-10-23 1:34 ` [PATCH 02/10] drm/i915: Add dev to ppgtt Ben Widawsky
2012-10-25 20:48 ` Jesse Barnes
2012-10-23 1:34 ` [PATCH 03/10] drm/i915: introduce gtt_pte_t Ben Widawsky
2012-10-25 20:49 ` Jesse Barnes [this message]
2012-10-23 1:34 ` [PATCH 04/10] drm/i915: Extract PPGTT pte encoding Ben Widawsky
2012-10-25 20:50 ` Jesse Barnes
2012-10-23 1:34 ` [PATCH 05/10] drm/i915: move more pte encoding to pte encode Ben Widawsky
2012-10-25 20:51 ` Jesse Barnes
2012-10-31 10:52 ` Daniel Vetter
2012-10-23 1:34 ` [PATCH 06/10] drm/i915: Stop using AGP layer for GEN6+ Ben Widawsky
2012-10-23 9:59 ` Chris Wilson
2012-10-23 14:57 ` Ben Widawsky
2012-10-23 14:58 ` Daniel Vetter
2012-10-23 19:57 ` Ben Widawsky
2012-10-23 20:03 ` Daniel Vetter
2012-10-23 20:27 ` Ben Widawsky
2012-10-25 20:55 ` Jesse Barnes
2012-10-25 20:54 ` Jesse Barnes
[not found] ` <878vaxwk61.fsf@gaia.fi.intel.com>
2012-10-24 17:56 ` Ben Widawsky
2012-10-26 20:54 ` [PATCH 06/10 v2] " Ben Widawsky
2012-10-29 2:08 ` [PATCH 6/9 v3] " Ben Widawsky
2012-10-31 9:57 ` Daniel Vetter
2012-10-31 15:51 ` Ben Widawsky
2012-10-31 10:37 ` [PATCH 06/10 v2] " Chris Wilson
2012-10-23 1:34 ` [PATCH 07/10] drm/i915: Calculate correct stolen size for GEN7+ Ben Widawsky
2012-10-25 21:06 ` Jesse Barnes
2012-10-25 22:15 ` Ben Widawsky
2012-10-25 22:39 ` Jesse Barnes
2012-10-23 1:34 ` [PATCH 08/10] drm/i915: Kill off now unused gen6+ AGP code Ben Widawsky
2012-10-25 21:07 ` Jesse Barnes
2012-10-23 1:34 ` [PATCH 09/10] drm/i915: flush system agent TLBs on SNB Ben Widawsky
2012-10-23 14:17 ` Jesse Barnes
2012-10-23 14:28 ` Daniel Vetter
2012-10-23 14:35 ` Jesse Barnes
2012-10-23 14:42 ` Ben Widawsky
2012-10-25 21:07 ` Jesse Barnes
2012-10-26 20:55 ` [PATCH 09/10 v2] " Ben Widawsky
2012-10-23 1:34 ` [PATCH 10/10] drm/i915: Kill off actually requiring AGP Ben Widawsky
2012-10-23 2:03 ` Ben Widawsky
2012-10-25 21:09 ` Jesse Barnes
2012-10-25 22:15 ` Ben Widawsky
2012-10-25 22:39 ` Jesse Barnes
2012-10-25 22:47 ` Daniel Vetter
2012-10-26 20:52 ` Ben Widawsky
2012-10-26 20:58 ` [PATCH 00/10] Kill AGP dependencies for Gen6+ Ben Widawsky
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20121025134913.24ee2f06@jbarnes-desktop \
--to=jbarnes@virtuousgeek.org \
--cc=ben@bwidawsk.net \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox