Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: Jesse Barnes <jbarnes@virtuousgeek.org>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 2/8] lib: Introduce drmtest_skip_on_simulation()
Date: Thu, 18 Jul 2013 18:42:04 +0200	[thread overview]
Message-ID: <20130718164204.GU4550@phenom.ffwll.local> (raw)
In-Reply-To: <20130718091834.547d863c@jbarnes-desktop>

On Thu, Jul 18, 2013 at 09:18:34AM -0700, Jesse Barnes wrote:
> On Thu, 18 Jul 2013 16:19:07 +0100
> Damien Lespiau <damien.lespiau@intel.com> wrote:
> 
> > This will allow us to explicitely blacklist tests we don't want to run
> > on simulation.
> 
> So FWIW I'll reiterate that I'd prefer to manage this in either the
> Makefile target for the tests (e.g. have a single_kernel_sim_tests or
> somesuch), or separate scripts altogether for running the different
> types of tests, with specific subsets for running on simulation.

We have lots of tests with subtests, and sometimes we might want to
exclude just a few of them, not all. Doing that at the Makefile level is a
bit too coarse imo.

> Having to sprinkle skip_on_simulation into the actual tests seems like
> duplicated effort across every test.
> 
> For the cases where the args or iterations differ, it might be better
> to simply take an argv for the values, and have the sim vs. full
> scripts pass different values.

We have tons of tests meanwhile, if you want to run them with piglit
passing individual options with argv for each test doesn't scale better
imo than just baking those into the tests.

It's gonna suck a bit one way or the other I guess :(
-Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch

  parent reply	other threads:[~2013-07-18 16:42 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-07-18 15:19 Provide a simulation friendly test environment v4 Damien Lespiau
2013-07-18 15:19 ` [PATCH 1/8] lib: Rename IGT_QUICK to INTEL_SIMULATION Damien Lespiau
2013-07-18 15:19 ` [PATCH 2/8] lib: Introduce drmtest_skip_on_simulation() Damien Lespiau
2013-07-18 16:18   ` Jesse Barnes
2013-07-18 16:31     ` Ben Widawsky
2013-07-18 16:55       ` Damien Lespiau
2013-07-18 16:57         ` Jesse Barnes
2013-07-18 21:54         ` Daniel Vetter
2013-07-18 16:42     ` Daniel Vetter [this message]
2013-07-18 15:19 ` [PATCH 3/8] lib: Remove old dead code intel_batchbuffer_emit_mi_flush() Damien Lespiau
2013-07-18 15:19 ` [PATCH 4/8] tests: Black list tests we don't want to run on simulation Damien Lespiau
2013-07-18 15:19 ` [PATCH 5/8] tests: Instrument tests run in simulation to run quickly Damien Lespiau
2013-07-18 15:19 ` [PATCH 6/8] tests: Instrument gem_lut_handle for simulation Damien Lespiau
2013-07-18 15:19 ` [PATCH 7/8] tests: Instrument gem_seqno_wrap to run in simulation Damien Lespiau
2013-07-18 15:19 ` [PATCH 8/8] tests: Add some tiled tests to the runs on simulation Damien Lespiau
2013-07-18 15:50 ` Provide a simulation friendly test environment v4 Daniel Vetter
2013-07-19 11:21   ` Damien Lespiau

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130718164204.GU4550@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=jbarnes@virtuousgeek.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox