From: "Ville Syrjälä" <ville.syrjala@linux.intel.com>
To: Paulo Zanoni <przanoni@gmail.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 17/17] drm/i915: Add comments about units of latency values
Date: Fri, 2 Aug 2013 19:09:31 +0300 [thread overview]
Message-ID: <20130802160931.GO5004@intel.com> (raw)
In-Reply-To: <CA+gsUGS+-9DnMpc+cv2-VyO51fW=frBTCNFSFgiV+wx7cHGsqQ@mail.gmail.com>
On Fri, Aug 02, 2013 at 12:58:07PM -0300, Paulo Zanoni wrote:
> 2013/8/1 <ville.syrjala@linux.intel.com>:
> > From: Ville Syrjälä <ville.syrjala@linux.intel.com>
> >
> > All the ILK+ WM compute functions take the latency values in 0.1us
> > units. Add a few comments to remind people about that.
> >
> > Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
>
> Reviewed-by: Paulo Zanoni <paulo.r.zanoni@intel.com>
>
> (but I would have written Latency instead of latency :P )
I was considering going for full blown kernel-doc, but since we don't
currently generate docs for i915, i just used the name of the argument
in question.
> > ---
> > drivers/gpu/drm/i915/intel_pm.c | 17 ++++++++++++++---
> > 1 file changed, 14 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/i915/intel_pm.c b/drivers/gpu/drm/i915/intel_pm.c
> > index 5fe8c4e..51f445f 100644
> > --- a/drivers/gpu/drm/i915/intel_pm.c
> > +++ b/drivers/gpu/drm/i915/intel_pm.c
> > @@ -2108,6 +2108,7 @@ static uint32_t ilk_pipe_pixel_rate(struct drm_device *dev,
> > return pixel_rate;
> > }
> >
> > +/* latency must be in 0.1us units. */
> > static uint32_t ilk_wm_method1(uint32_t pixel_rate, uint8_t bytes_per_pixel,
> > uint32_t latency)
> > {
> > @@ -2122,6 +2123,7 @@ static uint32_t ilk_wm_method1(uint32_t pixel_rate, uint8_t bytes_per_pixel,
> > return ret;
> > }
> >
> > +/* latency must be in 0.1us units. */
> > static uint32_t ilk_wm_method2(uint32_t pixel_rate, uint32_t pipe_htotal,
> > uint32_t horiz_pixels, uint8_t bytes_per_pixel,
> > uint32_t latency)
> > @@ -2185,7 +2187,10 @@ enum hsw_data_buf_partitioning {
> > HSW_DATA_BUF_PART_5_6,
> > };
> >
> > -/* For both WM_PIPE and WM_LP. */
> > +/*
> > + * For both WM_PIPE and WM_LP.
> > + * mem_value must be in 0.1us units.
> > + */
> > static uint32_t ilk_compute_pri_wm(struct hsw_pipe_wm_parameters *params,
> > uint32_t mem_value,
> > bool is_lp)
> > @@ -2212,7 +2217,10 @@ static uint32_t ilk_compute_pri_wm(struct hsw_pipe_wm_parameters *params,
> > return min(method1, method2);
> > }
> >
> > -/* For both WM_PIPE and WM_LP. */
> > +/*
> > + * For both WM_PIPE and WM_LP.
> > + * mem_value must be in 0.1us units.
> > + */
> > static uint32_t ilk_compute_spr_wm(struct hsw_pipe_wm_parameters *params,
> > uint32_t mem_value)
> > {
> > @@ -2232,7 +2240,10 @@ static uint32_t ilk_compute_spr_wm(struct hsw_pipe_wm_parameters *params,
> > return min(method1, method2);
> > }
> >
> > -/* For both WM_PIPE and WM_LP. */
> > +/*
> > + * For both WM_PIPE and WM_LP.
> > + * mem_value must be in 0.1us units.
> > + */
> > static uint32_t ilk_compute_cur_wm(struct hsw_pipe_wm_parameters *params,
> > uint32_t mem_value)
> > {
> > --
> > 1.8.1.5
> >
> > _______________________________________________
> > Intel-gfx mailing list
> > Intel-gfx@lists.freedesktop.org
> > http://lists.freedesktop.org/mailman/listinfo/intel-gfx
>
>
>
> --
> Paulo Zanoni
--
Ville Syrjälä
Intel OTC
next prev parent reply other threads:[~2013-08-02 16:09 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-08-01 13:18 [PATCH 0/17] drm/i915: ILK+ watermark prep patches ville.syrjala
2013-08-01 13:18 ` [PATCH v2 01/17] drm/i915: Add scaled paramater to update_sprite_watermarks() ville.syrjala
2013-08-05 16:23 ` Daniel Vetter
2013-08-01 13:18 ` [PATCH 02/17] drm/i915: Pass the actual sprite width to watermarks functions ville.syrjala
2013-08-01 13:18 ` [PATCH 03/17] drm/i915: Calculate the sprite WM based on the source width instead of the destination width ville.syrjala
2013-08-01 13:18 ` [PATCH 04/17] drm/i915: Rename hsw_wm_get_pixel_rate to ilk_pipe_pixel_rate ville.syrjala
2013-08-01 13:18 ` [PATCH 05/17] drm/i915: Rename most wm compute functions to ilk_ prefix ville.syrjala
2013-08-01 13:18 ` [PATCH 06/17] drm/i915: Don't pass "mem_value" to ilk_compute_fbc_wm ville.syrjala
2013-08-01 13:18 ` [PATCH 07/17] drm/i915: Change the watermark latency type to uint16_t ville.syrjala
2013-08-01 13:18 ` [PATCH 08/17] drm/i915: Split out reading of HSW watermark latency values ville.syrjala
2013-08-01 13:18 ` [PATCH 09/17] drm/i915: Don't multiply the watermark latency values too early ville.syrjala
2013-08-01 13:18 ` [PATCH 10/17] drm/i915: Add SNB/IVB support to intel_read_wm_latency ville.syrjala
2013-08-01 13:18 ` [PATCH 11/17] drm/i915: Add ILK " ville.syrjala
2013-08-02 14:16 ` Paulo Zanoni
2013-08-01 13:18 ` [PATCH v2 12/17] drm/i915: Store the watermark latency values in dev_priv ville.syrjala
2013-08-01 14:23 ` Chris Wilson
2013-08-05 16:25 ` Daniel Vetter
2013-08-05 16:41 ` Chris Wilson
2013-08-02 14:28 ` Paulo Zanoni
2013-08-01 13:18 ` [PATCH v2 13/17] drm/i915: Use the stored cursor and plane latencies properly ville.syrjala
2013-08-02 14:34 ` Paulo Zanoni
2013-08-01 13:18 ` [PATCH v2 14/17] drm/i915: Print the watermark latencies during init ville.syrjala
2013-08-02 14:41 ` Paulo Zanoni
2013-08-02 14:55 ` Ville Syrjälä
2013-08-01 13:18 ` [PATCH v2 15/17] drm/i915: Disable specific watermark levels when latency is zero ville.syrjala
2013-08-02 14:48 ` Paulo Zanoni
2013-08-05 16:31 ` Daniel Vetter
2013-08-01 13:18 ` [PATCH 16/17] drm/i915: Use the watermark latency values from dev_priv for ILK/SNB/IVB too ville.syrjala
2013-08-02 15:16 ` Paulo Zanoni
2013-08-02 15:23 ` Ville Syrjälä
2013-08-02 15:55 ` Paulo Zanoni
2013-08-01 13:18 ` [PATCH 17/17] drm/i915: Add comments about units of latency values ville.syrjala
2013-08-02 15:58 ` Paulo Zanoni
2013-08-02 16:09 ` Ville Syrjälä [this message]
2013-08-05 16:41 ` Daniel Vetter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130802160931.GO5004@intel.com \
--to=ville.syrjala@linux.intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=przanoni@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox