From: Jesse Barnes <jbarnes@virtuousgeek.org>
To: Daniel Vetter <daniel@ffwll.ch>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 1/2] drm/i915/vlv: Make the vlv_dpio_read/vlv_dpio_write more PHY centric
Date: Tue, 26 Nov 2013 15:10:22 -0800 [thread overview]
Message-ID: <20131126151022.704213e6@jbarnes-desktop> (raw)
In-Reply-To: <20131111092324.GM14082@phenom.ffwll.local>
On Mon, 11 Nov 2013 10:23:24 +0100
Daniel Vetter <daniel@ffwll.ch> wrote:
> On Wed, Nov 06, 2013 at 12:51:05PM +0200, Ville Syrjälä wrote:
> > On Wed, Nov 06, 2013 at 02:36:35PM +0800, Chon Ming Lee wrote:
> > > vlv_dpio_read/write should be describe more in PHY centric instead of
> > > display controller centric.
> > > Create a enum dpio_channel for channel index and enum dpio_phy for PHY
> > > index. This should better to gather for upcoming platform.
> > >
> > > v2: Rebase the code based on
> > > drm/i915/vlv: Fix typo in the DPIO register define.
> > >
> > > v3: Rename vlv_phy to dpio_phy_iosf_port and define additional macro
> > > DPIO_PHY, and remove unrelated change. (Ville)
> > >
> > > Suggested-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
> > > Signed-off-by: Chon Ming Lee <chon.ming.lee@intel.com>
> >
> > Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
>
> Queued for -next, thanks for the patch.
Looks like this one gives me bogus DPIO values at least some of the
time. Reverting to using 0x12 as the port ID seems to get me valid
values back...
--
Jesse Barnes, Intel Open Source Technology Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2013-11-26 23:37 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-10-30 3:11 [PATCH 1/2] drm/i915/vlv: Make the vlv_dpio_read/vlv_dpio_write more PHY centric Chon Ming Lee
2013-10-30 3:11 ` [PATCH 2/2] drm/i915/vlv: Rename VLV DPIO register to be more structure to match configdb document Chon Ming Lee
2013-11-06 6:37 ` Chon Ming Lee
2013-11-06 12:02 ` Ville Syrjälä
2013-11-07 2:25 ` Lee, Chon Ming
2013-11-07 12:43 ` Ville Syrjälä
2013-11-07 2:43 ` [PATCH v3 " Chon Ming Lee
2013-11-08 9:25 ` Ville Syrjälä
2013-11-08 16:42 ` Daniel Vetter
2013-10-31 12:20 ` [PATCH 1/2] drm/i915/vlv: Make the vlv_dpio_read/vlv_dpio_write more PHY centric Ville Syrjälä
2013-11-06 6:36 ` Chon Ming Lee
2013-11-06 10:51 ` Ville Syrjälä
2013-11-11 9:23 ` Daniel Vetter
2013-11-26 23:10 ` Jesse Barnes [this message]
2013-11-26 23:18 ` Jesse Barnes
2013-11-27 6:51 ` Daniel Vetter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20131126151022.704213e6@jbarnes-desktop \
--to=jbarnes@virtuousgeek.org \
--cc=daniel@ffwll.ch \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).