From: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
To: Michal Wajdeczko <michal.wajdeczko@intel.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 10/11] drm/i915/uc: Add params for specifying firmware
Date: Wed, 15 Mar 2017 13:00:48 +0100 [thread overview]
Message-ID: <20170315120048.GA4469@ahiler-desk.igk.intel.com> (raw)
In-Reply-To: <20170314151717.GA125796@mwajdecz-MOBL1.ger.corp.intel.com>
On Tue, Mar 14, 2017 at 04:17:17PM +0100, Michal Wajdeczko wrote:
> On Tue, Mar 14, 2017 at 03:28:14PM +0100, Arkadiusz Hiler wrote:
> > `guc_firmware_path` and `huc_firmware_path` module parameters are added.
> >
> > Using the parameter disables version checks and loads desired firmware
> > instead of the default one.
> >
> > v2: make params unsafe && notice about disabled fw check (J. Lahtinen)
> >
> > Cc: Chris Wilson <chris@chris-wilson.co.uk>
> > Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
> > Cc: Michal Winiarski <michal.winiarski@intel.com>
> > Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
> > Reviewed-by: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
> > ---
>
> snip
>
> > @@ -356,8 +356,10 @@ void intel_uc_prepare_fw(struct drm_i915_private *dev_priv,
> > goto fail;
> > }
> >
> > - if (uc_fw->major_ver_found != uc_fw->major_ver_wanted ||
> > - uc_fw->minor_ver_found < uc_fw->minor_ver_wanted) {
> > + if (uc_fw->major_ver_wanted == 0 && uc_fw->minor_ver_wanted == 0) {
> > + DRM_NOTE("Skipping uC firmware version check\n");
>
> Do we really need this explicit message?
> I would rather promote DRM_DEBUG_DRIVER that prints loaded fw version to
> DRM_NOTE to always trace what fw version driver will use (which is even more
> important as user may specify any version that may cause driver go crazy)
It's logged anyway, right below this if statement :-)
I think it's useful that we are explicit about frimware version
overriding in logs. Additional benefit is that the logical conditions
are split and more readable.
> -Michal
>
> > + } else if (uc_fw->major_ver_found != uc_fw->major_ver_wanted ||
> > + uc_fw->minor_ver_found < uc_fw->minor_ver_wanted) {
> > DRM_NOTE("uC firmware version %d.%d, required %d.%d\n",
> > uc_fw->major_ver_found, uc_fw->minor_ver_found,
> > uc_fw->major_ver_wanted, uc_fw->minor_ver_wanted);
> > --
> > 2.9.3
> >
> > _______________________________________________
> > Intel-gfx mailing list
> > Intel-gfx@lists.freedesktop.org
> > https://lists.freedesktop.org/mailman/listinfo/intel-gfx
--
Cheers,
Arek
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2017-03-15 12:00 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-03-14 14:28 [PATCH v9 00/11] GuC Scrub vol. 1 Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 01/11] drm/i915/uc: Drop superfluous externs in intel_uc.h Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 02/11] drm/i915/huc: Add huc_to_i915 Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 03/11] drm/i915/uc: Rename intel_?uc_{setup, load}() to _init_hw() Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 04/11] drm/i915/uc: Move intel_uc_fw_fetch() to intel_uc.c Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 05/11] drm/i915/uc: Introduce intel_uc_init_fw() Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 06/11] drm/i915/guc: Extract param logic form guc_init_fw() Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 07/11] drm/i915/guc: Simplify intel_guc_init_hw() Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 08/11] drm/i915/uc: Simplify firmware path handling Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 09/11] drm/i915/uc: Separate firmware selection and preparation Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 10/11] drm/i915/uc: Add params for specifying firmware Arkadiusz Hiler
2017-03-14 15:17 ` Michal Wajdeczko
2017-03-15 12:00 ` Arkadiusz Hiler [this message]
2017-03-14 14:28 ` [PATCH 11/11] HAX enable GuC for CI Arkadiusz Hiler
2017-03-14 19:47 ` ✓ Fi.CI.BAT: success for GuC Scrub vol. 1 (rev13) Patchwork
-- strict thread matches above, loose matches on Subject: below --
2017-03-13 13:14 [PATCH v8 00/11] GuC Scrub vol. 1 Arkadiusz Hiler
2017-03-13 13:15 ` [PATCH 10/11] drm/i915/uc: Add params for specifying firmware Arkadiusz Hiler
2017-03-14 12:18 ` Joonas Lahtinen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170315120048.GA4469@ahiler-desk.igk.intel.com \
--to=arkadiusz.hiler@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=michal.wajdeczko@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox