From: "Nautiyal, Ankit K" <ankit.k.nautiyal@intel.com>
To: <intel-gfx@lists.freedesktop.org>, <intel-xe@lists.freedesktop.org>
Cc: <ville.syrjala@linux.intel.com>, <arun.r.murthy@intel.com>,
<jani.nikula@linux.intel.com>, <suraj.kandpal@intel.com>
Subject: Re: [PATCH v7 00/14] Add support for Common SDP Transmission Line
Date: Fri, 18 Sep 2026 09:24:44 +0530 [thread overview]
Message-ID: <2acee09f-a947-4018-99d8-8e5c97c6e4bf@intel.com> (raw)
In-Reply-To: <20260915164657.3429075-1-ankit.k.nautiyal@intel.com>
On 9/15/2026 10:16 PM, Ankit Nautiyal wrote:
> Xe3p_lpd introduces new register bits to program a common SDP
> Transmission line that will be used by the Hardware to position the
> SDPs. Along with this, another new register is also added to stagger
> the different SDPs.
>
> This series adds support for programming the Common SDP Transmission Line
> (CMN_SDP_TL) and its stagger control registers.
>
> Rev2:
> - Add tracking for AS SDP Transmission line first. Instead of directly
> programming it in the register, compute the state during
> compute_config_late() and write the value from crtc_state.
> Readout from the register through a vrr helper, since the register is
> defined in context of VRR and will be used for both DP and HDMI VRR
> packets.
> - Add support to track other SDP transmission lines, instead of stagger
> values.
> - Compute the transmission lines in compute_config_late path and add
> readout.
> - Always write the Common SDP Transmission line and other stagger
> values, whether the packets are sent or not.
> - Dump SDP transmission lines in crtc_state.
>
> Rev3:
> - Introduce new files for handling the Data Island Packets (DIPs)
> programming in one place. (Ville)
> - Extract the Transmission Line programming for
> HDMI Extended Metadata Packet (EMP) and Adaptive Sync SDP (AS SDP)
> i.e. EMP_AS_SDP_TL in the new file.
> - Add programming for Common Base SDP Transmission lines and other
> stagger offsets in the new file.
> - Add a #TODO to extract other helpers that deal with Data Island Packets
> and VIDEO_DIP registers.
> - Place the HAS_* Macros related to DIP in the intel_dip.h file
> instead of intel_display_devices.h (Jani)
> - Make function names more descriptive and avoid overuse of multiple
> acronyms. (Jani)
>
> Note:
> - Though I have fixed the naming as suggested in most places, I
> have retained HAS_EMP_AS_SDP_TL for the following reasons:
> 1) Lack of an apt name that avoids the acronym for
> 'Extended Metadata Packet Adaptive Sync Secondary Packet Transmission
> Line'.
> 2) Keeping this name makes it easier to find and map with the exact name
> for such a complex register name.
>
> However, I am open to suggestions for a better name.
>
> Rev4:
> - Drop the patch to check for DP encoder before writing EMP_AS_SDP_TL
> register. Instead reset the register to 0 for non DP encoder case.
>
> Rev5:
> - Rebase
> - Address review comments from Suraj:
> - Drop some redundant checks, and fix few commit messages.
>
> Rev6:
> - Move the new struct in intel_display_types.h from intel_dip.h (Jani)
> - Check for CMN_SDP_TL restriction and Warn if not followed. (Suraj)
> - Use HAS_CMN_SDP_TL() instead of checking if cmn_sdp_tl is set or not.
> (Sashiko)
> - Make sure that the guardband is sufficient as per CMN_SDP_TL while
> optiminzing the guardband.
>
> Rev7:
> - Account for VSC SDP's own minimum guardband requirement in
> intel_dp_sdp_min_guardband(), for completeness. (Sashiko)
> - Wrap two long line macro definitions in intel_dip_regs.h.
>
> Ankit Nautiyal (13):
> drm/i915/dip: Add new file to handle Data Island Packet hardware
> drm/i915/vrr: Use the helper to write EMP_AS_SDP_TL register
> drm/i915/intel_dip: Add check for DP encoder
> drm/i915/dip: Add helper to get AS SDP Transmission Line
> drm/i915/display: Add crtc state for DIP transmission lines
> drm/i915/dip: Store and use AS SDP transmission line from crtc state
> drm/i915/dip: Add HAS_COMMON_SDP_TL macro
> drm/i915/dip: Store SDP transmission lines in crtc_state
> drm/i915/dp: Introduce helpers to enable/disable CMN SDP Transmission
> line
> drm/i915/dip: Enable Common SDP Transmission line
> drm/i915/dp: Account VSC SDP in min guardband
> drm/i915/dp: Adjust SDP guardband requirement for CMN_SDP_TL
> drm/i915/display: Dump DIP Transmission lines
>
> Arun R Murthy (1):
> drm/i915/dip_regs: Add register definitions for common SDP
> Transmission Line
Thanks for the review comments, and suggestions. Pushed to drm-intel-next.
intel_dip.c was introduced here but only covers the transmission-line
handling. Two follow-ups remain:
- Extract the remaining low-level DIP buffer/infoframe code out of
intel_hdmi.c into intel_dip.c.
- Introduce a DIP type enum so HDMI packet types and DP SDP types aren't
mixed in the same namespace in hsw_infoframe_enable()
I'll try to get to that next.
Thanks & Regards,
Ankit
>
> drivers/gpu/drm/i915/Makefile | 1 +
> .../drm/i915/display/intel_crtc_state_dump.c | 9 +
> drivers/gpu/drm/i915/display/intel_ddi.c | 5 +
> drivers/gpu/drm/i915/display/intel_dip.c | 215 ++++++++++++++++++
> drivers/gpu/drm/i915/display/intel_dip.h | 53 +++++
> drivers/gpu/drm/i915/display/intel_dip_regs.h | 38 ++++
> drivers/gpu/drm/i915/display/intel_display.c | 6 +
> .../drm/i915/display/intel_display_types.h | 16 ++
> drivers/gpu/drm/i915/display/intel_dp.c | 62 ++++-
> drivers/gpu/drm/i915/display/intel_vrr.c | 14 +-
> drivers/gpu/drm/i915/display/intel_vrr_regs.h | 6 -
> drivers/gpu/drm/xe/Makefile | 1 +
> 12 files changed, 407 insertions(+), 19 deletions(-)
> create mode 100644 drivers/gpu/drm/i915/display/intel_dip.c
> create mode 100644 drivers/gpu/drm/i915/display/intel_dip.h
> create mode 100644 drivers/gpu/drm/i915/display/intel_dip_regs.h
>
prev parent reply other threads:[~2026-09-18 3:55 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-15 16:46 [PATCH v7 00/14] Add support for Common SDP Transmission Line Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 01/14] drm/i915/dip: Add new file to handle Data Island Packet hardware Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 02/14] drm/i915/vrr: Use the helper to write EMP_AS_SDP_TL register Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 03/14] drm/i915/intel_dip: Add check for DP encoder Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 04/14] drm/i915/dip: Add helper to get AS SDP Transmission Line Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 05/14] drm/i915/display: Add crtc state for DIP transmission lines Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 06/14] drm/i915/dip: Store and use AS SDP transmission line from crtc state Ankit Nautiyal
2026-09-15 17:22 ` sashiko-bot
2026-09-16 4:18 ` Nautiyal, Ankit K
2026-09-15 16:46 ` [PATCH v7 07/14] drm/i915/dip_regs: Add register definitions for common SDP Transmission Line Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 08/14] drm/i915/dip: Add HAS_COMMON_SDP_TL macro Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 09/14] drm/i915/dip: Store SDP transmission lines in crtc_state Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 10/14] drm/i915/dp: Introduce helpers to enable/disable CMN SDP Transmission line Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 11/14] drm/i915/dip: Enable Common " Ankit Nautiyal
2026-09-15 17:28 ` sashiko-bot
2026-09-16 4:19 ` Nautiyal, Ankit K
2026-09-15 16:46 ` [PATCH v7 12/14] drm/i915/dp: Account VSC SDP in min guardband Ankit Nautiyal
2026-09-16 2:41 ` Kandpal, Suraj
2026-09-15 16:46 ` [PATCH v7 13/14] drm/i915/dp: Adjust SDP guardband requirement for CMN_SDP_TL Ankit Nautiyal
2026-09-15 16:46 ` [PATCH v7 14/14] drm/i915/display: Dump DIP Transmission lines Ankit Nautiyal
2026-09-15 20:23 ` ✓ i915.CI.BAT: success for Add support for Common SDP Transmission Line (rev7) Patchwork
2026-09-16 7:09 ` ✓ i915.CI.Full: " Patchwork
2026-09-18 3:54 ` Nautiyal, Ankit K [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2acee09f-a947-4018-99d8-8e5c97c6e4bf@intel.com \
--to=ankit.k.nautiyal@intel.com \
--cc=arun.r.murthy@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=intel-xe@lists.freedesktop.org \
--cc=jani.nikula@linux.intel.com \
--cc=suraj.kandpal@intel.com \
--cc=ville.syrjala@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox