From: Jaroslav Kysela <perex@perex.cz>
To: Takashi Iwai <tiwai@suse.de>
Cc: alsa-devel@alsa-project.org, liam.r.girdwood@intel.com,
jocelyn.li@intel.com, mengdong.lin@intel.com,
intel-gfx@lists.freedesktop.org,
Wang Xingchao <xingchao.wang@linux.intel.com>,
jesse.barnes@intel.com, daniel@ffwll.ch,
David Henningsson <david.henningsson@canonical.com>,
paulo.r.zanoni@intel.com
Subject: Re: [PATCH 5/5] ALSA/i915: Check power well API existense before calling
Date: Mon, 13 May 2013 11:53:56 +0200 [thread overview]
Message-ID: <5190B834.5090201@perex.cz> (raw)
In-Reply-To: <s5h1u9btfvn.wl%tiwai@suse.de>
Date 13.5.2013 10:59, Takashi Iwai wrote:
> At Mon, 13 May 2013 10:55:46 +0200,
> Jaroslav Kysela wrote:
>>
>> Date 13.5.2013 10:28, David Henningsson wrote:
>>> On 05/13/2013 09:37 AM, Wang Xingchao wrote:
>>>> I915 module maybe loaded after snd_hda_intel, the power-well
>>>> API doesnot exist in such case. This patch intended to avoid
>>>> loading dependency between snd-hda-intel and i915 module.
>>>
>>> Hi Xingchao and thanks for working on this.
>>>
>>> This patch seems to re-do some of the work done in other patches (a lot
>>> of lines removed), so it's a little hard to follow. But I'll try to
>>> write some overall comments on how I have envisioned things...
>>>
>>> 1. I don't think there's any need to create an additional kernel module,
>>> we can just let hda_i915.c be in the snd-hda-intel.ko module, and only
>>> compile it if DRM_I915 is defined.
>>>
>>> 2. We don't need an IS_HSW macro on the audio side. Instead declare a
>>> new AZX_DCAPS_NEED_I915_POWER (or similar) driver quirk.
>>>
>>> 3. Somewhere in the beginning of the probing in hda_intel.c, we'll need
>>> something like:
>>>
>>> if (driver_caps & AZX_DCAPS_NEED_I915_POWER)
>>> hda_i915_init(chip);
>>>
>>> 4. The hda_i915_init does not need to be exported (they're now both in
>>> the same module). hda_i915.h could have something like:
>>>
>>> #ifdef DRM_I915
>>> void hda_i915_init(chip);
>>> #else
>>> #define hda_i915_init(chip) do {} while(0)
>>> #endif
>>>
>>> 5. You're saying this patch is about avoid loading dependency between
>>> snd-hda-intel and i915 module. That does not make sense to me, since the
>>> powerwell API is in the i915 module, snd-hda-intel must load it when it
>>> wants to enable power on haswell, right? Thus there is a loading
>>> dependency. If the i915 module is not loaded at that point, we must wait
>>> for it to load, so we can have proper power, instead of continuing
>>> probing without the power well?
>>
>> Looking to the code, if the drm code requires a callback to the audio
>> code, I would just register it in the audio driver init phase and
>> unregister it when snd-hda-intel is unloaded. This cross module loading
>> dependency looks really bad. Or it is not allowed to load the audio
>> driver later than DRM one?
>
> It's not allowed. The drm/i915 must be initialized before the audio.
> And yet, we don't want this dependency in a hard way in the hda
> driver, because the driver is not only for i915 but for other vendor's
> controllers, too.
>
> In the previous meeting, I suggested to split snd-hda-intel for
> Haswell as an alternative solution. But this has obvious
> disadvantages, and since the dynamic symbol lookup is already used in
> a few other kernel codes, we decided to try this first.
Yes, I agree here, but I was talking about the proposed
intel_gpu_audio_init() function which creates a back-dependency to the
audio driver. It should be done using a callback to the DRM code without
adding a new cross module. The other stuff (request_module, symbol_get)
looks good, but it should be integrated to the main snd-hda-intel module
as David proposed.
Jaroslav
--
Jaroslav Kysela <perex@perex.cz>
Linux Kernel Sound Maintainer
ALSA Project; Red Hat, Inc.
next prev parent reply other threads:[~2013-05-13 9:53 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-05-13 7:37 [PATCH 0/5] Power-well API implementation for Haswell Wang Xingchao
2013-05-13 7:37 ` [PATCH 1/5] drm/915: Add private api for power well usage Wang Xingchao
2013-05-13 12:29 ` Takashi Iwai
2013-05-13 7:37 ` [PATCH 2/5] ALSA: hda - Add external module hda-i915 for power well Wang Xingchao
2013-05-13 12:32 ` Takashi Iwai
2013-05-13 7:37 ` [PATCH 3/5] ALSA: hda - Power well request/release for hda controller Wang Xingchao
2013-05-13 7:37 ` [PATCH 4/5] ALSA: hda - Fix module dependency with gfx i915 Wang Xingchao
2013-05-13 12:34 ` Takashi Iwai
2013-05-13 7:37 ` [PATCH 5/5] ALSA/i915: Check power well API existense before calling Wang Xingchao
2013-05-13 8:28 ` David Henningsson
2013-05-13 8:55 ` Jaroslav Kysela
2013-05-13 8:59 ` [alsa-devel] " Takashi Iwai
2013-05-13 9:53 ` Jaroslav Kysela [this message]
2013-05-13 12:00 ` Wang, Xingchao
2013-05-13 11:55 ` [alsa-devel] " Wang, Xingchao
2013-05-13 12:13 ` David Henningsson
2013-05-13 13:50 ` Wang, Xingchao
2013-05-13 15:37 ` David Henningsson
2013-05-13 12:17 ` Takashi Iwai
2013-05-13 13:43 ` Wang, Xingchao
2013-05-13 12:38 ` [alsa-devel] " Takashi Iwai
2013-05-13 7:51 ` [alsa-devel] [PATCH 0/5] Power-well API implementation for Haswell Wang, Xingchao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5190B834.5090201@perex.cz \
--to=perex@perex.cz \
--cc=alsa-devel@alsa-project.org \
--cc=daniel@ffwll.ch \
--cc=david.henningsson@canonical.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jesse.barnes@intel.com \
--cc=jocelyn.li@intel.com \
--cc=liam.r.girdwood@intel.com \
--cc=mengdong.lin@intel.com \
--cc=paulo.r.zanoni@intel.com \
--cc=tiwai@suse.de \
--cc=xingchao.wang@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox