From: Mika Kuoppala <mika.kuoppala@linux.intel.com>
To: Chris Wilson <chris@chris-wilson.co.uk>,
Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>,
intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 3/3] drm/i915: Move find_active_request() to the engine
Date: Wed, 06 Mar 2019 16:33:33 +0200 [thread overview]
Message-ID: <8736o0ul6q.fsf@gaia.fi.intel.com> (raw)
In-Reply-To: <155181014188.27405.8385697202915739967@skylake-alporthouse-com>
Chris Wilson <chris@chris-wilson.co.uk> writes:
> Quoting Tvrtko Ursulin (2019-03-05 18:13:34)
>>
>> intel_engine.h in 3...2...1.. ;)
>
> As soon as we have a good name for the legacy submission method. At the
> moment, my favorites are:
> gen2_submission.c / legacy_submission.c (actually that's winning again)
> gen8_submission.c / execlists_submission.c
> guc_submission.c
I would favour the name of the method instead of gens. And legacy is
always sneaking steadily towards present. So how about
ringbuf_submission.c ?
-Mika
>
> intel_ring.[ch] can provide the small bit of common struct intel_ring,
> and intel_engine.[ch] for the common setup/poking.
> -Chris
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/intel-gfx
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2019-03-06 14:34 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-03-05 18:03 [PATCH 1/3] drm/i915: Store the BIT(engine->id) as the engine's mask Chris Wilson
2019-03-05 18:03 ` [PATCH 2/3] drm/i915/gtt: Mark ALL_ENGINES as dirty on ppGTT modification Chris Wilson
2019-03-05 18:03 ` [PATCH 3/3] drm/i915: Move find_active_request() to the engine Chris Wilson
2019-03-05 18:13 ` Tvrtko Ursulin
2019-03-05 18:22 ` Chris Wilson
2019-03-06 14:33 ` Mika Kuoppala [this message]
2019-03-05 18:11 ` [PATCH 1/3] drm/i915: Store the BIT(engine->id) as the engine's mask Tvrtko Ursulin
2019-03-05 18:27 ` ✗ Fi.CI.CHECKPATCH: warning for series starting with [1/3] " Patchwork
2019-03-05 18:29 ` ✗ Fi.CI.SPARSE: " Patchwork
2019-03-05 18:50 ` ✓ Fi.CI.BAT: success " Patchwork
2019-03-05 22:53 ` ✓ Fi.CI.IGT: " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8736o0ul6q.fsf@gaia.fi.intel.com \
--to=mika.kuoppala@linux.intel.com \
--cc=chris@chris-wilson.co.uk \
--cc=intel-gfx@lists.freedesktop.org \
--cc=tvrtko.ursulin@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox