From: Jani Nikula <jani.nikula@intel.com>
To: Chris Wilson <chris@chris-wilson.co.uk>,
Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>,
intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 5/6] drm/i915: move load failure injection to selftests
Date: Mon, 31 Dec 2018 17:12:41 +0200 [thread overview]
Message-ID: <87a7klwx06.fsf@intel.com> (raw)
In-Reply-To: <154626231206.12016.1366050729641533150@skylake-alporthouse-com>
On Mon, 31 Dec 2018, Chris Wilson <chris@chris-wilson.co.uk> wrote:
> Quoting Tvrtko Ursulin (2018-12-31 13:13:26)
>>
>> On 27/12/2018 14:33, Jani Nikula wrote:
>> > Seems like selftests is a better home for everything related to load
>> > failure injection, including the module parameter.
>>
>> Hm not sure I would immediately want to couple the two, however..
>>
>> > The failure injection code gets moved from under DRM_I915_DEBUG to
>> > DRM_I915_SELFTEST config option. This should be of no consequence, as
>> > the former selects the latter.
>>
>> ... I also don't see why debug would auto-select self-tests.
>
> DRM_I915_DEBUG is now the list of things we use for igt
> s/DRM_I915_DEBUG/DRM_I915_IGT/
>
> Just so we can have a single switch for "if you want to run igt, enable
> this CONFIG to enable all debug features used by igt". Handy for CI
> testing when more features are required.
So what say you on the patch? I can keep it in i915_params.c too, it
just needs some extra juggling because it gets used before i915 gets
allocated. So not very easy as a "device param".
BR,
Jani.
--
Jani Nikula, Intel Open Source Graphics Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2018-12-31 15:12 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-12-27 14:33 [PATCH 0/6] drm/i915: modparam rework prep work Jani Nikula
2018-12-27 14:33 ` [PATCH 1/6] drm/i915: add a helper to make a copy of i915_params Jani Nikula
2018-12-27 14:33 ` [PATCH 2/6] drm/i915: add a helper to free the members " Jani Nikula
2018-12-31 12:51 ` Tvrtko Ursulin
2018-12-27 14:33 ` [PATCH 3/6] drm/i915/uc: add dev_priv parameter to intel_uc_is_using_* functions Jani Nikula
2018-12-31 12:56 ` Tvrtko Ursulin
2018-12-27 14:33 ` [PATCH 4/6] drm/i915/params: set i915.enable_hangcheck permissions to 0600 Jani Nikula
2018-12-31 13:01 ` Tvrtko Ursulin
2018-12-31 13:31 ` Jani Nikula
2018-12-27 14:33 ` [PATCH 5/6] drm/i915: move load failure injection to selftests Jani Nikula
2018-12-31 13:13 ` Tvrtko Ursulin
2018-12-31 13:18 ` Chris Wilson
2018-12-31 15:12 ` Jani Nikula [this message]
2018-12-31 15:16 ` Chris Wilson
2018-12-27 14:33 ` [PATCH 6/6] drm/i915/params: document I915_PARAMS_FOR_EACH() Jani Nikula
2018-12-31 13:05 ` Tvrtko Ursulin
2018-12-31 13:24 ` Jani Nikula
2018-12-31 15:07 ` Tvrtko Ursulin
2018-12-31 15:16 ` Jani Nikula
2018-12-27 14:59 ` ✗ Fi.CI.CHECKPATCH: warning for drm/i915: modparam rework prep work Patchwork
2018-12-27 15:02 ` ✗ Fi.CI.SPARSE: " Patchwork
2018-12-27 15:20 ` ✗ Fi.CI.BAT: failure " Patchwork
2018-12-28 8:59 ` ✗ Fi.CI.CHECKPATCH: warning for drm/i915: modparam rework prep work (rev2) Patchwork
2018-12-28 9:02 ` ✗ Fi.CI.SPARSE: " Patchwork
2018-12-28 9:35 ` ✓ Fi.CI.BAT: success " Patchwork
2018-12-28 11:06 ` ✓ Fi.CI.IGT: " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87a7klwx06.fsf@intel.com \
--to=jani.nikula@intel.com \
--cc=chris@chris-wilson.co.uk \
--cc=intel-gfx@lists.freedesktop.org \
--cc=tvrtko.ursulin@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox