From: Jani Nikula <jani.nikula@linux.intel.com>
To: Paulo Zanoni <paulo.r.zanoni@intel.com>, intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 2/4] drm/i915: Extract a intel_power_well_disable() function
Date: Fri, 31 Jul 2015 12:24:00 +0300 [thread overview]
Message-ID: <87twsk8ytr.fsf@intel.com> (raw)
In-Reply-To: <1438291229-7541-3-git-send-email-paulo.r.zanoni@intel.com>
On Fri, 31 Jul 2015, Paulo Zanoni <paulo.r.zanoni@intel.com> wrote:
> From: Damien Lespiau <damien.lespiau@intel.com>
>
> Similar to the ->enable vfunc in commit:
>
> commit 865720564389b2b19cf58e41ed31701e5f464b9d
That sha won't be the same once it gets applied. Maybe just squash these
two patches into one?
BR,
Jani.
> Author: Damien Lespiau <damien.lespiau@intel.com>
> Date: Wed Jun 3 14:27:05 2015 +0100
>
> drm/i915: Extract a intel_power_well_enable() function
>
> v2 (from Paulo):
> - Same s/i915_/intel_/ bikeshed as the previous patch.
> - Update the commit hash.
>
> Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
> Reviewed-by: Paulo Zanoni <paulo.r.zanoni@intel.com>
> Signed-off-by: Paulo Zanoni <paulo.r.zanoni@intel.com>
> ---
> drivers/gpu/drm/i915/intel_runtime_pm.c | 15 ++++++++++-----
> 1 file changed, 10 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/intel_runtime_pm.c b/drivers/gpu/drm/i915/intel_runtime_pm.c
> index a52574d..821644d 100644
> --- a/drivers/gpu/drm/i915/intel_runtime_pm.c
> +++ b/drivers/gpu/drm/i915/intel_runtime_pm.c
> @@ -76,6 +76,14 @@ static void intel_power_well_enable(struct drm_i915_private *dev_priv,
> power_well->hw_enabled = true;
> }
>
> +static void intel_power_well_disable(struct drm_i915_private *dev_priv,
> + struct i915_power_well *power_well)
> +{
> + DRM_DEBUG_KMS("disabling %s\n", power_well->name);
> + power_well->hw_enabled = false;
> + power_well->ops->disable(dev_priv, power_well);
> +}
> +
> /*
> * We should only use the power well if we explicitly asked the hardware to
> * enable it, so check if it's enabled and also check if we've requested it to
> @@ -1147,11 +1155,8 @@ void intel_display_power_put(struct drm_i915_private *dev_priv,
> for_each_power_well_rev(i, power_well, BIT(domain), power_domains) {
> WARN_ON(!power_well->count);
>
> - if (!--power_well->count && i915.disable_power_well) {
> - DRM_DEBUG_KMS("disabling %s\n", power_well->name);
> - power_well->hw_enabled = false;
> - power_well->ops->disable(dev_priv, power_well);
> - }
> + if (!--power_well->count && i915.disable_power_well)
> + intel_power_well_disable(dev_priv, power_well);
> }
>
> mutex_unlock(&power_domains->lock);
> --
> 2.4.6
>
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/intel-gfx
--
Jani Nikula, Intel Open Source Technology Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2015-07-31 9:21 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-07-30 21:20 [PATCH 0/4] Fix SKL runtime PM Paulo Zanoni
2015-07-30 21:20 ` [PATCH 1/4] drm/i915: Extract a intel_power_well_enable() function Paulo Zanoni
2015-07-30 21:20 ` [PATCH 2/4] drm/i915: Extract a intel_power_well_disable() function Paulo Zanoni
2015-07-31 9:24 ` Jani Nikula [this message]
2015-07-31 15:19 ` Paulo Zanoni
2015-07-30 21:20 ` [PATCH 3/4] drm/i915: Make turning on/off PW1 and Misc I/O part of the init/fini sequences Paulo Zanoni
2015-08-05 8:30 ` Daniel Vetter
2015-08-05 18:28 ` Paulo Zanoni
2015-08-06 12:53 ` Daniel Vetter
2015-07-30 21:20 ` [PATCH 4/4] drm/i915/skl: send opregion_nofify_adapter(PCI_D1) instead of PCI_D3 Paulo Zanoni
2015-07-31 11:25 ` [PATCH 0/4] Fix SKL runtime PM Patrik Jakobsson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87twsk8ytr.fsf@intel.com \
--to=jani.nikula@linux.intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=paulo.r.zanoni@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox