From: "Yokoyama, Caz" <caz.yokoyama@intel.com>
To: "intel-gfx@lists.freedesktop.org"
<intel-gfx@lists.freedesktop.org>,
"Souza, Jose" <jose.souza@intel.com>
Cc: "Sripada, Radhakrishna" <radhakrishna.sripada@intel.com>,
"Deak, Imre" <imre.deak@intel.com>
Subject: Re: [Intel-gfx] [PATCH 1/2] drm/i915/display: Rename POWER_DOMAIN_DPLL_DC_OFF to POWER_DOMAIN_DC_OFF
Date: Wed, 20 Oct 2021 15:09:30 +0000 [thread overview]
Message-ID: <8e9f8fecda3a25653dd85a8747b5fd292da0215f.camel@intel.com> (raw)
In-Reply-To: <20211020003558.222198-1-jose.souza@intel.com>
Looks good to me.
Reviewed-by: Caz Yokoyama <caz.yokoyama@intel.com>
-caz
On Tue, 2021-10-19 at 17:35 -0700, José Roberto de Souza wrote:
> This power domain to disable DC states will be used in places outside
> of DPLL, so making the name more generic.
>
> Cc: Radhakrishna Sripada <radhakrishna.sripada@intel.com>
> Cc: Imre Deak <imre.deak@intel.com>
> Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
> ---
> drivers/gpu/drm/i915/display/intel_display_power.c | 6 +++---
> drivers/gpu/drm/i915/display/intel_display_power.h | 2 +-
> drivers/gpu/drm/i915/display/intel_dpll_mgr.c | 6 +++---
> 3 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_display_power.c
> b/drivers/gpu/drm/i915/display/intel_display_power.c
> index d88da0d0f05ac..6637760d24e0c 100644
> --- a/drivers/gpu/drm/i915/display/intel_display_power.c
> +++ b/drivers/gpu/drm/i915/display/intel_display_power.c
> @@ -155,8 +155,8 @@ intel_display_power_domain_str(enum
> intel_display_power_domain domain)
> return "MODESET";
> case POWER_DOMAIN_GT_IRQ:
> return "GT_IRQ";
> - case POWER_DOMAIN_DPLL_DC_OFF:
> - return "DPLL_DC_OFF";
> + case POWER_DOMAIN_DC_OFF:
> + return "DC_OFF";
> case POWER_DOMAIN_TC_COLD_OFF:
> return "TC_COLD_OFF";
> default:
> @@ -2803,7 +2803,7 @@ intel_display_power_put_mask_in_set(struct
> drm_i915_private *i915,
> ICL_PW_2_POWER_DOMAINS | \
> BIT_ULL(POWER_DOMAIN_MODESET) | \
> BIT_ULL(POWER_DOMAIN_AUX_A) | \
> - BIT_ULL(POWER_DOMAIN_DPLL_DC_OFF) | \
> + BIT_ULL(POWER_DOMAIN_DC_OFF) | \
> BIT_ULL(POWER_DOMAIN_INIT))
>
> #define ICL_DDI_IO_A_POWER_DOMAINS ( \
> diff --git a/drivers/gpu/drm/i915/display/intel_display_power.h
> b/drivers/gpu/drm/i915/display/intel_display_power.h
> index 0612e4b6e3c81..d54b7574ed373 100644
> --- a/drivers/gpu/drm/i915/display/intel_display_power.h
> +++ b/drivers/gpu/drm/i915/display/intel_display_power.h
> @@ -117,7 +117,7 @@ enum intel_display_power_domain {
> POWER_DOMAIN_GMBUS,
> POWER_DOMAIN_MODESET,
> POWER_DOMAIN_GT_IRQ,
> - POWER_DOMAIN_DPLL_DC_OFF,
> + POWER_DOMAIN_DC_OFF,
> POWER_DOMAIN_TC_COLD_OFF,
> POWER_DOMAIN_INIT,
>
> diff --git a/drivers/gpu/drm/i915/display/intel_dpll_mgr.c
> b/drivers/gpu/drm/i915/display/intel_dpll_mgr.c
> index ca69b67bbc231..fc8fda77483ab 100644
> --- a/drivers/gpu/drm/i915/display/intel_dpll_mgr.c
> +++ b/drivers/gpu/drm/i915/display/intel_dpll_mgr.c
> @@ -3741,7 +3741,7 @@ static void combo_pll_enable(struct
> drm_i915_private *dev_priv,
> * domain.
> */
> pll->wakeref = intel_display_power_get(dev_priv,
> - POWER_DOMAIN_DPL
> L_DC_OFF);
> + POWER_DOMAIN_DC_
> OFF);
> }
>
> icl_pll_power_enable(dev_priv, pll, enable_reg);
> @@ -3848,7 +3848,7 @@ static void combo_pll_disable(struct
> drm_i915_private *dev_priv,
>
> if (IS_JSL_EHL(dev_priv) &&
> pll->info->id == DPLL_ID_EHL_DPLL4)
> - intel_display_power_put(dev_priv,
> POWER_DOMAIN_DPLL_DC_OFF,
> + intel_display_power_put(dev_priv, POWER_DOMAIN_DC_OFF,
> pll->wakeref);
> }
>
> @@ -4232,7 +4232,7 @@ static void readout_dpll_hw_state(struct
> drm_i915_private *i915,
> if (IS_JSL_EHL(i915) && pll->on &&
> pll->info->id == DPLL_ID_EHL_DPLL4) {
> pll->wakeref = intel_display_power_get(i915,
> - POWER_DOMAIN_DPL
> L_DC_OFF);
> + POWER_DOMAIN_DC_
> OFF);
> }
>
> pll->state.pipe_mask = 0;
prev parent reply other threads:[~2021-10-20 15:09 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-10-20 0:35 [Intel-gfx] [PATCH 1/2] drm/i915/display: Rename POWER_DOMAIN_DPLL_DC_OFF to POWER_DOMAIN_DC_OFF José Roberto de Souza
2021-10-20 0:35 ` [Intel-gfx] [PATCH 2/2] drm/i915/display: Add warn_on in intel_psr_pause() José Roberto de Souza
2021-10-20 11:28 ` Kahola, Mika
2021-10-20 15:15 ` Yokoyama, Caz
2021-10-20 1:13 ` [Intel-gfx] ✗ Fi.CI.SPARSE: warning for series starting with [1/2] drm/i915/display: Rename POWER_DOMAIN_DPLL_DC_OFF to POWER_DOMAIN_DC_OFF Patchwork
2021-10-20 1:43 ` [Intel-gfx] ✓ Fi.CI.BAT: success " Patchwork
2021-10-20 5:49 ` [Intel-gfx] ✗ Fi.CI.IGT: failure " Patchwork
2021-10-20 20:30 ` Souza, Jose
2021-10-20 15:09 ` Yokoyama, Caz [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8e9f8fecda3a25653dd85a8747b5fd292da0215f.camel@intel.com \
--to=caz.yokoyama@intel.com \
--cc=imre.deak@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jose.souza@intel.com \
--cc=radhakrishna.sripada@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox