Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2025-05-07 15:50:41 to 2025-05-12 08:12:29 UTC [more...]

[RFC v2 00/13] Some (drm_sched_|dma_)fence lifetime issues
 2025-05-12  8:12 UTC  (22+ messages)
` [RFC v2 01/13] drm/i915: Use provided dma_fence_is_chain
` [RFC v2 02/13] dma-fence: Change signature of __dma_fence_is_later
` [RFC v2 03/13] dma-fence: Use a flag for 64-bit seqnos
` [RFC v2 04/13] dma-fence: Move array and chain checks to flags
` [RFC v2 05/13] dma-fence: Add helpers for accessing driver and timeline name
` [RFC v2 06/13] dma-fence: Use driver and timeline name helpers internally
` [RFC v2 07/13] sync_file: Use dma-fence driver and timeline name helpers
` [RFC v2 08/13] drm/amdgpu: "
` [RFC v2 09/13] drm/i915: "
` [RFC v2 10/13] dma-fence: Add safe access helpers and document the rules
` [RFC v2 11/13] sync_file: Protect access to driver and timeline name
` [RFC v2 12/13] drm/i915: "
` [RFC v2 13/13] drm/xe: Make dma-fences compliant with the safe access rules
` ✗ Fi.CI.CHECKPATCH: warning for Some (drm_sched_|dma_)fence lifetime issues
` ✗ Fi.CI.SPARSE: "
` ✓ i915.CI.BAT: success "
` ✗ i915.CI.Full: failure "

[CI] drm/i915: Use provided dma_fence_is_chain
 2025-05-12  7:20 UTC 

[PATCH v2 0/3] drm: Create an app info option for wedge events
 2025-05-12  6:08 UTC  (9+ messages)
` [PATCH v2 1/3] "
` [PATCH v2 2/3] drm/doc: Add a section about "App information" for the wedge API
` [PATCH v2 3/3] drm/amdgpu: Make use of drm_wedge_app_info
` ✗ Fi.CI.CHECKPATCH: warning for drm: Create an app info option for wedge events (rev2)
` ✗ Fi.CI.SPARSE: "
` ✓ i915.CI.BAT: success "
` ✓ i915.CI.Full: "

[REGRESSION] on linux-next (next-20250507)
 2025-05-12  6:00 UTC 

[PATCH 00/18] DPLL framework redesign
 2025-05-12  4:27 UTC  (41+ messages)
` [PATCH 01/18] drm/i915/dpll: Rename intel_dpll
` [PATCH 02/18] drm/i915/dpll: Rename intel_dpll_funcs
` [PATCH 03/18] drm/i915/dpll: Rename intel_shared_dpll_state
` [PATCH 04/18] drm/i915/dpll: Rename macro for_each_shared_dpll
` [PATCH 05/18] drm/i915/dpll: Rename intel_shared_dpll_funcs
` [PATCH 06/18] drm/i915/dpll: Rename intel_shared_dpll
` [PATCH 07/18] drm/i915/dpll: Move away from using shared dpll
` [PATCH 08/18] drm/i915/dpll: Rename crtc_get_shared_dpll
` [PATCH 09/18] drm/i915/dpll: Change argument for enable hook in intel_dpll_funcs
` [PATCH 10/18] drm/i915/drm: Rename disable hook in intel_dpll_global_func
` [PATCH 11/18] drm/i915/dpll: Introduce new hook in intel_dpll_funcs
` [PATCH 12/18] drm/i915/dpll: Add intel_encoder argument to get_hw_state hook
` [PATCH 13/18] drm/i915/dpll: Change arguments for get_freq hook
` [PATCH 14/18] drm/i915/dpll: Rename intel_[enable/disable]_dpll
` [PATCH 15/18] drm/i915/dpll: Rename intel_unreference_dpll__crtc
` [PATCH 16/18] drm/i915/dpll: Rename intel_<release/reserve>_dpll
` [PATCH 17/18] drm/i915/dpll: Rename intel_compute_dpll
` [PATCH 18/18] drm/i915/dpll: Rename intel_update_active_dpll

[PATCH v9 00/10] ref_tracker: add ability to register a debugfs file for a ref_tracker_dir
 2025-05-10 11:17 UTC  (16+ messages)
` [PATCH v9 01/10] ref_tracker: don't use %pK in pr_ostream() output
` [PATCH v9 02/10] ref_tracker: add a top level debugfs directory for ref_tracker
` [PATCH v9 03/10] ref_tracker: have callers pass output function to pr_ostream()
` [PATCH v9 04/10] ref_tracker: add a static classname string to each ref_tracker_dir
` [PATCH v9 05/10] ref_tracker: allow pr_ostream() to print directly to a seq_file
` [PATCH v9 06/10] ref_tracker: automatically register a file in debugfs for a ref_tracker_dir
` [PATCH v9 07/10] ref_tracker: add a way to create a symlink to the ref_tracker_dir debugfs file
` [PATCH v9 08/10] net: add symlinks to ref_tracker_dir for netns
` [PATCH v9 09/10] i915: add ref_tracker_dir symlinks for each tracker
` [PATCH v9 10/10] ref_tracker: eliminate the ref_tracker_dir name field
` ✗ Fi.CI.CHECKPATCH: warning for ref_tracker: add ability to register a debugfs file for a ref_tracker_dir (rev5)
` ✗ Fi.CI.SPARSE: "
` ✗ i915.CI.BAT: failure "

[PATCH v3 00/12] drm/i915/dp_mst: Add support for fractional link bpps
 2025-05-09 21:05 UTC  (17+ messages)
` [PATCH v3 01/12] drm/i915/dp_mst: Use the correct connector while computing the link BPP limit on MST
` [PATCH v3 02/12] drm/i915/dp_mst: Simplify handling the single-bpp case during state computation
` [PATCH v3 03/12] drm/i915/dp_mst: Validate compressed bpp vs. platform restrictions
` [PATCH v3 04/12] drm/i915/dp_mst: Update the total link slot count early
` [PATCH v3 05/12] drm/i915/dp_mst: Check BW limit on the local MST link early
` [PATCH v3 06/12] drm/i915/dp_mst: Simplify computing the min/max compressed bpp limits
` [PATCH v3 07/12] drm/i915/dp: Limit max link bpp properly to a fractional value on SST
` [PATCH v3 08/12] drm/i915/dp_mst: Add support for fractional compressed link bpps on MST
` [PATCH v3 09/12] drm/i915/display: Factor out intel_display_{min, max}_pipe_bpp()
` [PATCH v3 10/12] drm/i915/dp: Export intel_dp_dsc_min_src_compressed_bpp()
` [PATCH v3 11/12] drm/i915: Add support for forcing the link bpp on a connector
` [PATCH v3 12/12] drm/i915/dp_mst: Enable fractional link bpps on MST if the bpp is forced
` ✗ Fi.CI.CHECKPATCH: warning for drm/i915/dp_mst: Add support for fractional link bpps (rev4)
` ✗ Fi.CI.SPARSE: "
` ✓ i915.CI.BAT: success "
` ✗ i915.CI.Full: failure "

[PATCH v3] drm/i915/selftest: allow larger memory allocation
 2025-05-09 20:08 UTC  (5+ messages)
` ✓ i915.CI.BAT: success for drm/i915/selftest: allow larger memory allocation (rev3)
` ✓ i915.CI.Full: "

[PATCH v8 00/10] ref_tracker: add ability to register a debugfs file for a ref_tracker_dir
 2025-05-09 15:10 UTC  (6+ messages)
` [PATCH v8 10/10] ref_tracker: eliminate the ref_tracker_dir name field
` ✗ i915.CI.BAT: failure for ref_tracker: add ability to register a debugfs file for a ref_tracker_dir (rev4)

[PATCH v3 0/2] ALPM rework and fixes
 2025-05-09 12:04 UTC  (9+ messages)
` [PATCH v3 1/2] drm/i915/alpm: Make intel_alpm_enable_sink available for PSR
` [PATCH v3 2/2] drm/i915/alpm: Stop writing ALPM registers when PSR is enabled
` ✗ Fi.CI.SPARSE: warning for ALPM rework and fixes (rev3)
` ✓ i915.CI.BAT: success "
` ✗ i915.CI.Full: failure "

[PATCH RESEND v13 0/5] Expose modifiers/formats supported by async flips
 2025-05-09 11:55 UTC  (9+ messages)

[PATCH] drm/i915/display: Send DSI DCS commands with pipeline flush in High Speed
 2025-05-09 11:51 UTC  (11+ messages)
` ✗ Fi.CI.CHECKPATCH: warning for "
` ✓ i915.CI.BAT: success "
` ✗ i915.CI.Full: failure "
` [PATCH] drm/i915/display: Enforce pipeline flush with DSI HS transfer
` ✗ i915.CI.BAT: failure for drm/i915/display: Send DSI DCS commands with pipeline flush in High Speed (rev2)

[PATCH 00/13] Modify drm helpers to use luminance
 2025-05-09  8:43 UTC  (17+ messages)
` [PATCH 01/13] drm/dp: Introduce new member in drm_backlight_info
` [PATCH 02/13] drm/dp: Add argument in drm_edp_backlight_init
` [PATCH 03/13] drm/dp: Add argument for luminance range info "
` [PATCH 04/13] drm/dp: Move from u16 to u32 for max in drm_edp_backlight_info
` [PATCH 05/13] drm/dp: Change current_level argument type to u32
` [PATCH 06/13] drm/dp: Modify drm_edp_probe_state
` [PATCH 07/13] drm/dp: Change argument type for drm_edp_backlight_set_level
` [PATCH 08/13] drm/dp: Modify drm_edp_backlight_set_level
` [PATCH 09/13] drm/dp: Change argument type of drm_edp_backlight_enable
` [PATCH 10/13] drm/dp: Enable backlight control using luminance
` [PATCH 11/13] drm/i915/backlight: Use drm helper to initialize edp backlight
` [PATCH 12/13] drm/i915/backlight: Use drm helper to set "
` [PATCH 13/13] drm/i915/backlight: Use drm_edp_backlight_enable
` ✗ Fi.CI.SPARSE: warning for Modify drm helpers to use luminance (rev3)
` ✓ i915.CI.BAT: success "
` ✗ i915.CI.Full: failure "

[PULL] drm-intel-fixes
 2025-05-09  7:30 UTC 

[PATCH] drm/i915/vrr: Set vrr.vmin to min Vtotal to re-enable LRR for PTL
 2025-05-09  6:15 UTC  (3+ messages)
` ✓ i915.CI.BAT: success for "
` ✗ i915.CI.Full: failure "

[PULL] drm-xe-fixes
 2025-05-09  5:12 UTC 

[PATCH v5 03/21] drm/i915: Avoid open-coded use of ratelimit_state structure's ->missed field
 2025-05-08 23:33 UTC 

[PATCH] drm/i915/dp: Fix determining SST/MST mode during MTP TU state computation
 2025-05-08 17:57 UTC  (4+ messages)
` ✓ i915.CI.BAT: success for "
` ✗ i915.CI.Full: failure "

[PATCH v3] drm/i915/guc: Enable DUAL_QUEUE_WA for newer platforms
 2025-05-08 16:23 UTC  (3+ messages)
` ✓ i915.CI.BAT: success for drm/i915/guc: Enable DUAL_QUEUE_WA for newer platforms (rev4)
` ✗ i915.CI.Full: failure "

[PULL] drm-xe-next
 2025-05-08 16:01 UTC 

[PATCH v2 00/12] drm/i915/dp_mst: Add support for fractional link bpps
 2025-05-08 14:37 UTC  (5+ messages)
` ✗ i915.CI.BAT: failure for drm/i915/dp_mst: Add support for fractional link bpps (rev2)
` ✗ Fi.CI.BUILD: failure for drm/i915/dp_mst: Add support for fractional link bpps (rev3)

[PATCH v2 0/8] drm/i915: refactor VLV IOSF SB for display usage
 2025-05-08 14:09 UTC  (11+ messages)
` [PATCH v2 1/8] drm/i915: rename vlv_sideband*.[ch] to vlv_iosf_sb*.[ch]
` [PATCH v2 2/8] drm/i915: add generic read/write functions for VLV IOSF SB
` [PATCH v2 3/8] drm/i915: rewrite VLV IOSF SB unit specific read/write functions
` [PATCH v2 4/8] drm/i915: switch i915 core to generic VLV IOSF SB functions
` [PATCH v2 5/8] drm/i915: move VLV IOSF SB unit specific helpers under display
` [PATCH v2 6/8] drm/i915: convert VLV IOSF SB interface to struct drm_device
` [PATCH v2 7/8] drm/i915: rename VLV IOSF SB ports parameter to unit_mask
` [PATCH v2 8/8] drm/i915: ensure correct VLV IOSF SB units have been get/put
` ✗ Fi.CI.BUILD: warning for drm/i915: refactor VLV IOSF SB for display usage (rev2)
` ✗ i915.CI.BAT: failure "

[PULL] drm-intel-next
 2025-05-08 13:31 UTC 

[PATCH v8 0/9] LOBF enablement fix
 2025-05-08 11:57 UTC  (3+ messages)
` [PATCH v8 6/9] drm/i915/lobf: Update lobf if any change in dependent parameters

[PULL] drm-misc-fixes
 2025-05-08 10:49 UTC 

[PATCH 0/6] drm/i915: refactor VLV IOSF SB for display usage
 2025-05-08 10:05 UTC  (3+ messages)
` [PATCH 4/6] drm/i915: switch i915 core to generic VLV IOSF SB functions

[PATCH] drm/i915/irq: stop using HAS_GMCH()
 2025-05-08  9:50 UTC  (2+ messages)

[PULL] drm-misc-next
 2025-05-08  7:05 UTC 

[PULL] drm-intel-gt-next
 2025-05-08  6:21 UTC 

[PATCH 0/4] drm/{i915, xe}: convert i915->display and xe->display into pointers
 2025-05-07 22:28 UTC  (6+ messages)
` ✗ Fi.CI.CHECKPATCH: warning for drm/{i915, xe}: convert i915->display and xe->display into pointers (rev2)
` ✗ Fi.CI.SPARSE: "
` ✓ i915.CI.BAT: success "
` ✗ i915.CI.Full: failure "

[PATCH v2 0/2] drm/i915: DG1 fixes
 2025-05-07 21:06 UTC  (2+ messages)
` ✗ Fi.CI.SPARSE: warning for drm/i915: DG1 fixes (rev5)

[PATCH 0/6] drm/i915/dram: dram_info refactoring
 2025-05-07 18:22 UTC  (3+ messages)
` ✗ Fi.CI.SPARSE: warning for "
` ✗ i915.CI.BAT: failure "

[PATCH] drm/i915/gt: Remove const from struct i915_wa list allocation
 2025-05-07 15:50 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox