Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Sagar Arun Kamble <sagar.a.kamble@intel.com>
To: Chris Wilson <chris@chris-wilson.co.uk>, intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH v2 1/6] drm/i915: Update execlists tasklet naming
Date: Thu, 16 Nov 2017 18:32:07 +0530	[thread overview]
Message-ID: <cfe7db37-2003-3204-794b-e7fe7cd4506a@intel.com> (raw)
In-Reply-To: <151082689003.26104.2462730126134642649@mail.alporthouse.com>



On 11/16/2017 3:38 PM, Chris Wilson wrote:
> Quoting Sagar Arun Kamble (2017-11-16 09:53:50)
>> intel_lrc_irq_handler and i915_guc_irq_handler are HW submission
>> related bh functions. Name them with submission_bh suffix and
>> remove intel/i915 prefix as they are static. Also rename irq_tasklet
>> as just tasklet for clarity.
> s/_bh/_tasklet/ bottom-halves dropped out of favour about a decade ago,
> tasklets are also on the cusp of being replaced but at least it's
> current!
> -Chris
I concluded this discussion little early yesterday with _bh as choice. :)
Sorry, will update it as _tasklet.
Thanks for the review.

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2017-11-16 13:02 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-11-16  9:53 [PATCH v2 0/6] GuC submission functions/struct name/prototype update Sagar Arun Kamble
2017-11-16  9:53 ` [PATCH v2 1/6] drm/i915: Update execlists tasklet naming Sagar Arun Kamble
2017-11-16 10:08   ` Chris Wilson
2017-11-16 13:02     ` Sagar Arun Kamble [this message]
2017-11-16  9:53 ` [PATCH v2 2/6] drm/i915/guc: Update names of submission related static functions Sagar Arun Kamble
2017-11-16 11:25   ` Michal Wajdeczko
2017-11-16  9:53 ` [PATCH v2 3/6] drm/i915/guc: Update name and prototype of GuC submission interface functions Sagar Arun Kamble
2017-11-16 11:10   ` Michal Wajdeczko
2017-11-16  9:53 ` [PATCH v2 4/6] drm/i915/guc: Rename i915_guc_client struct to intel_guc_client Sagar Arun Kamble
2017-11-16  9:53 ` [PATCH v2 5/6] drm/i915/guc: Rename i915_guc_submission.c|h to intel_guc_submission.c|h Sagar Arun Kamble
2017-11-16  9:53 ` [PATCH v2 6/6] HAX enable GuC submission for CI Sagar Arun Kamble
2017-11-16 10:10 ` ✓ Fi.CI.BAT: success for GuC submission functions/struct name/prototype update (rev2) Patchwork
2017-11-16 11:05 ` ✗ Fi.CI.IGT: warning " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cfe7db37-2003-3204-794b-e7fe7cd4506a@intel.com \
    --to=sagar.a.kamble@intel.com \
    --cc=chris@chris-wilson.co.uk \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox