From: Jani Nikula <jani.nikula@intel.com>
To: Jani Nikula <jani.nikula@intel.com>, intel-gfx@lists.freedesktop.org
Subject: [PATCH v3 0/3] drm/i915: introduce macros to define register contents
Date: Wed, 27 Feb 2019 19:02:35 +0200 [thread overview]
Message-ID: <cover.1551286447.git.jani.nikula@intel.com> (raw)
v3 of [1] with naming hopefully settled (fingers crossed), and some more
compile time checks, documentation and other polish added.
The naming scheme of the local wrappers/copies of bit fiddling macros is
to just use REG_ prefix for the regular kernel ones, with hopefully
minimal confusion. So we end up with:
REG_BIT()
REG_GENMASK()
REG_FIELD_PREP()
REG_FIELD_GET()
We can also use the same macros in i915_reg.h and rest of the driver,
with no mixed use for register contents. Indeed some of the regular
kernel macros lead to non-u32 types being used.
BR,
Jani.
[1] http://mid.mail-archive.com/cover.1547726792.git.jani.nikula@intel.com
Jani Nikula (3):
drm/i915: introduce REG_BIT() and REG_GENMASK() to define register
contents
drm/i915: deprecate _SHIFT in favor of _MASK passed to accessors
drm/i915: use REG_FIELD_PREP() to define register bitfield values
drivers/gpu/drm/i915/i915_reg.h | 182 +++++++++++++++++++-----------
drivers/gpu/drm/i915/intel_dp.c | 40 +++----
drivers/gpu/drm/i915/intel_lvds.c | 40 +++----
3 files changed, 151 insertions(+), 111 deletions(-)
--
2.20.1
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next reply other threads:[~2019-02-27 17:00 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-02-27 17:02 Jani Nikula [this message]
2019-02-27 17:02 ` [PATCH v3 1/3] drm/i915: introduce REG_BIT() and REG_GENMASK() to define register contents Jani Nikula
2019-02-27 20:50 ` Chris Wilson
2019-02-27 21:13 ` Ville Syrjälä
2019-02-27 23:06 ` Michal Wajdeczko
2019-02-28 10:07 ` Jani Nikula
2019-02-28 10:12 ` Chris Wilson
2019-02-28 11:12 ` Michal Wajdeczko
2019-02-27 17:02 ` [PATCH v3 2/3] drm/i915: deprecate _SHIFT in favor of _MASK passed to accessors Jani Nikula
2019-02-27 20:58 ` Chris Wilson
2019-02-27 17:02 ` [PATCH v3 3/3] drm/i915: use REG_FIELD_PREP() to define register bitfield values Jani Nikula
2019-02-27 21:07 ` Chris Wilson
2019-02-27 21:11 ` Ville Syrjälä
2019-02-28 0:17 ` Michal Wajdeczko
2019-02-28 10:24 ` Jani Nikula
2019-02-28 11:38 ` Michal Wajdeczko
2019-02-28 13:48 ` Jani Nikula
2019-02-28 4:49 ` kbuild test robot
2019-02-27 17:44 ` ✗ Fi.CI.CHECKPATCH: warning for drm/i915: introduce macros to define register contents (rev3) Patchwork
2019-02-27 17:46 ` ✗ Fi.CI.SPARSE: " Patchwork
2019-02-27 18:20 ` ✓ Fi.CI.BAT: success " Patchwork
2019-02-27 20:13 ` ✓ Fi.CI.IGT: " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cover.1551286447.git.jani.nikula@intel.com \
--to=jani.nikula@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox