From: Chris Wilson <chris@chris-wilson.co.uk>
To: Jesse Barnes <jbarnes@virtuousgeek.org>, dri-devel@lists.freedesktop.org
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [Intel-gfx] [PATCH 3/4] drm/i915: rename existing overlay support to "legacy"
Date: Tue, 07 Jun 2011 21:59:55 +0100 [thread overview]
Message-ID: <e0d58a$9sb59@orsmga002.jf.intel.com> (raw)
In-Reply-To: <1307477262-8242-4-git-send-email-jbarnes@virtuousgeek.org>
On Tue, 7 Jun 2011 13:07:41 -0700, Jesse Barnes <jbarnes@virtuousgeek.org> wrote:
> The old overlay block has all sorts of quirks and is very different than
> ILK+ video sprites. So rename it to legacy to make that clear and clash
> less with core overlay support.
>
> Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
> ---
> @@ -191,7 +191,7 @@ struct drm_i915_error_state {
> u32 cache_level:2;
> } *active_bo, *pinned_bo;
> u32 active_bo_count, pinned_bo_count;
> - struct intel_overlay_error_state *overlay;
> + struct intel_legacy_overlay_error_state *overlay;
We need to change the name here as well, unless you have some
differently name error struct up your sleeve.
struct intel_sprite_error_state?
> diff --git a/drivers/gpu/drm/i915/intel_drv.h b/drivers/gpu/drm/i915/intel_drv.h
> index 3cfc391..d73e622 100644
> --- a/drivers/gpu/drm/i915/intel_drv.h
> +++ b/drivers/gpu/drm/i915/intel_drv.h
> @@ -161,7 +161,7 @@ struct intel_crtc {
> bool busy; /* is scanout buffer being updated frequently? */
> struct timer_list idle_timer;
> bool lowfreq_avail;
> - struct intel_overlay *overlay;
> + struct intel_legacy_overlay *overlay;
> struct intel_unpin_work *unpin_work;
> int fdi_lanes;
And here. Give the old code longer names, we don't want to be touching
it ever again. ;-)
-Chris
--
Chris Wilson, Intel Open Source Technology Centre
next prev parent reply other threads:[~2011-06-07 20:59 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-06-07 20:07 [RFC] Updated DRM plane handling patches Jesse Barnes
2011-06-07 20:07 ` [PATCH 1/4] drm: add plane support Jesse Barnes
2011-06-07 21:01 ` Jesse Barnes
2011-06-08 9:41 ` Marcus Lorentzon
2011-06-08 18:54 ` Jesse Barnes
2011-06-09 9:16 ` Marcus Lorentzon
2011-06-07 21:05 ` Jesse Barnes
2011-06-07 20:07 ` [PATCH 2/4] drm: add an fb creation ioctl that takes a pixel format Jesse Barnes
2011-06-07 20:07 ` [PATCH 3/4] drm/i915: rename existing overlay support to "legacy" Jesse Barnes
2011-06-07 20:59 ` Chris Wilson [this message]
2011-06-07 20:07 ` [PATCH 4/4] drm/i915: add SNB video sprite support Jesse Barnes
2011-06-07 21:01 ` Chris Wilson
2011-06-15 17:29 ` [RFC] Updated DRM plane handling patches Jesse Barnes
2011-07-21 10:15 ` Joonyoung Shim
2011-07-21 17:15 ` Jesse Barnes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='e0d58a$9sb59@orsmga002.jf.intel.com' \
--to=chris@chris-wilson.co.uk \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jbarnes@virtuousgeek.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox