Linux io-uring development
 help / color / mirror / Atom feed
From: Pavel Begunkov <asml.silence@gmail.com>
To: io-uring@vger.kernel.org
Cc: asml.silence@gmail.com, netdev@vger.kernel.org,
	"Clément Léger" <cleger@meta.com>
Subject: [PATCH io_uring-7.2 0/3] fix up zcrx "notification" uapi naming
Date: Wed, 22 Jul 2026 14:42:14 +0100	[thread overview]
Message-ID: <cover.1784726895.git.asml.silence@gmail.com> (raw)

There is a degree of inconsistency, nuisance and ambiguity in the naming
of the zcrx "notification" API. Rename it to "events" and do other small
adjustments while it's not released yet. The patch set only does
renaming, there is no functional or ABI changes.

Pavel Begunkov (3):
  io_uring/zcrx: drop "notif" from stats struct names
  io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS
  io_uring/zcrx: rename notif to event

 include/uapi/linux/io_uring/query.h | 14 ++++++------
 include/uapi/linux/io_uring/zcrx.h  | 32 +++++++++++++--------------
 io_uring/query.c                    | 12 +++++-----
 io_uring/zcrx.c                     | 34 ++++++++++++++---------------
 io_uring/zcrx.h                     |  7 +++---
 5 files changed, 50 insertions(+), 49 deletions(-)

-- 
2.54.0


             reply	other threads:[~2026-07-22 13:42 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-22 13:42 Pavel Begunkov [this message]
2026-07-22 13:42 ` [PATCH io_uring-7.2 1/3] io_uring/zcrx: drop "notif" from stats struct names Pavel Begunkov
2026-07-22 13:42 ` [PATCH io_uring-7.2 2/3] io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS Pavel Begunkov
2026-07-22 19:36   ` Mina Almasry
2026-07-22 13:42 ` [PATCH io_uring-7.2 3/3] io_uring/zcrx: rename notif to event Pavel Begunkov
2026-07-22 19:37   ` Mina Almasry
2026-07-22 20:11     ` Pavel Begunkov
2026-07-22 20:19       ` Mina Almasry

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover.1784726895.git.asml.silence@gmail.com \
    --to=asml.silence@gmail.com \
    --cc=cleger@meta.com \
    --cc=io-uring@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox