Linux io-uring development
 help / color / mirror / Atom feed
* [PATCH io_uring-7.2 0/3] fix up zcrx "notification" uapi naming
@ 2026-07-22 13:42 Pavel Begunkov
  2026-07-22 13:42 ` [PATCH io_uring-7.2 1/3] io_uring/zcrx: drop "notif" from stats struct names Pavel Begunkov
                   ` (2 more replies)
  0 siblings, 3 replies; 8+ messages in thread
From: Pavel Begunkov @ 2026-07-22 13:42 UTC (permalink / raw)
  To: io-uring; +Cc: asml.silence, netdev, Clément Léger

There is a degree of inconsistency, nuisance and ambiguity in the naming
of the zcrx "notification" API. Rename it to "events" and do other small
adjustments while it's not released yet. The patch set only does
renaming, there is no functional or ABI changes.

Pavel Begunkov (3):
  io_uring/zcrx: drop "notif" from stats struct names
  io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS
  io_uring/zcrx: rename notif to event

 include/uapi/linux/io_uring/query.h | 14 ++++++------
 include/uapi/linux/io_uring/zcrx.h  | 32 +++++++++++++--------------
 io_uring/query.c                    | 12 +++++-----
 io_uring/zcrx.c                     | 34 ++++++++++++++---------------
 io_uring/zcrx.h                     |  7 +++---
 5 files changed, 50 insertions(+), 49 deletions(-)

-- 
2.54.0


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2026-07-22 20:19 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-22 13:42 [PATCH io_uring-7.2 0/3] fix up zcrx "notification" uapi naming Pavel Begunkov
2026-07-22 13:42 ` [PATCH io_uring-7.2 1/3] io_uring/zcrx: drop "notif" from stats struct names Pavel Begunkov
2026-07-22 13:42 ` [PATCH io_uring-7.2 2/3] io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS Pavel Begunkov
2026-07-22 19:36   ` Mina Almasry
2026-07-22 13:42 ` [PATCH io_uring-7.2 3/3] io_uring/zcrx: rename notif to event Pavel Begunkov
2026-07-22 19:37   ` Mina Almasry
2026-07-22 20:11     ` Pavel Begunkov
2026-07-22 20:19       ` Mina Almasry

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox