Kernel KVM-PPC virtualization development
 help / color / mirror / Atom feed
* [PATCH 25/27] Fix trace.h
@ 2009-09-29  8:18 Alexander Graf
  2009-10-09 21:42 ` Hollis Blanchard
  2009-10-10 23:07 ` Benjamin Herrenschmidt
  0 siblings, 2 replies; 5+ messages in thread
From: Alexander Graf @ 2009-09-29  8:18 UTC (permalink / raw)
  To: kvm-ppc

It looks like the variable "pc" is defined. At least the current code always
failed on me stating that "pc" is already defined somewhere else.

Let's use _pc instead, because that doesn't collide.

Is this the right approach? Does it break on 440 too? If not, why not?

Signed-off-by: Alexander Graf <agraf@suse.de>
---
 arch/powerpc/kvm/trace.h |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
index 67f219d..a8e8400 100644
--- a/arch/powerpc/kvm/trace.h
+++ b/arch/powerpc/kvm/trace.h
@@ -12,8 +12,8 @@
  * Tracepoint for guest mode entry.
  */
 TRACE_EVENT(kvm_ppc_instr,
-	TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
-	TP_ARGS(inst, pc, emulate),
+	TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
+	TP_ARGS(inst, _pc, emulate),
 
 	TP_STRUCT__entry(
 		__field(	unsigned int,	inst		)
@@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
 
 	TP_fast_assign(
 		__entry->inst		= inst;
-		__entry->pc		= pc;
+		__entry->pc		= _pc;
 		__entry->emulate	= emulate;
 	),
 
-- 
1.6.0.2


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH 25/27] Fix trace.h
  2009-09-29  8:18 [PATCH 25/27] Fix trace.h Alexander Graf
@ 2009-10-09 21:42 ` Hollis Blanchard
  2009-10-10 23:07 ` Benjamin Herrenschmidt
  1 sibling, 0 replies; 5+ messages in thread
From: Hollis Blanchard @ 2009-10-09 21:42 UTC (permalink / raw)
  To: kvm-ppc

On Tue, 2009-09-29 at 10:18 +0200, Alexander Graf wrote:
> It looks like the variable "pc" is defined. At least the current code always
> failed on me stating that "pc" is already defined somewhere else.
> 
> Let's use _pc instead, because that doesn't collide.
> 
> Is this the right approach? Does it break on 440 too? If not, why not?
> 
> Signed-off-by: Alexander Graf <agraf@suse.de>
> ---
>  arch/powerpc/kvm/trace.h |    6 +++---
>  1 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
> index 67f219d..a8e8400 100644
> --- a/arch/powerpc/kvm/trace.h
> +++ b/arch/powerpc/kvm/trace.h
> @@ -12,8 +12,8 @@
>   * Tracepoint for guest mode entry.
>   */
>  TRACE_EVENT(kvm_ppc_instr,
> -	TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
> -	TP_ARGS(inst, pc, emulate),
> +	TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
> +	TP_ARGS(inst, _pc, emulate),
> 
>  	TP_STRUCT__entry(
>  		__field(	unsigned int,	inst		)
> @@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
> 
>  	TP_fast_assign(
>  		__entry->inst		= inst;
> -		__entry->pc		= pc;
> +		__entry->pc		= _pc;
>  		__entry->emulate	= emulate;
>  	),
> 

After much digging, I managed to actually enable CONFIG_TRACEPOINTS.
However, I still don't get any build errors from this code. Maybe you
could paste the full gcc output?

-- 
Hollis Blanchard
IBM Linux Technology Center


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 25/27] Fix trace.h
  2009-09-29  8:18 [PATCH 25/27] Fix trace.h Alexander Graf
  2009-10-09 21:42 ` Hollis Blanchard
@ 2009-10-10 23:07 ` Benjamin Herrenschmidt
  1 sibling, 0 replies; 5+ messages in thread
From: Benjamin Herrenschmidt @ 2009-10-10 23:07 UTC (permalink / raw)
  To: kvm-ppc

On Fri, 2009-10-09 at 14:42 -0700, Hollis Blanchard wrote:
> After much digging, I managed to actually enable CONFIG_TRACEPOINTS.
> However, I still don't get any build errors from this code. Maybe you
> could paste the full gcc output? 

Another option is to be a bit more "ppc-ish" and call it IAR instead of
PC :-)

Cheers,
Ben.


^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH 25/27] Fix trace.h
       [not found]                                                 ` <1256137413-15256-25-git-send-email-agraf-l3A5Bk7waGM@public.gmane.org>
@ 2009-10-21 15:03                                                   ` Alexander Graf
  0 siblings, 0 replies; 5+ messages in thread
From: Alexander Graf @ 2009-10-21 15:03 UTC (permalink / raw)
  To: kvm-u79uwXL29TY76Z2rM5mHXA
  Cc: Avi Kivity, kvm-ppc, Hollis Blanchard, Arnd Bergmann,
	Benjamin Herrenschmidt, Kevin Wolf, bphilips-l3A5Bk7waGM,
	Marcelo Tosatti

It looks like the variable "pc" is defined. At least the current code always
failed on me stating that "pc" is already defined somewhere else.

Let's use _pc instead, because that doesn't collide.

Is this the right approach? Does it break on 440 too? If not, why not?

Signed-off-by: Alexander Graf <agraf@suse.de>
---
 arch/powerpc/kvm/trace.h |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
index 67f219d..a8e8400 100644
--- a/arch/powerpc/kvm/trace.h
+++ b/arch/powerpc/kvm/trace.h
@@ -12,8 +12,8 @@
  * Tracepoint for guest mode entry.
  */
 TRACE_EVENT(kvm_ppc_instr,
-	TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
-	TP_ARGS(inst, pc, emulate),
+	TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
+	TP_ARGS(inst, _pc, emulate),
 
 	TP_STRUCT__entry(
 		__field(	unsigned int,	inst		)
@@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
 
 	TP_fast_assign(
 		__entry->inst		= inst;
-		__entry->pc		= pc;
+		__entry->pc		= _pc;
 		__entry->emulate	= emulate;
 	),
 
-- 
1.6.0.2


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [PATCH 25/27] Fix trace.h
  2009-10-30 15:47 [PATCH 00/27] Add KVM support for Book3s_64 (PPC64) hosts v6 Alexander Graf
@ 2009-10-30 15:47 ` Alexander Graf
  0 siblings, 0 replies; 5+ messages in thread
From: Alexander Graf @ 2009-10-30 15:47 UTC (permalink / raw)
  To: kvm
  Cc: Avi Kivity, kvm-ppc, Hollis Blanchard, Arnd Bergmann,
	Benjamin Herrenschmidt, Kevin Wolf, bphilips, Marcelo Tosatti,
	Olof Johansson, linuxppc-dev

It looks like the variable "pc" is defined. At least the current code always
failed on me stating that "pc" is already defined somewhere else.

Let's use _pc instead, because that doesn't collide.

Is this the right approach? Does it break on 440 too? If not, why not?

Signed-off-by: Alexander Graf <agraf@suse.de>
---
 arch/powerpc/kvm/trace.h |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
index 67f219d..a8e8400 100644
--- a/arch/powerpc/kvm/trace.h
+++ b/arch/powerpc/kvm/trace.h
@@ -12,8 +12,8 @@
  * Tracepoint for guest mode entry.
  */
 TRACE_EVENT(kvm_ppc_instr,
-	TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
-	TP_ARGS(inst, pc, emulate),
+	TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
+	TP_ARGS(inst, _pc, emulate),
 
 	TP_STRUCT__entry(
 		__field(	unsigned int,	inst		)
@@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
 
 	TP_fast_assign(
 		__entry->inst		= inst;
-		__entry->pc		= pc;
+		__entry->pc		= _pc;
 		__entry->emulate	= emulate;
 	),
 
-- 
1.6.0.2


^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2009-10-30 15:47 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2009-09-29  8:18 [PATCH 25/27] Fix trace.h Alexander Graf
2009-10-09 21:42 ` Hollis Blanchard
2009-10-10 23:07 ` Benjamin Herrenschmidt
  -- strict thread matches above, loose matches on Subject: below --
2009-10-21 15:03 [PATCH 00/27] Add KVM support for Book3s_64 (PPC64) hosts v5 Alexander Graf
2009-10-21 15:03 ` [PATCH 01/27] Move dirty logging code to sub-arch Alexander Graf
2009-10-21 15:03   ` [PATCH 02/27] Pass PVR in sregs Alexander Graf
2009-10-21 15:03     ` [PATCH 03/27] Add Book3s definitions Alexander Graf
2009-10-21 15:03       ` [PATCH 04/27] Add Book3s fields to vcpu structs Alexander Graf
2009-10-21 15:03         ` [PATCH 05/27] Add asm/kvm_book3s.h Alexander Graf
2009-10-21 15:03           ` [PATCH 06/27] Add Book3s_64 intercept helpers Alexander Graf
2009-10-21 15:03             ` [PATCH 07/27] Add book3s_64 highmem asm code Alexander Graf
2009-10-21 15:03               ` [PATCH 08/27] Add SLB switching code for entry/exit Alexander Graf
2009-10-21 15:03                 ` [PATCH 09/27] Add interrupt handling code Alexander Graf
2009-10-21 15:03                   ` [PATCH 10/27] Add book3s.c Alexander Graf
2009-10-21 15:03                     ` [PATCH 11/27] Add book3s_64 Host MMU handling Alexander Graf
2009-10-21 15:03                       ` [PATCH 12/27] Add book3s_64 guest MMU Alexander Graf
2009-10-21 15:03                         ` [PATCH 13/27] Add book3s_32 " Alexander Graf
2009-10-21 15:03                           ` [PATCH 14/27] Add book3s_64 specific opcode emulation Alexander Graf
2009-10-21 15:03                             ` [PATCH 15/27] Add mfdec emulation Alexander Graf
2009-10-21 15:03                               ` [PATCH 16/27] Add desktop PowerPC specific emulation Alexander Graf
2009-10-21 15:03                                 ` [PATCH 17/27] Make head_64.S aware of KVM real mode code Alexander Graf
2009-10-21 15:03                                   ` [PATCH 18/27] Add Book3s_64 offsets to asm-offsets.c Alexander Graf
2009-10-21 15:03                                     ` [PATCH 19/27] Export symbols for KVM module Alexander Graf
2009-10-21 15:03                                       ` [PATCH 20/27] Split init_new_context and destroy_context Alexander Graf
2009-10-21 15:03                                         ` [PATCH 21/27] Export KVM symbols for module Alexander Graf
2009-10-21 15:03                                           ` [PATCH 22/27] Add fields to PACA Alexander Graf
2009-10-21 15:03                                             ` [PATCH 23/27] Export new PACA constants in asm-offsets Alexander Graf
2009-10-21 15:03                                               ` [PATCH 24/27] Include Book3s_64 target in buildsystem Alexander Graf
     [not found]                                                 ` <1256137413-15256-25-git-send-email-agraf-l3A5Bk7waGM@public.gmane.org>
2009-10-21 15:03                                                   ` [PATCH 25/27] Fix trace.h Alexander Graf
2009-10-30 15:47 [PATCH 00/27] Add KVM support for Book3s_64 (PPC64) hosts v6 Alexander Graf
2009-10-30 15:47 ` [PATCH 25/27] Fix trace.h Alexander Graf

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox