Kernel KVM virtualization development
 help / color / mirror / Atom feed
* [kvm-unit-tests PATCH 0/2] riscv: sbi: Rename sbi ecall wrappers
@ 2024-08-30 15:53 Andrew Jones
  2024-08-30 15:53 ` [kvm-unit-tests PATCH 1/2] sbi: Rename __*_sbi_ecall to sbi_* Andrew Jones
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Andrew Jones @ 2024-08-30 15:53 UTC (permalink / raw)
  To: kvm, kvm-riscv; +Cc: atishp, cade.richard, jamestiotio

Just some renaming to improve readability and also add another DBCN
test to ensure we only write a single byte with write-byte. Use the
"raw" ecall for that because sbi_dbcn_write_byte now takes a uint8_t.

Andrew Jones (2):
  sbi: Rename __*_sbi_ecall to sbi_*
  sbi: dbcn: Add write-byte test with more than byte given

 riscv/sbi.c | 48 ++++++++++++++++++++++++++++++------------------
 1 file changed, 30 insertions(+), 18 deletions(-)

-- 
2.45.2


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2024-09-03 13:58 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2024-08-30 15:53 [kvm-unit-tests PATCH 0/2] riscv: sbi: Rename sbi ecall wrappers Andrew Jones
2024-08-30 15:53 ` [kvm-unit-tests PATCH 1/2] sbi: Rename __*_sbi_ecall to sbi_* Andrew Jones
2024-08-30 15:53 ` [kvm-unit-tests PATCH 2/2] sbi: dbcn: Add write-byte test with more than byte given Andrew Jones
2024-09-03 13:58 ` [kvm-unit-tests PATCH 0/2] riscv: sbi: Rename sbi ecall wrappers Andrew Jones

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox