Kernel KVM virtualization development
 help / color / mirror / Atom feed
From: Sean Christopherson <seanjc@google.com>
To: Zide Chen <zide.chen@intel.com>
Cc: Paolo Bonzini <pbonzini@redhat.com>,
	Peter Zijlstra <peterz@infradead.org>,
	kvm@vger.kernel.org,  linux-kernel@vger.kernel.org,
	Jim Mattson <jmattson@google.com>,
	 Mingwei Zhang <mizhang@google.com>,
	Das Sandipan <Sandipan.Das@amd.com>,
	 Shukla Manali <Manali.Shukla@amd.com>,
	Dapeng Mi <dapeng1.mi@linux.intel.com>,
	 Falcon Thomas <thomas.falcon@intel.com>,
	Xudong Hao <xudong.hao@intel.com>
Subject: Re: [PATCH 04/15] KVM: x86/pmu: Add PMC bitmap accessor helpers
Date: Tue, 28 Jul 2026 16:35:27 -0700	[thread overview]
Message-ID: <amk8v8Vx3KyM5c7D@google.com> (raw)
In-Reply-To: <5a03c9c8-09b1-42fa-a086-63734aa17f6d@intel.com>

On Tue, Jul 28, 2026, Zide Chen wrote:
> On 7/28/2026 2:28 PM, Sean Christopherson wrote:
> > On Tue, Jul 07, 2026, Zide Chen wrote:
> >> @@ -120,6 +146,17 @@ static inline struct kvm_pmc *kvm_pmc_idx_to_pmc(struct kvm_pmu *pmu, int idx)
> >>  			continue;				\
> >>  		else						\
> >>  
> >> +/*
> >> + * @mask must be an lvalue of type unsigned long because for_each_set_bit()
> >> + * takes its address.
> >> + *
> >> + * @type is token-pasted into KVM_MAX_NR_##type##_COUNTERS to match one of the
> >> + * counter defines, e.g. GP, FIXED, AMD_GP, INTEL_GP, or INTEL_FIXED. This
> >> + * reflects what KVM supports, not the underlying host's PMU capabilities.
> >> + */
> >> +#define kvm_for_each_set_pmc_idx(i, mask, type)		\
> >> +	for_each_set_bit((i), &(mask), KVM_MAX_NR_##type##_COUNTERS)
> > 
> > 
> > Provide dedciated macros instead of requiring the caller to pass in a type and
> > then doing token pasting, e.g.
> > 
> >   #define kvm_for_each_gp_counter()
> > 
> >   #define kvm_for_each_fixed_counter()
> 
> Do you mean having only two macros, and using
> KVM_MAX_NR_{GP,FIXED}_COUNTERS for Intel, AMD, and the common PMU code?
> 
> That should work, since all_valid_pmc_mask64 is already constrained by
> KVM_MAX_NR_{AMD,INTEL}_{GP,FIXED}_COUNTERS, so iterating up to
> KVM_MAX_NR_{GP,FIXED}_COUNTERS would be safe.

Yep, exactly.

  reply	other threads:[~2026-07-28 23:35 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-07 18:33 [PATCH 00/15] KVM: x86/pmu: Add mediated vPMU PerfMon v5 support Zide Chen
2026-07-07 18:33 ` [PATCH 01/15] KVM: x86/pmu: Remove redundant Perf Global Status MSR bit definitions Zide Chen
2026-07-07 18:33 ` [PATCH 02/15] KVM: x86/pmu: Rename all_valid_pmc_idx to all_valid_pmc_mask Zide Chen
2026-07-28 19:11   ` Sean Christopherson
2026-07-28 19:51     ` Chen, Zide
2026-07-07 18:33 ` [PATCH 03/15] KVM: x86/pmu: Rename reserved_bits to eventsel_rsvd in kvm_pmu Zide Chen
2026-07-07 18:33 ` [PATCH 04/15] KVM: x86/pmu: Add PMC bitmap accessor helpers Zide Chen
2026-07-28 19:28   ` Sean Christopherson
2026-07-28 20:42     ` Chen, Zide
2026-07-28 23:35       ` Sean Christopherson [this message]
2026-07-07 18:33 ` [PATCH 05/15] KVM: x86/pmu: Drop nr_arch_{gp,fixed}_counters from kvm_pmu Zide Chen
2026-07-07 18:33 ` [PATCH 06/15] KVM: x86/pmu: Expose kvm_host_pmu to vendor modules Zide Chen
2026-07-07 18:33 ` [PATCH 07/15] perf/x86: Plumb counter bitmap from x86_pmu to x86_pmu_cap Zide Chen
2026-07-07 18:33 ` [PATCH 08/15] KVM: x86/pmu: Switch to bitmask-based KVM PMU capabilities Zide Chen
2026-07-23 21:47   ` Jim Mattson
2026-07-24 15:15     ` Chen, Zide
2026-07-07 18:33 ` [PATCH 09/15] perf/x86: Remove num_counters_{gp,fixed} from x86_pmu_capability Zide Chen
2026-07-23 21:49   ` Jim Mattson
2026-07-24 15:52     ` Chen, Zide
2026-07-07 18:34 ` [PATCH 10/15] KVM: x86/pmu: Emulate the GLOBAL_STATUS_SET and GLOBAL_INUSE MSRs Zide Chen
2026-07-07 18:34 ` [PATCH 11/15] KVM: x86/pmu: Emulate streamlined Freeze-LBR-on-PMI Zide Chen
2026-07-28 19:33   ` Sean Christopherson
2026-07-28 19:48     ` Chen, Zide
2026-07-07 18:34 ` [PATCH 12/15] KVM: x86/pmu: Populate CPUID.0AH:ECX fixed-counter bitmap Zide Chen
2026-07-07 18:34 ` [PATCH 13/15] KVM: x86/pmu: Ignore AnyThread bit if CPUID.0AH:EDX[15] is not set Zide Chen
2026-07-07 18:34 ` [PATCH 14/15] KVM: x86/pmu: Advertise PerfMon version 5 on Intel hosts Zide Chen
2026-07-23 21:53   ` Jim Mattson
2026-07-23 23:25     ` Chen, Zide
2026-07-24  3:20       ` Jim Mattson
2026-07-24 14:19         ` Chen, Zide
2026-07-07 18:34 ` [PATCH 15/15] KVM: selftests: Support fixed counters bitmap in pmu_counters_test Zide Chen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=amk8v8Vx3KyM5c7D@google.com \
    --to=seanjc@google.com \
    --cc=Manali.Shukla@amd.com \
    --cc=Sandipan.Das@amd.com \
    --cc=dapeng1.mi@linux.intel.com \
    --cc=jmattson@google.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mizhang@google.com \
    --cc=pbonzini@redhat.com \
    --cc=peterz@infradead.org \
    --cc=thomas.falcon@intel.com \
    --cc=xudong.hao@intel.com \
    --cc=zide.chen@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox