From: Xiaoyao Li <xiaoyao.li@intel.com>
To: Sean Christopherson <seanjc@google.com>,
Paolo Bonzini <pbonzini@redhat.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
Rick Edgecombe <rick.p.edgecombe@intel.com>,
Binbin Wu <binbin.wu@linux.intel.com>,
Kai Huang <kai.huang@intel.com>, Yan Zhao <yan.y.zhao@intel.com>
Subject: Re: [PATCH v2 4/8] KVM: VMX: Rename posted interrupt prefixes from "vmx" to "vt"
Date: Thu, 27 Aug 2026 19:38:12 +0800 [thread overview]
Message-ID: <d0d318a4-3f27-40dd-b089-2dd2638e8c53@intel.com> (raw)
In-Reply-To: <20260826171246.777729-5-seanjc@google.com>
On 8/27/2026 1:12 AM, Sean Christopherson wrote:
> Rename all common posted interrupt APIs that use a "vmx" prefix to instead
> use a "vt" prefix to capture that they are used for both VMX and TDX vCPUs.
>
> No functional change intended.
>
> Signed-off-by: Sean Christopherson <seanjc@google.com>
With renaming vmx_needs_pi_wakeup() to vt_needs_pi_wakeup(),
Reviewed-by: Xiaoyao Li <xiaoyao.li@intel.com>
> ---
> arch/x86/kvm/vmx/common.h | 4 ++--
> arch/x86/kvm/vmx/main.c | 4 ++--
> arch/x86/kvm/vmx/posted_intr.c | 18 +++++++++---------
> arch/x86/kvm/vmx/posted_intr.h | 8 ++++----
> arch/x86/kvm/vmx/tdx.c | 6 +++---
> arch/x86/kvm/vmx/vmx.c | 6 +++---
> 6 files changed, 23 insertions(+), 23 deletions(-)
>
> diff --git a/arch/x86/kvm/vmx/common.h b/arch/x86/kvm/vmx/common.h
> index 4b1d46eafd0f..ff4f6a2b6402 100644
> --- a/arch/x86/kvm/vmx/common.h
> +++ b/arch/x86/kvm/vmx/common.h
> @@ -170,8 +170,8 @@ static inline void kvm_vcpu_trigger_posted_interrupt(struct kvm_vcpu *vcpu,
> * Post an interrupt to a vCPU's PIR and trigger the vCPU to process the
> * interrupt if necessary.
> */
> -static inline void __vmx_deliver_posted_interrupt(struct kvm_vcpu *vcpu,
> - struct pi_desc *pi_desc, int vector)
> +static inline void __vt_deliver_posted_interrupt(struct kvm_vcpu *vcpu,
> + struct pi_desc *pi_desc, int vector)
Nit: Maybe we can just name it vt_deliver_posted_interrupt() without
underscore since no collide with vmx_deliver_posted_interrupt() anymore?
But it's OK to keep the underscore to indicate it's an common inner helper.
next prev parent reply other threads:[~2026-08-27 11:38 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-26 17:12 [PATCH v2 0/8] KVM: VMX: Harden against interpreting TDX vCPU as vcpu_vmx Sean Christopherson
2026-08-26 17:12 ` [PATCH v2 1/8] KVM: VMX: Move the shared "IRQs off" exit handler(s) to common code Sean Christopherson
2026-08-27 10:48 ` Xiaoyao Li
2026-08-27 19:34 ` Sean Christopherson
2026-08-26 17:12 ` [PATCH v2 2/8] KVM: VMX: Move the shared NMI handler/trampoline " Sean Christopherson
2026-08-27 11:20 ` Xiaoyao Li
2026-08-26 17:12 ` [PATCH v2 3/8] KVM: VMX: Disallowing using to_vmx() in common VT code Sean Christopherson
2026-08-27 2:32 ` Huang, Kai
2026-08-27 11:21 ` Xiaoyao Li
2026-08-26 17:12 ` [PATCH v2 4/8] KVM: VMX: Rename posted interrupt prefixes from "vmx" to "vt" Sean Christopherson
2026-08-26 17:22 ` sashiko-bot
2026-08-26 18:38 ` Sean Christopherson
2026-08-27 2:35 ` Huang, Kai
2026-08-27 11:38 ` Xiaoyao Li [this message]
2026-08-27 14:17 ` Sean Christopherson
2026-08-26 17:12 ` [PATCH v2 5/8] KVM: VMX: Rename EPT violation handler prefix " Sean Christopherson
2026-08-27 2:36 ` Huang, Kai
2026-08-27 11:48 ` Xiaoyao Li
2026-08-26 17:12 ` [PATCH v2 6/8] KVM: VMX: Use dummy pseudo-overlay struct for to_vt() and vt_to_vcpu() Sean Christopherson
2026-08-27 11:58 ` Xiaoyao Li
2026-08-26 17:12 ` [PATCH v2 7/8] KVM: VMX: Move common VT getters/converters to common.h Sean Christopherson
2026-08-27 12:02 ` Xiaoyao Li
2026-08-26 17:12 ` [PATCH v2 8/8] KVM: VMX: Rename common exit info getters prefixes from "vmx" to "vt" Sean Christopherson
2026-08-27 12:09 ` Xiaoyao Li
2026-08-27 2:53 ` [PATCH v2 0/8] KVM: VMX: Harden against interpreting TDX vCPU as vcpu_vmx Huang, Kai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d0d318a4-3f27-40dd-b089-2dd2638e8c53@intel.com \
--to=xiaoyao.li@intel.com \
--cc=binbin.wu@linux.intel.com \
--cc=kai.huang@intel.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=rick.p.edgecombe@intel.com \
--cc=seanjc@google.com \
--cc=yan.y.zhao@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox