From: Peter Xu <peterx@redhat.com>
To: Marc Zyngier <maz@kernel.org>
Cc: kvm@vger.kernel.org, catalin.marinas@arm.com,
andrew.jones@linux.dev, will@kernel.org, shan.gavin@gmail.com,
bgardon@google.com, dmatlack@google.com, pbonzini@redhat.com,
zhenyzha@redhat.com, shuah@kernel.org,
kvmarm@lists.cs.columbia.edu
Subject: Re: [PATCH 2/6] KVM: Add KVM_CAP_DIRTY_LOG_RING_ORDERED capability and config option
Date: Sat, 24 Sep 2022 09:22:32 -0400 [thread overview]
Message-ID: <Yy8EmMhF+2jcm3m6@x1n> (raw)
In-Reply-To: <87czblhv2a.wl-maz@kernel.org>
On Sat, Sep 24, 2022 at 12:26:53PM +0100, Marc Zyngier wrote:
> On Sat, 24 Sep 2022 09:51:39 +0100,
> Marc Zyngier <maz@kernel.org> wrote:
> >
> > On Fri, 23 Sep 2022 19:26:18 +0100,
> > Peter Xu <peterx@redhat.com> wrote:
> > >
> > > On Fri, Sep 23, 2022 at 03:28:34PM +0100, Marc Zyngier wrote:
> > > > On Thu, 22 Sep 2022 22:48:19 +0100,
> > > > Peter Xu <peterx@redhat.com> wrote:
> > > > >
> > > > > On Thu, Sep 22, 2022 at 06:01:29PM +0100, Marc Zyngier wrote:
> > > > > > In order to differenciate between architectures that require no extra
> > > > > > synchronisation when accessing the dirty ring and those who do,
> > > > > > add a new capability (KVM_CAP_DIRTY_LOG_RING_ORDERED) that identify
> > > > > > the latter sort. TSO architectures can obviously advertise both, while
> > > > > > relaxed architectures most only advertise the ORDERED version.
> > > > > >
> > > > > > Suggested-by: Paolo Bonzini <pbonzini@redhat.com>
> > > > > > Signed-off-by: Marc Zyngier <maz@kernel.org>
> > > > > > ---
> > > > > > include/linux/kvm_dirty_ring.h | 6 +++---
> > > > > > include/uapi/linux/kvm.h | 1 +
> > > > > > virt/kvm/Kconfig | 14 ++++++++++++++
> > > > > > virt/kvm/Makefile.kvm | 2 +-
> > > > > > virt/kvm/kvm_main.c | 11 +++++++++--
> > > > > > 5 files changed, 28 insertions(+), 6 deletions(-)
> > > > > >
> > > > > > diff --git a/include/linux/kvm_dirty_ring.h b/include/linux/kvm_dirty_ring.h
> > > > > > index 906f899813dc..7a0c90ae9a3f 100644
> > > > > > --- a/include/linux/kvm_dirty_ring.h
> > > > > > +++ b/include/linux/kvm_dirty_ring.h
> > > > > > @@ -27,7 +27,7 @@ struct kvm_dirty_ring {
> > > > > > int index;
> > > > > > };
> > > > > >
> > > > > > -#ifndef CONFIG_HAVE_KVM_DIRTY_RING
> > > > > > +#ifndef CONFIG_HAVE_KVM_DIRTY_LOG
> > > > >
> > > > > s/LOG/LOG_RING/ according to the commit message? Or the name seems too
> > > > > generic.
> > > >
> > > > The commit message talks about the capability, while the above is the
> > > > config option. If you find the names inappropriate, feel free to
> > > > suggest alternatives (for all I care, they could be called FOO, BAR
> > > > and BAZ).
> > >
> > > The existing name from David looks better than the new one.. to me.
> >
> > I'm happy to bikeshed, but please spell it out for me. If we follow
> > the current scheme, we need 3 configuration symbols (of which we
> > already have one), and 2 capabilities (of which we already have one).
I hope it's not bikeshedding. I normally don't comment on namings at all
because many of them can be "bikeshedding" to me. But this one is so
special because it directly collides with KVM_GET_DIRTY_LOG, which is other
method of dirty tracking.
> >
> > Do you have any concrete proposal for those?
>
> In order to make some forward progress, I've reworked the series[1]
> with another proposal for those:
>
> Config symbols:
>
> - HAVE_KVM_DIRTY_RING:
> * mostly the same meaning as today
> * not directly selected by any architecture
> * doesn't expose any capability on its own
>
> - HAVE_KVM_DIRTY_RING_TSO:
> * only for strongly ordered architectures
> * selects HAVE_KVM_DIRTY_RING
> * exposes KVM_CAP_DIRTY_LOG_RING
> * selected by x86
>
> - HAVE_KVM_DIRTY_RING_ACQ_REL:
> * selects HAVE_KVM_DIRTY_RING
> * exposes KVM_CAP_DIRTY_LOG_RING_ACQ_REL
> * selected by arm64 and x86
>
> Capabilities:
>
> - KVM_CAP_DIRTY_LOG_RING: the good old x86-specific stuff, advertised
> when HAVE_KVM_DIRTY_RING_TSO is selected
>
> - KVM_CAP_DIRTY_LOG_RING_ACQ_REL: the new acquire/release semantics,
> advertised when HAVE_KVM_DIRTY_RING_ACQ_REL is selected
>
> This significantly reduces the churn and makes things slightly more
> explicit.
This looks good to me, thanks.
--
Peter Xu
_______________________________________________
kvmarm mailing list
kvmarm@lists.cs.columbia.edu
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm
next prev parent reply other threads:[~2022-09-24 13:22 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-09-22 17:01 [PATCH 0/6] KVM: Fix dirty-ring ordering on weakly ordered architectures Marc Zyngier
2022-09-22 17:01 ` [PATCH 1/6] KVM: Use acquire/release semantics when accessing dirty ring GFN state Marc Zyngier
2022-09-22 21:38 ` Peter Xu
2022-09-22 23:46 ` Gavin Shan
2022-09-23 14:40 ` Marc Zyngier
2022-09-23 14:19 ` Marc Zyngier
2022-09-23 14:22 ` Paolo Bonzini
2022-09-22 17:01 ` [PATCH 2/6] KVM: Add KVM_CAP_DIRTY_LOG_RING_ORDERED capability and config option Marc Zyngier
2022-09-22 21:48 ` Peter Xu
2022-09-23 0:04 ` Gavin Shan
2022-09-23 14:28 ` Marc Zyngier
2022-09-23 18:26 ` Peter Xu
2022-09-23 21:23 ` Paolo Bonzini
2022-09-23 22:34 ` Peter Xu
2022-09-24 8:51 ` Marc Zyngier
2022-09-24 11:26 ` Marc Zyngier
2022-09-24 13:22 ` Peter Xu [this message]
2022-09-24 18:57 ` Marc Zyngier
2022-09-25 23:17 ` Gavin Shan
2022-09-22 17:01 ` [PATCH 3/6] KVM: x86: Select CONFIG_HAVE_KVM_DIRTY_RING_ORDERED Marc Zyngier
2022-09-23 22:46 ` Peter Xu
2022-09-24 8:47 ` Marc Zyngier
2022-09-24 13:29 ` Peter Xu
2022-09-22 17:01 ` [PATCH 4/6] KVM: Document weakly ordered architecture requirements for dirty ring Marc Zyngier
2022-09-22 17:01 ` [PATCH 5/6] KVM: selftests: dirty-log: Upgrade dirty_gfn_set_collected() to store-release Marc Zyngier
2022-09-22 21:38 ` Paolo Bonzini
2022-09-23 14:49 ` Marc Zyngier
2022-09-22 17:01 ` [PATCH 6/6] KVM: selftests: dirty-log: Use KVM_CAP_DIRTY_LOG_RING_ORDERED of available Marc Zyngier
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Yy8EmMhF+2jcm3m6@x1n \
--to=peterx@redhat.com \
--cc=andrew.jones@linux.dev \
--cc=bgardon@google.com \
--cc=catalin.marinas@arm.com \
--cc=dmatlack@google.com \
--cc=kvm@vger.kernel.org \
--cc=kvmarm@lists.cs.columbia.edu \
--cc=maz@kernel.org \
--cc=pbonzini@redhat.com \
--cc=shan.gavin@gmail.com \
--cc=shuah@kernel.org \
--cc=will@kernel.org \
--cc=zhenyzha@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox