Linux ACPI
 help / color / mirror / Atom feed
From: Toshi Kani <toshi.kani@hp.com>
To: "Rafael J. Wysocki" <rjw@sisk.pl>
Cc: ACPI Devel Maling List <linux-acpi@vger.kernel.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 0/5] ACPI: acpi_bind_one()/acpi_unbind_one() cleanups
Date: Tue, 06 Aug 2013 15:15:36 -0600	[thread overview]
Message-ID: <1375823736.10300.196.camel@misato.fc.hp.com> (raw)
In-Reply-To: <3015032.qfOqgEVZKP@vostro.rjw.lan>

On Tue, 2013-08-06 at 02:22 +0200, Rafael J. Wysocki wrote:
> Hi All,
> 
> The following 5 patches clean up a little mess in acpi_bind_one() and
> acpi_unbind_one().  They are on top of current linux-next plus the patch
> at https://patchwork.kernel.org/patch/2839101/ .
> 
> [1/5] Move duplicated code from acpi_bind_one()/acpi_unbind_one() to a separate
>       function.

I think the name of acpi_bind_physnode_name() is a bit confusing as if
it would make some persistent binding.  So, I'd suggest to rename it to
acpi_set_physnode_name().

> [2/5] Create symlinks in acpi_bind_one() under physical_node_lock.
> [3/5] Clean up inconsistent use of whitespace in acpi_bind_one()/acpi_unbind_one().
> [4/5] Use list_for_each_entry() to walk the list in acpi_unbind_one().
> [5/5] Clean up the error code path in acpi_unbind_one().

All changes look good.  For the series:

Acked-by: Toshi Kani <toshi.kani@hp.com>

Thanks,
-Toshi


  parent reply	other threads:[~2013-08-06 21:16 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-08-06  0:22 [PATCH 0/5] ACPI: acpi_bind_one()/acpi_unbind_one() cleanups Rafael J. Wysocki
2013-08-06  0:26 ` [PATCH 1/5] ACPI: Reduce acpi_bind_one()/acpi_unbind_one() code duplication Rafael J. Wysocki
2013-08-06  0:26 ` [PATCH 2/5] ACPI: Create symlinks in acpi_bind_one() under physical_node_lock Rafael J. Wysocki
2013-08-06  0:27 ` [PATCH 3/5] ACPI: acpi_bind_one()/acpi_unbind_one() whitespace cleanups Rafael J. Wysocki
2013-08-06  0:28 ` [PATCH 4/5] ACPI: Use list_for_each_entry() in acpi_unbind_one() Rafael J. Wysocki
2013-08-06  0:28 ` [PATCH 5/5] ACPI: Clean up error code path " Rafael J. Wysocki
2013-08-06 21:15 ` Toshi Kani [this message]
2013-08-06 22:29   ` [PATCH 0/5] ACPI: acpi_bind_one()/acpi_unbind_one() cleanups Rafael J. Wysocki
2013-08-06 22:51     ` Toshi Kani
2013-08-07  5:09 ` Yasuaki Ishimatsu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1375823736.10300.196.camel@misato.fc.hp.com \
    --to=toshi.kani@hp.com \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rjw@sisk.pl \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox